38
[GUIDE] How to Enable 1080p YouTube on ALL 1080p ANDROID DEVICES!

  1. Maxximuscool Jelly Bean Aug 15, 2014

    Maxximuscool, Aug 15, 2014 :
    I have proof and I have tested all my devices.
    It is not the OS based issues but it is the application base issue. YouTube application restrict most devices from 1080p and only allowing some. Possibly based on screen size and resolution.

    All latest YouTube App installed:
    1. LG G Pad 8.3 running on 4.4.2
    All video options available to 1080p

    2. Nexus 7 2012 running on 4.4.2
    All video options from 144p, 240p, 360p, 480p, 720p

    3. Galaxy S3 GT-i9300 running on 4.3
    Video options 144p, 240p, 360p, 720p

    4. Nexus 5 running on 4.4.4
    Only up to 720p

    5. Nexus 7 running on 4.4.3
    144p, 240p, 360p, 720p

    6. Nexus 7 running on 4.4.4
    144p, 240p, 360p, 720p

    7. OnePlus One
    Missing 1080p and 480p despite the resolution.
     
    Last edited: Aug 15, 2014

  2. gatenosix KitKat Aug 15, 2014

    gatenosix, Aug 15, 2014 :
    Hopefully, TC will surely deliver. I'll be trying this out later.
     

  3. Maxximuscool Jelly Bean Aug 15, 2014

    Maxximuscool, Aug 15, 2014 :
    It is not based on OS version but more like YouTube App is being very discrete with screen resolution or software filtering based on screen size database which Google restricted these devices to see 1080p. My guess it is being test by Google, experimenting or some sort.
     

  4. SolarTrans Ice Cream Sandwich Aug 15, 2014

    SolarTrans, Aug 15, 2014 :
    Well of course you're not gonna get 1080p if you're on a lower than 1080p device. I stated this in the OP: this isn't a way to get 1080p YouTube running on non-1080p devices.

    Also, I'm not sure what you're trying to prove, but your testing proves my point perfectly.
    The only thing that gets 1080p out of your test devices is the G Pad, and it's the only thing on 4.4.2 (the Nexus 7 2012 is also on 4.4.2, but it has a sub-1080p screen anyways so it wouldn't get 1080p).
    You say the OPO doesn't get it, but you're on 4.4.3/4.4.4, and according to my original claim that wouldn't work.

    Also, if what you're saying is true, why would this fix work for so many people? Yes, the YouTube app pays attention to the screen resolution, but if you're on a 1080p+ device the YouTube app must think you're on 4.4.2 or L for you to get the 1080p and 480p options.
     

  5. SolarTrans Ice Cream Sandwich Aug 15, 2014

    SolarTrans, Aug 15, 2014 :
    My testing was done on an HTC M8 Developer Edition, HTC M8 Google Play Edition, Sony Z Ultra GPE, OnePlus One, and Nexus 5 (all 1080p devices, mind you)
    I tested all available versions from 4.4 onward on each of these, and
    on every single device, they only received the 480p+1080p options while on 4.4.2 KitKat. Not 4.4, 4.4.3 or 4.4.4 (except for the Nexus 5, where 1080p worked on Android L as well as 4.4.2).
    Also, after doing this testing, I put each device on 4.4.3, tried my fix, and it worked. Then, I updated each device to 4.4.4 (each one with a 4.4.4 update available), tried my fix, and it still worked.
     

  6. pjs312 Ice Cream Sandwich Aug 15, 2014

    pjs312, Aug 15, 2014 :
    Keep in mind that:
    1. 4.4.2 and L are the only ones that will get 480p/1080p+ resolutions.
    2. The Nexus 7 2012 and Galaxy S3 are not 1080p, so of course they won't get 1080p.
    3. The HTC One M7 is the same size as the Galaxy S3 and it gets the 480p and 1080p options.
     

    SolarTrans likes this.
  7. OW3N111 Jelly Bean Aug 15, 2014

    OW3N111, Aug 15, 2014 :
    I had done it all jus rebooted my phone started working, weird.. Thanks though =)
     

    gmo8492 likes this.
  8. Aelfassy Donut Aug 15, 2014

    Aelfassy, Aug 15, 2014 :
    Works like a charm! Also when using 480p or 1080p google uses a different renderer that doesn't drop as many frames and provides much smoother playback. That's more important than just the resolution increases.
     

    SolarTrans likes this.
  9. SolarTrans Ice Cream Sandwich Aug 16, 2014

    SolarTrans, Aug 16, 2014 :
    I didn't realize that. Thanks for mentioning it! Yet another reason to enable 1080p ;)
     

  10. pjs312 Ice Cream Sandwich Aug 16, 2014

    pjs312, Aug 16, 2014 :
    It might be related to the DASH that YouTube uses on 480p and 1080p+ resolutions.
     

    SolarTrans likes this.
  11. joshst85 Eclair Aug 16, 2014


  12. SolarTrans Ice Cream Sandwich Aug 16, 2014

    SolarTrans, Aug 16, 2014 :
    Well if you're interested, it's quite easy to add! The modding community for the OPO is huge.
     

  13. Walkin_mn Jelly Bean Aug 16, 2014


  14. SolarTrans Ice Cream Sandwich Aug 17, 2014

    SolarTrans, Aug 17, 2014 :
    After seeing so many people complain about losing 1080p with the update, I kinda feel like this should get a sticky (at least temporarily, or maybe an announcement about it).
    What do you think @Adam Krisko?
     

  15. ChrisA4 Donut Aug 17, 2014

    ChrisA4, Aug 17, 2014 :
    After the update I also can't watch 1080p anymore. But the worst thing now is, that the videos are not smooth anymore. Every few seconds (circa 10) there's a little stop in the video. This happens on all resolutions. When I use chrome all videos ate running smooth.

    I think Google changed the renderer/decoder.
     

  16. penndavid Honeycomb Aug 17, 2014

    penndavid, Aug 17, 2014 :
    I wouldn't have updated my one if I knew I would lost 1080p :/ I use youtube a lot and that's very disappointing.
     

  17. swaneon Cupcake Aug 17, 2014


  18. SolarTrans Ice Cream Sandwich Aug 17, 2014

    SolarTrans, Aug 17, 2014 :
    Yeah it's silly Google disabled/didn't enable it. I'm glad I was able to figure it out though, it was driving me insane XD
     

  19. Technoboy Froyo Aug 22, 2014

    Technoboy, Aug 22, 2014 :
    I thought I was the only one that had the problem. I tested the same video on my LG G2 and on my 1 + 1 and I could not get 1080p on 1 + 1. G2 has 4.4.2 while 1 + 1 has 4.4.4.

    This is not cool.
     

  20. VincentoTheGamer Cupcake Aug 22, 2014

    VincentoTheGamer, Aug 22, 2014 :
    Ive got a LG G2 running 4.4.2 , and out of no-where i suddenly cant watch in 480p and 1080p, like if i was running 4.4.4?
     

    csosa1978 likes this.