13
Guide: How to flash COS 13

  1. aijazuddin.sk
    Froyo Apr 9, 2016

    aijazuddin.sk , Apr 9, 2016 :
    Lets start with identifying where you stand now -

    a. You are on yog7das2k1/lower and on stock recovery.
    b. You are on yog7das2k1/lower but with TWRP
    c. You are on OxygenOS
    d. You are on cm13.

    For scenario (a), if on a build lower than yog7das2k1, download incremental update of yog7das2k1 and update to this build first. If already on yog7das2k1, download the incremental zip to znh0eas26m from step 1, boot to cyanogen recovery and flash it.

    For the remaining scenarios, since full zip (twrp or fastboot) is not available, you'll have to flash yog7das2k1 with stock recovery and system, and then update from cyanogen recovery (or maybe system updater if you can see update available).

    Note: I tried flashing stock recovery directly, and tried updating from it, but if you have supersu flashed or xposed flashed, it throws an error and prevents you from updating.

    Here we go -

    1. Download incremental update of Marshmallow znh0eas26m on your phone from - http://builds.cyngn.com/incremental/bacon/cm-bacon-cee4e8702d-to-e36dd78050-signed.zip
    2. Reboot phone to recovery and make a full nandriod backup. After backup, reboot your phone into fastboot mode.
    3. Download fastboot image of yog7das2k1 on your laptop from - http://builds.cyngn.com/factory/bacon/cm-12.1-YOG7DAS2K1-bacon-signed-fastboot-bed37f2e18.zip
    4. Connect your phone to laptop while in fastboot mode and flash above image. (instructions and commands - http://www.ibtimes.co.uk/oneplus-on...-12-1-ota-update-how-install-manually-1517108). Essentially this is to revert to stock recovery and system partition. Remember, DO NOT FLASH USERDATA - it will wipe your entire internal storage.
    5. Once flashed, boot into recovery once again, which is cyanogen recovery this time, and select update option, choose zip file downloaded in step1.
    6. Once updated to latest increment, you can boot your phone in fast-boot once again, and flash TWRP recovery through fastboot.
    7. After flashing TWRP, boot into recovery (TWRP again). Restore only data from backup created in step2.
    8. Reboot and let phone boot up.

    This worked for me! I am now on Marshmallow with all my data intact (but I lost superuser and xposed) - no bootloops or errors.

    Note: I did not flash supersu zip or xposed framework yet - not sure if that will result in a bootloop. If you end up in a bootloop anyhow, you can wipe system/data, and restore complete backup made in step2.
     
    Last edited: Apr 9, 2016

    #1
  2. lolrepeatlol
    Jelly Bean Apr 9, 2016

  3. kryshnakishore
    Ice Cream Sandwich Apr 9, 2016


    #3
    lolreppeatlol likes this.
  4. Anonymous B-)
    Gingerbread Apr 9, 2016


    #4
  5. blueq
    Honeycomb Apr 9, 2016


    #5
    johnkops likes this.
  6. gianmarcorev
    Eclair Apr 9, 2016


    #6
    aijazuddin.sk likes this.
  7. JosePProenca
    Donut Apr 9, 2016

    JosePProenca , Apr 9, 2016 :
    This might not be de ideal thread to ask this, but you've mentioned b. You are on yog7das2k1/lower but with TWRP and that is my case. However I've not rooted the one, so can I wait for the ota and install it that way, or do I have to do it manually and follow your steps?
     
    Last edited: Apr 9, 2016

    #7
  8. LexTertia
    Froyo Apr 9, 2016

    LexTertia , Apr 9, 2016 :
    with SuperSU

    This one can be made a lot easier (at least it worked for me).

    1. Enable Update recovery in your phone settings
    2. Open SuperSU select complete unroot
    3. Get signed flashable cm-12.1-YOG7DAS2K1
    4. Flash it with TWRP (since you have update recovery enabled, TWRP will be replaced with stock on next reboot)
    5. Get Incremantal Marshmallow
    6. Flash it via update in stock recovery
     

    #8
  9. aijazuddin.sk
    Froyo Apr 9, 2016

    aijazuddin.sk , Apr 9, 2016 :
    I agree, this sounds more convenient. I had xposed framework installed too, although that too can be removed flashing a zip through recovery.
     

    #9
  10. bithal
    Froyo Apr 9, 2016

    bithal , Apr 9, 2016 :
    Want help for rooting my phone. I have been on stock since I bought opo but what to root my device after I update it to cm12. I have been staying away from rooting because as far as I know you will loose all data if you root and unlock bootloader. So is there any way around it? i.e root without loosing data.
     

    #10
  11. aijazuddin.sk
    Froyo Apr 9, 2016

    aijazuddin.sk , Apr 9, 2016 :
    I know, in past I have run into trouble doing this. But since this is an incremental update, meant to be flashed on an OS I was already on, this shouldn't be an issue. Although for someone coming from OOS or CM13, I wonder if this may cause problems. Fingers crossed!
     

    #11
  12. nikifu
    Honeycomb Apr 9, 2016

    nikifu , Apr 9, 2016 :
    After flashing the cos13 zip via stock recovery my phone is now stuck in bootloop, great -.-
     

    #12
  13. gianmarcorev
    Eclair Apr 9, 2016

    gianmarcorev , Apr 9, 2016 :
    Well this is very likely going to cause problems to those coming from cm13 nightlies. You should update your post, don't tell people to do something if you have to be "finger crossed" about it
     

    #13
  14. gianmarcorev
    Eclair Apr 9, 2016

    gianmarcorev , Apr 9, 2016 :
    If you followed the guide, try to wipe data
     

    #14
  15. gianmarcorev
    Eclair Apr 9, 2016

    gianmarcorev , Apr 9, 2016 :
    Moreover, the update process itself doesn't wipe data partition, so restoring it is an unnecessary step. Instead, you should manually wipe data when you switch from a nightly to a release
     

    #15
  16. HenriH
    Gingerbread Apr 10, 2016

    HenriH , Apr 10, 2016 :
    Is it really necessary to fastboot flash all files (except Userdata) in the zip? Won't just flashing recovery.img do the trick to go back to stock-recovery?
     
    Last edited: Apr 11, 2016

    #16
  17. anku.ani
    Cupcake Apr 11, 2016

    anku.ani , Apr 11, 2016 :
    Did some one tried this method???


    QUOTE="aijazuddin.sk, post: 14721829, member: 551481"]I agree, this sounds more convenient. I had xposed framework installed too, although that too can be removed flashing a zip through recovery.[/QUOTE]
    Did
     

    #17
  18. PauwelD
    Eclair Apr 12, 2016

    PauwelD , Apr 12, 2016 :
    Is it a problem if you have Xposed framework installed?
     

    #18
  19. HenriH
    Gingerbread Apr 12, 2016


    #19
  20. ferozgandhi007
    Honeycomb Apr 13, 2016

    ferozgandhi007 , Apr 13, 2016 :
    Should it be a clean flash or dirty ? Im on cm-12.1-YOG7DAS2K1 with TWRP...

    I did follow the above steps (dirty flashed cm-12.1-YOG7DAS2K1 on cm-12.1-YOG7DAS2K1) but it is still TWRP ...

    What am I missing ?
     

    #20
    cosmic likes this.