[GUIDE] How to Unroot your OnePlus 3 / 3T and go back completely to stock

  1. CsRohit Froyo Mar 29, 2017

    CsRohit, Mar 29, 2017 :
    You don't need oxygen recovery once you flash or sideload the ota file it automatically flashes the stock recovery. That's why we lose root after ota ypgrade

  2. Talnoy Donut Mar 29, 2017

    Talnoy, Mar 29, 2017 :
    Followed these instructions to the letter and at 45% flashing the ota it stops, and says 'installation failed'

    I'm so confused. Halp?

  3. idanzairi302 Cupcake Mar 29, 2017

  4. JorgeManuelSilva91 Ice Cream Sandwich Mar 29, 2017

    JorgeManuelSilva91, Mar 29, 2017 :
    YOU NEED TO FLASH RECOVERY. Don't act like a fool. Follow the guide.

    Read the following posts and reinstall/fix ADB:

    If failure still persists, contact OnePlus support via Live Chat at: https://OnePlus.net/support

    mithunkr, sangriaman and calvinistmac like this.
  5. sangriaman Cupcake Apr 1, 2017

    JorgeManuelSilva91 likes this.
  6. JorgeManuelSilva91 Ice Cream Sandwich Apr 1, 2017

    JorgeManuelSilva91, Apr 1, 2017 :
    By the way, it might be important to add a step in the guide where the user sideloads OxygenOS (on the stock recovery) before locking bootloader, this is important to check if sideloads work. And if it fails and user cannot fix, bootloader is still unlocked, so one can flash TWRP and get back to a working daily driver albeit unlocked.

    calvinistmac likes this.
  7. Phil403 Cupcake Apr 1, 2017

    Phil403, Apr 1, 2017 :
    Oxygen OS has perks that its not that bad (like Samsung Overlay f.ex.) so you dont need to root it ^^

  8. G_지영재_bkhI Cupcake Apr 1, 2017

    G_지영재_bkhI, Apr 1, 2017 :
    I have a problem with this update.
    I can't update my OP3 from beta12 to beta 13.
    It's not rooted.

    I got update OTA notification, so I tried to update it.
    It ended up being in a recovery mode.

    I thought that it's weird so I went into setting and update menu.
    Now I see full version of beta 13 update 1.4G

    I went for it and again, it ended up in a recovery mode.

    So I tried and choose the file downloaded in the phone storage.
    I found the 1.4G full update image and clicked it.

    and it just says 'Failed to update'

    What am I missing?
    Would adb update work for me?
    I don't want to wipe all my data and reset my phone with beta 13

    Thank you!

  9. ayumicn Cupcake Apr 7, 2017

  10. JorgeManuelSilva91 Ice Cream Sandwich Apr 9, 2017

    JorgeManuelSilva91, Apr 9, 2017 :
    Contact OnePlus support, the issue you're facing is unrelated to this guide.

  11. vincentbeck Cupcake Apr 16, 2017

  12. calvinistmac Jelly Bean Apr 18, 2017

    calvinistmac, Apr 18, 2017 :
    Did you follow ALL the instructions in the original post? If you did you should be fine. Check and make sure you're running the latest SDK tools from Google and try again.

  13. JorgeManuelSilva91 Ice Cream Sandwich Apr 18, 2017

    JorgeManuelSilva91, Apr 18, 2017 :
    Hmm.. As far as I know, ADB on Linux may require root to be able to access the phone correctly.

    This might help:

  14. Traviz Vu Froyo Apr 19, 2017

    Traviz Vu, Apr 19, 2017 :
    Thank you. Rooting and unlocking the bootloader was bugging and laggy this helped a lot. God bless you and have a good day

  15. rfmarves Donut Apr 20, 2017

    rfmarves, Apr 20, 2017 :
    Not in the spirit of asking for the video (already followed the written instructions successfully and didn't need to be pressing a pause button:)) But I would recommend OBS Studio to record tutorials. It's free, open source, plug-in expandable and supports doing screen casts and mixing the screen cast with camera inputs.

  16. white43 Eclair Apr 20, 2017

    white43, Apr 20, 2017 :
    For the benefit of anyone else who might be struggling.
    I had Beta 5 installed with TWRP and wanted to get back to stock.

    Firstly, I had a dm-verity error. This was resolved by following the "If you get dm-verity error" in post here:

    From page #29 of this thread (post 570), I downloaded and installed the 'Nice set of ADB drivers'. I installed system wide. I also followed the link to get the tool to make adb.exe large address aware.

    *I didn't follow the links to get 'latest adb/fastboot tools'. (When I did use these, it generated an adb error)* - so skip this if you get an adb crash.

    I then HAD to use the tool to make adb.exe LARGE ADDRESS AWARE(see the same post above). Otherwise I got error that it couldn't read ota.zip.

    I then opened command prompt at C:\adb and copied in the ota.zip

    After this, followed the guide without issue - flashed to stock OOS 4.1.3 - bootloader locked, happy days!

    JorgeManuelSilva91 likes this.
  17. JorgeManuelSilva91 Ice Cream Sandwich Apr 20, 2017

    JorgeManuelSilva91, Apr 20, 2017 :
    Thanks for your input. Unfortunately Google has done a mess up on the latest March 2017 versions of ADB tools, while Dec 16th 2016 versions are also known to work (I've mirrored them).

  18. appumohan Cupcake Apr 27, 2017

    appumohan, Apr 27, 2017 :
    Hii.. I am in aex rom now with render kernel. My question is can i flash the 4.1.3 full zip without locking bootloader ? When i tried the same i got an error in 47%.

    Another doubt is as i am on a custom kernel do i need to flash another kernel for OOS or just flash the Stock Rom ??

  19. Sun90 Lollipop Apr 27, 2017

    Sun90, Apr 27, 2017 :
    You can just flash the stock ROM as long as the kernel supports it.

    appumohan likes this.
  20. appumohan Cupcake Apr 27, 2017

    appumohan, Apr 27, 2017 :
    i am using render kernel LOS version. Do i need to install kernel for OOS or just flash the Rom ??