[GUIDE] How to Unroot your OnePlus 3 / 3T and go back completely to stock

  1. G_EVR Honeycomb Dec 2, 2017

    G_EVR, Dec 2, 2017 :
    Hey guys,

    I have stock OOS 5.0 with Magisk Beta v14.5 installed and I am trying to get back to full stock and relock the bootloader.

    Every time I get to step 7 of the tutorial, where I flash stock recovery, the command prompt yields OKAY results but the phone stays stuck in the OnePlus bootlogo screen. I am forced to reflash TWRP recovery to get back into system.

    Have redownloaded the stock recovery file multiple times and ADB drivers are working fine.

    I need your help. Thanks.

    G_Brian_Wilmot_kTDj likes this.
  2. calvinistmac Jelly Bean Dec 2, 2017

    calvinistmac, Dec 2, 2017 :
    If it's not working you didn't do something right. Detail out for me exactly what you did.

    G_Brian_Wilmot_kTDj and G_EVR like this.
  3. G_EVR Honeycomb Dec 3, 2017

    G_EVR, Dec 3, 2017 :
    Thank you for your reply.

    I ended up going about it a different way because, even following your instructions to the letter, stock recovery just didn't want to flash. I used this tutorial here and that worked for me:


    Post #2085.

    Thank you for your expedient reply on this. Really appreciate it.

    G_Brian_Wilmot_kTDj likes this.
  4. calvinistmac Jelly Bean Dec 3, 2017

    calvinistmac, Dec 3, 2017 :
    I'm glad that worked for you. Sorry my method fouled up the recovery. It's odd because the other day I went from a custom 7.1.2 rom to OOS Oreo (the stable one) with my method and it worked just fine. Seems that every phone is different.

    I was glad I had a moment to respond quick. That doesn't always happen. Have a good one!

    G_EVR likes this.
  5. ojm94 Cupcake Dec 10, 2017

    ojm94, Dec 10, 2017 :
    Where do GApps and firmware play into this?

    Do I need to flash new firmware before doing this? I am currently on microG LineageOS build using whatever the most recent Nougat firmware beta is. I want to upgrade to 5.0 Oreo stable build, with stock everything and locked bootloader.

    I would like Play services to be working on the device, is that included with the stock ROM image or does it need to be flashed separately? If so, when? During this process? Or after?
    Last edited: Dec 10, 2017

  6. calvinistmac Jelly Bean Dec 10, 2017

    calvinistmac, Dec 10, 2017 :
    Oh for crying out loud! Did you actually read what I wrote in the first post? If any of the above stuff you mentioned was necessary I would've put it there.

    Everything you need is there in the first post, and everything you need software-wise is included with every release of OxygenOS, including Oreo.

    Please next time read more carefully.

  7. calvinistmac Jelly Bean Dec 10, 2017

    calvinistmac, Dec 10, 2017 :
    UPDATE: I have updated the guide to version 4.0.1.

    The reason is I added another piece of information as well as bumped up the Open Beta version numbers.

    Happy unrooting!

  8. monjur_miah Gingerbread Dec 10, 2017

    monjur_miah, Dec 10, 2017 :
    Hi, i knw this a noob question but how would i install the drivers required to unroot? Thanks.

  9. monjur_miah Gingerbread Dec 10, 2017

  10. calvinistmac Jelly Bean Dec 10, 2017

  11. monjur_miah Gingerbread Dec 11, 2017

  12. calvinistmac Jelly Bean Dec 12, 2017

    calvinistmac, Dec 12, 2017 :
    It's probably a driver issue. Go to your device manager and make sure fastboot is showing up in the device manager. If not you'll need to reinstall the drivers. This does happen on occasion.

  13. badounee Cupcake Dec 17, 2017

    calvinistmac likes this.
  14. Prem Kumar P Cupcake Dec 17, 2017

    Prem Kumar P, Dec 17, 2017 :
    I have done till the step 6. after that when i try to select recovery mode, its not going in recovery mode. and stuck in android log.
    what is the problem???

  15. DekmenCZ Gingerbread Dec 18, 2017

    calvinistmac likes this.
  16. calvinistmac Jelly Bean Dec 18, 2017

    calvinistmac, Dec 18, 2017 :
    I honestly have no idea here. I'm not in front of your phone so I cannot diagnose your issue. If you followed my steps to the letter you should be sailing smoothly.

  17. oneplustimo Cupcake Dec 20, 2017

    calvinistmac likes this.
  18. Prem Kumar P Cupcake Dec 23, 2017

    Prem Kumar P, Dec 23, 2017 :
    i tried again and its not working,
    I took my mobile to a service centre and they told if the system is rooted then there is a risk of hardware issue if original version is installed.
    They are not using adb or fastboot to do the recovery.
    What should i do?? should i ask then to do the recovery on my risk, will there be any issue??

  19. castaway Froyo Dec 27, 2017

  20. calvinistmac Jelly Bean Dec 27, 2017

    calvinistmac, Dec 27, 2017 :
    If it hasn't moved start the process over.