203
[GUIDE] How to Unroot your OnePlus 3 / 3T and go back completely to stock

  1. calvinistmac Jelly Bean Dec 30, 2017


  2. theshinybeast Lollipop Jan 3, 2018

    theshinybeast, Jan 3, 2018 :
    Just used this after a test encrypted me, couldn't mount data in TWRP:confused: Thanks for this comes in very handy.;)
     

    BeingIncog likes this.
  3. calvinistmac Jelly Bean Jan 3, 2018

    calvinistmac, Jan 3, 2018 :
    Hey man! I'm glad it helped! Hope all is well!
     

    theshinybeast and BeingIncog like this.
  4. theshinybeast Lollipop Jan 3, 2018

    theshinybeast, Jan 3, 2018 :
    Oh yeah, not a problem, more of a hassle than anything. ;)
     

  5. Pytajnik Honeycomb Jan 5, 2018


  6. calvinistmac Jelly Bean Jan 5, 2018

    calvinistmac, Jan 5, 2018 :
    You might need to use the unbrick tool then to get completely back to stock.
     

  7. Mullafabz Froyo Jan 8, 2018

    Mullafabz, Jan 8, 2018 :
    Hey guys,i am trying to re-lock the bootloader of my 3t and i get the message saying that Flashing lock is not allowed.Can anyone help.Tried all the different options available on the forum and youtube and nothing.
     

  8. calvinistmac Jelly Bean Jan 8, 2018

    calvinistmac, Jan 8, 2018 :
    Boot back into android and make sure OEM Unlock is turned on. Having that off can do this.
     

  9. Mullafabz Froyo Jan 8, 2018


  10. laupuy Gingerbread Jan 8, 2018

    laupuy, Jan 8, 2018 :
    Hmm, don't know. Reflash your rom, something wrong.
     

  11. calvinistmac Jelly Bean Jan 8, 2018

    calvinistmac, Jan 8, 2018 :
    If you have the 3 (not sure where the 3T one is) use the unbricking tool (there's a forum post stickied). Get your phone back to absolute bone stock that way. Make sure you follow the instructions to a T.
     

  12. Mullafabz Froyo Jan 9, 2018

    Mullafabz, Jan 9, 2018 :
    Managed to lock it back again.Kept flashing between the Magisk.zip and the stock recovery and it worked finally.Installed the 5.1 update and unlocked it back again.
     

  13. calvinistmac Jelly Bean Jan 9, 2018


  14. rodeojones000 Cupcake Jan 14, 2018

    Last edited: Jan 15, 2018

  15. calvinistmac Jelly Bean Jan 15, 2018

    calvinistmac, Jan 15, 2018 :
    Sorry I didn't get back to you right away. My wife and I just had a new baby over the weekend so things have been a bit haphazard. I'm glad you figured something out!
     

  16. Mike8983 Cupcake Jan 21, 2018

    Mike8983, Jan 21, 2018 :
    I had the SuperSU installed on my oneplus3t once i unsintalled it and that unrooted my phone how do I lock the bootloader and OEM lock again ? I did follow your post also but failed when I got to the part where it was telling me to install from adb had about 42% transfered. Knowing me it's probably because I already unrooted via SuperSU and was already on the latest update and also I'm knew to the oneplus3t
     

  17. calvinistmac Jelly Bean Jan 21, 2018

    calvinistmac, Jan 21, 2018 :
    From what I'm reading you didn't follow any of my steps at all or didn't read carefully. Try again.
     

  18. Ramesh758 Cupcake Jan 24, 2018

    Ramesh758, Jan 24, 2018 :
    I have twrp recovery. When is flash stock recovery from fastboot. Its stuck on oneplus logo when i go to recovery.


    Plz help..
     

  19. Bharadwaj K Honeycomb Jan 24, 2018

    Bharadwaj K, Jan 24, 2018 :
    let me know the process you have used?

    sometimes it takes bit longer than expected but not on OnePlus logo. might be in bootloop.

    try to use OnePlus 3T unbrick tool to get into stock version.
     

  20. Ramesh758 Cupcake Jan 24, 2018

    Ramesh758, Jan 24, 2018 :
    Bro . I have oneplus 3. I have installed freedom os on phone. But now i want to go on stock os. As guide on first page i download stock recovery and latest oxyzen os file around 1.5 gb.
    As per guide i fast boot device via pc. The serial no. Shows.
    Next step i flash stock recovery its also done
    But when i go to recovery mode phone stuck on oneplus logo. Doesnot go to recoverymode even after 20 minutes wait.

    Plzz help
     
    Last edited: Jan 24, 2018