171

[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 3

  1. Alias123in Cupcake Aug 19, 2017

    Alias123in, Aug 19, 2017 :
    Hi Naman
    see below Output of "fastboot oem device-info" of my oneplus 3
    is it ok for warranty purpose.can i take my cell to service center for repair as i was using custom rom before.
    C:\Users\Abidjan Office 3\Downloads\platform-tools-latest-windows\platform-tools>fastboot oem device-info
    ...
    (bootloader) Device tampered: false
    (bootloader) Device unlocked: false
    (bootloader) Device critical unlocked: false
    (bootloader) Charger screen enabled: false
    (bootloader) Display panel:
    (bootloader) Have console: false
    (bootloader) Selinux type: <none>
    (bootloader) Boot_mode: normal
    (bootloader) Kmemleak_detect: false
    (bootloader) force_training: false
    OKAY [ 0.125s]
    finished. total time: 0.125s










     

  2. saiyarra Cupcake Aug 25, 2017

    saiyarra, Aug 25, 2017 :
    Same problem...got any solution..??
     

  3. saiyarra Cupcake Aug 25, 2017

    saiyarra, Aug 25, 2017 :
     

  4. saiyarra Cupcake Aug 25, 2017

    saiyarra, Aug 25, 2017 :
    same problem....md5 checksum error what to do...??
     

  5. F_Pratheesh_Tk_ivoL Cupcake Aug 25, 2017


  6. saiyarra Cupcake Aug 25, 2017

    saiyarra, Aug 25, 2017 :
    thank you so soo sooooo much sir....u just saved me...
    for those struck in md5 checksum error try step 2 it has different tool(full)
     

  7. sunnysran Eclair Aug 27, 2017

    sunnysran, Aug 27, 2017 :
    I finally managed to revive my OnePlus 3 today, after almost 20 days of bricking it. I followed the method two outlined in the original post.

    Lessons learned are:
    1. All files have to be located in C: drive for it to work.
    2. You don't need to put your PC in test mode to successfully install drivers if you are not using Windows 8 and above.
    Just use the second option (says something like install drivers anyway...) in the security warning dialog and you are good to go, if you are on a system running Windows below version 8.
    3. If you get Sahara communication or Firehouse errors, change a USB port first. If that doesn't work, try a different machine.

    I borrowed my friend's laptop running Windows 7 64-bit to revive my phone.
    The process hardly took ten minutes when everything was right.

    I was even able to install the OTA update after reviving my phone. I am running OOS 4.1.7 at the moment.

    When I started, the phone did not respond to any button, no light when connected to charger.
    Thank you @Naman Bhalla!
    Cheers!
     

  8. Libio Eclair Aug 28, 2017

    Libio, Aug 28, 2017 :
    This is a life saver thread. I was able to put life into a water damaged OP3 which was initially dead and then into a bootloop after some cleaning and wiping. The only issue I am facing is that WiFi doesn't detect any network. I searched and couldn't find a relevant thread or fix. Guide me if possible. Thnx
     

  9. Libio Eclair Aug 29, 2017

    Libio, Aug 29, 2017 :
    Unfortunately the phone again went into bootloop when tried to upgrade via OTA after using method 2. Also tried sideloading the full zip. The sideload was successful but the phone again went to bootloop and is now completely dead. Doesn't even vibrate on holding the power button. [e]1f623[/e]
     

  10. Mlabu Cupcake Sep 7, 2017

    Mlabu, Sep 7, 2017 :
    Hi everyone, I really need some help to get my OP3 live. Its been almost a week, my OP3 is not charging and there is no light. I read all the posts about this issue and i'm trying to unbrick it.i followed the method 1, but when i run the Msmdownload tool it showing me "firehose checkeRSP failed, Error: 258" message. What is next?
    Please HELP!!!!
     

  11. G_Flávia_Torezani_pZhC Cupcake Oct 3, 2017

    G_Flávia_Torezani_pZhC, Oct 3, 2017 :
    Hi Naman,
    When I start MsmTool, at first it shows "NO. 6 - COM Device" and then it turns to "no devide - Sahara Communication Failed".
    Is there anything else I can try?

    Thanks,
    Alm.

    dynamic_nvbk.bin: OK
    emmc_appsboot.mbn: OK
    gpt_backup0.bin: OK
    gpt_main0.bin: OK
    userdata.img: FAILED open or read
    rawprogram0.xml: FAILED
    NON-HLOS.bin: OK
    rpm.mbn: OK
    static_nvbk.bin: OK
    tz.mbn: OK
    boot.img: FAILED open or read
    cache.img: FAILED open or read
    persist.img: OK
    recovery.img: OK
    system.img: FAILED open or read
     

  12. nzu.islam Cupcake Oct 7, 2017

    nzu.islam, Oct 7, 2017 :
    Every time i reset my OP5 it gets stuck in boot loop on first boot but starts normally if i restart. Can you please explain what might be the problem?
     

  13. rishig Cupcake Oct 8, 2017


  14. MotasemBT Eclair Oct 18, 2017

    MotasemBT, Oct 18, 2017 :
    u saved my life , my work , my everything ,
    thanks from the bottom of my heart .
     

  15. francesco.pascolini Jelly Bean Oct 18, 2017


  16. AlexBurnout Froyo Oct 19, 2017

    AlexBurnout, Oct 19, 2017 :
    It's an amazing thing to see the advancements in this industry. Thanks.
     

  17. Swiftone Cupcake Oct 20, 2017


  18. kartikyv Eclair Oct 22, 2017

    kartikyv, Oct 22, 2017 :
    thanks a lot for the guide, got my op3 back to life using method 2, method 1 didn't work for me...
     

  19. ShadowJackpot Cupcake Oct 22, 2017

    Last edited: Oct 23, 2017

  20. BlackIce21 Cupcake Oct 26, 2017

    BlackIce21, Oct 26, 2017 :
    I'm trying both methods and installed the Qualcomm drivers but I just can't seem to get it to stay connected to the PC. Every time I plug it in and go to MSM it shows up as COM device connected in the tool and device manager but doesn't stay connected. It appears in the device manager for a second or two and gets disconnected automatically. I've tried with two different PCs and different USB cables but it just doesn't stay connected long enough. Any ideas? Thanks.