173
[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 3

  1. Jitesh Saitawadekar
    KitKat Jul 14, 2016

    Jitesh Saitawadekar , Jul 14, 2016 :
    Cz the driver isn't properly installed thats the reason it is not detected by Msm tool...that yellow triangle shows that driver isn't installed properly just manually install it. Just make sure you install in this method
    1.) Make sure driver signature enforcement is disabled.
    2.) Try these drivers,one of them might work too :-
    https://www.androidfilehost.com/?fid=24052804347799753
    https://www.androidfilehost.com/?fid=24269982086990168
    https://www.androidfilehost.com/?fid=24349802275800175
    https://www.androidfilehost.com/?fid=24349802275800173
    https://www.androidfilehost.com/?fid=24349802275800171
    3.)
    • Download this :- http://www.mediafire.com/download/4aqwyi3g1d6wc67/Qualcomm 1.00.11.rar
    • Keep phone disconnected from PC.
    • Open the folder "qc" and install the Test Certificate in the following Stores: Trusted Root, Trusted Publisher, Third-Party Root and Personal
    • Run the Qualcomm setup wizard (also located in the qc folder)
    • When completed, restart your PC again with Driver Signature Disabled. (Optional but preferred)
    • The driver should now automatically install. If not, go to device manager and right click "Unknown Device" and click "Update Driver" Search up the QC folder and press ok. The driver should now install.
     

    #41
    Naman Bhalla likes this.
  2. martinusbe
    Recognized developer Recognized Developer Jul 14, 2016

    martinusbe , Jul 14, 2016 :
    Yeah but fixed it myself
    Had no choice, since i'm the closest thing OnePlus has as a service center in Belgium ;)
     

    #42
    Naman Bhalla likes this.
  3. Naman Bhalla
    Recognized developer Recognized Developer Jul 14, 2016


    #43
    Jitesh Saitawadekar likes this.
  4. ch0p5t1ckb01
    Donut Jul 14, 2016

    ch0p5t1ckb01 , Jul 14, 2016 :
    Thanks @Jitesh Saitawadekar @Naman Bhalla ! I thought Signature Verification was disabled but it wasn't so I re-disabled it again and this time I got a "download complete" message from the Tool. Having said that, phone is still a black screen when it's booting but the LED is now working so that's a definite plus. Any idea what that a white LED means?
     

    #44
  5. inumeral
    Eclair Jul 18, 2016

    inumeral , Jul 18, 2016 :
    Thumbs up!

    At first the 1st solution messed with my phone, even bootloader is gone.
    But everything is fixed after tried the 2nd one.
     

    Attached Files:

    Last edited: Jul 19, 2016

    #45
    IgutbuN and obiwan+ like this.
  6. ch0p5t1ckb01
    Donut Jul 19, 2016

    ch0p5t1ckb01 , Jul 19, 2016 :

    I tried method 2 as well but same result as method 1. Phone vibrates when I hold power button but screen is still black. Holding power + volume down will get me a white LED. If I discharge the phone overnight and plug it back in the next morning, it'll show a red LED briefly before going back to a white LED.
     

    #46
  7. Krasendo
    Cupcake Jul 28, 2016

    Krasendo , Jul 28, 2016 :
    [​IMG]

    i got this, help me. I only can get into fastboot. Can i install system by fasboot? ;_;
     

    #47
    obiwan+ likes this.
  8. G_Patrick_Beuks_iiOc
    Cupcake Jul 28, 2016

    G_Patrick_Beuks_iiOc , Jul 28, 2016 :
    I have the same problem with the md5 checksum.

    I also can't start recovery (twrp).

    As it looks like three people have the same problem in a very short time. is it maybe because the os updated?

    EDIT:
    Some additional information. I can start fastboot, but the oem is locked so i can't flash from my computer
     
    Last edited: Jul 29, 2016

    #48
  9. F_Raphael_Salamoun_KRzm
    Donut Jul 29, 2016


    #49
  10. JonasH77
    Cupcake Jul 30, 2016

    JonasH77 , Jul 30, 2016 :
    I have tried all this and haven't had any luck. I got my OPT the other day and this morning the screen staring flickering a little and then by the end of the day the screen just went black and wouldn't turn on again. I tried everything to get it fixed, wiping the phone and trying to root/reinstall ROM but I think i just ended up bricking the phone. Do have any advice on a fix?
     

    #50
  11. Madocjenkins
    Gingerbread Aug 1, 2016

    Madocjenkins , Aug 1, 2016 :
    tried method one, now its showing md5 checksum error?
     

    #51
  12. AvinashPalivela
    Cupcake Aug 1, 2016

    AvinashPalivela , Aug 1, 2016 :
    Thanks
    h
     

    #52
  13. Madocjenkins
    Gingerbread Aug 1, 2016

    Madocjenkins , Aug 1, 2016 :
    After many attempts to complete these tasks I finally managed to unbrick my phone! Bravo.
     

    #53
    Salvi108 and pastmann like this.
  14. Jamesst20
    Jelly Bean Aug 2, 2016

    Jamesst20 , Aug 2, 2016 :

    Will this fix a broken aboot partition ? Let's say I mess hard with it?
     

    #54
  15. Naman Bhalla
    Recognized developer Recognized Developer Aug 3, 2016

    Naman Bhalla , Aug 3, 2016 :
    Yes. It will fix anything.
     

    #55
    Jamesst20 likes this.
  16. obiwan+
    Honeycomb Aug 3, 2016

    obiwan+ , Aug 3, 2016 :
    Yes, I think everyone gets that message until they try method 2. I think method 1 is broken in some way.
     

    #56
  17. Naman Bhalla
    Recognized developer Recognized Developer Aug 3, 2016

    Naman Bhalla , Aug 3, 2016 :
    No. It isn't broken. Method 1 doesn't work if system partition is broken.
     

    #57
    obiwan+ likes this.
  18. obiwan+
    Honeycomb Aug 3, 2016

    obiwan+ , Aug 3, 2016 :
    Those "md5" messages people have posted pictures of, do they come from the bootloader?
     

    #58
  19. HammaadhRasheedh
    Cupcake Aug 4, 2016


    #59
    obiwan+ likes this.
  20. Madocjenkins
    Gingerbread Aug 6, 2016

    Madocjenkins , Aug 6, 2016 :
    Use method 2. It will wipe your data but at least you have a working phone.
     

    #60
    pastmann likes this.