173
[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 3

  1. obiwan+
    Honeycomb Aug 12, 2016

    obiwan+ , Aug 12, 2016 :
    I need help. I restored my device with unbrick method 2. I have TWRP installed. The bootloader is unlocked.
    The problem: I am on 3.2.2 and can't install OTA 3.2.4. TWRP boots and says error 7:

    image.jpg

    Can anyone say what's going on? I read about others who use TWRP and they are rooted (I am not rooted) but they can upgrade. I believe the reason I can't upgrade maybe is the unbrick method 2 and how it changed the system.
     

    #61
  2. taruneswar
    Cupcake Aug 12, 2016

    taruneswar , Aug 12, 2016 :
    Naman!!Thank U so much For the post!!Though i Havent been able to get over the problem.The guide worked great till step 8 and got green text.The OP3 which just blinked the logo first now booted properly but sadly it didnot boot to os .Instead an error screen showed up(see image).The error was:MD5 checksum failed.start do md5 checksum.But Fastboot Works fine.No recovery too.Bootloader locked(i relocked it as oneplus 3 showed a message during bootup to lock oem).Please Help me OUT!!!!!You are my only hope now.
     

    Attached Files:


    #62
  3. Prasanna22290
    Cupcake Aug 14, 2016

    Prasanna22290 , Aug 14, 2016 :
    Hello Everyone

    I would need a little help here for my soft bricked oneplus 3.
    The situation is that the phone boots into TWRP and bootloader but no zip files to install.

    I tried adb sideload and adb push to send the files to my phone but that didnt help.
    All the USB drivers are installed and my phone even got detected in the sideload. Tried all possible commands but no success.

    Any help and suggestion on this would be of great help to me.

    Regards
    Prasanna
     

    #63
  4. obiwan+
    Honeycomb Aug 14, 2016

    obiwan+ , Aug 14, 2016 :
    @taruneswar You must use method 2. Me and others had the same "md5" problem when using method 1.
    Be aware this will erase all data currently on your phone.
     

    #64
  5. obiwan+
    Honeycomb Aug 14, 2016

    obiwan+ , Aug 14, 2016 :
    This worked for me:
    adb push file.zip /sdcard/
    I think I was in TWRP while doing this.
     

    #65
  6. olegusss
    Cupcake Aug 15, 2016

    olegusss , Aug 15, 2016 :
    A3000
    first method - the problem similar to taruneswar
    second method - work, but not updated on Oxygen or Hydrogen newest. Again brick.
    At the same time flashing any custom base on Cyan successfully installed
     

    #66
  7. adventurous
    Cupcake Aug 17, 2016

    adventurous , Aug 17, 2016 :
    Hello, I applied METHOD 1

    volume up + power button is turned fastboot mode

    It is open recovery mode, volume down + power

    [​IMG]

    I am unable to help system
    :(
     

    #67
  8. adventurous
    Cupcake Aug 17, 2016


    #68
  9. aitor.ibanez
    Eclair Aug 22, 2016

    aitor.ibanez , Aug 22, 2016 :
    Hi! I don't know if my phone is bricked or not. The screen is black, it does not turn on, charge, vibrate or anything... I haven't tried to install any rom or kernel but friday, suddenly, the phone turned black and it's still black. Yesterday, I started a thread (https://forums.oneplus.net/threads/op3-died.460759/#post-15179496) and some users told me to try this unbrick guide. Even the phone does not react, when I plugged to the PC, some drivers QUSB_BULK were trying to install. So, I have a few questions:

    1. Is it possible that the phone has bricked by itself?? Maybe a damaged update file or something like this?
    2. Should I try this unbrick method (1 or 2) even if I'm not sure if the phone is bricked?
    3. If I try to unbrick but I fail, do I lose the phone warranty?


    EDIT 1: I've tried to install the drivers, but even Windows says everything is up to date, the device is not named Qualcomm but RELINK HS-USB QDLoader 9008. And, of course, when I try to use the Unbrick Tool, it doesn't find any device. Any solution?

    EDIT 2: I finally solved the problem and get Qualcomm HS-USB QDLoader 9008, but when I used the Unbrick Tool, I get the Sahara Conection error... so, finally, I'm going to RMA... Wish me luck with Arvato!

    Thank you!!!
     
    Last edited: Aug 22, 2016

    #69
    obiwan+ likes this.
  10. imnishanto
    Cupcake Aug 26, 2016

    imnishanto , Aug 26, 2016 :
    @Naman Bhalla : Thanks a lot buddy. Your are a life savior. After flashing, FreedomOS, the boot splash screen changed to FreedomOS splash screen. To revert it back to stock, I flashed "logo.bin" using fastboot which bricked my device. And, after trying for an hour, I gave up and made up my mind to go to the OnePlus Exclusive Service Center. I packed my phone in the box and kept it aside. I knew, nothing can be done now but still was praying to god to do some magic. And I guess, god heard my prayers and I came across this post of yours after clicking on random search result on Google.

    I thought of trying these steps as my last hope. I am quite familiar with rooting and modding so it was easy for me to understand your instructions. I followed each step, took me around 2 hours as I had to download drivers and Full Unbrick tool first.

    And voila, my phone woke up from the grave. And I saw it coming back to life in front of my eyes. I was almost in tears :p:p:p. I was speechless after this experience. Everything worked so smoothly.

    I started believing in GOD after this experience. ;););)

    I would like to thank you from the bottom of my heart. Your guide saved me from going through the hassle of taking my OnePlus 3 to the service center and waiting for weeks.

    You are one of the gems of the Android community and we need more like you.

    God bless you.

    BTW, I am Nishant and I am from Bangalore.
     

    #70
    Praty_28 and RONY JOHN like this.
  11. obiwan+
    Honeycomb Aug 26, 2016

    obiwan+ , Aug 26, 2016 :
    Hey, maybe OnePlus indirectly released those tools so people can fix their phones themselves? I think other companies have such tools, too. But they don't release it so people have to send their phones in and pay much money just for some mouse clicks they could as well have done themselves.
    I think this is a great approach and they should do it for every new phone they sell.
     

    #71
  12. RONY JOHN
    Gingerbread Aug 27, 2016

    RONY JOHN , Aug 27, 2016 :
    first method results in total f**ked up state. no response from the device at all. while trying method 2 drivers are installed properly but the msm tool is not recognizing the device..what am i doing wrong here?
     

    #72
  13. G_Pierre_Wyrick_LBrw
    Cupcake Aug 30, 2016

    G_Pierre_Wyrick_LBrw , Aug 30, 2016 :
    OMG Thanks, You just saved me from a soft brick. It was exceptionally bad timing because I'm going on vacation tomorrow and had no time for an RMA.
    I owe you a few drinks.
     

    #73
  14. kumarujjwalsingh
    Cupcake Sep 10, 2016


    #74
  15. haki99ify
    Cupcake Sep 10, 2016

    haki99ify , Sep 10, 2016 :
    Sorry for the nooby question but if i use a firmware other than OOS v3.1.3(say OOS v3.2.4),will there be any problems?I'm new to these stuffs.Sorry :)
     

    #75
  16. gelosound
    Cupcake Sep 17, 2016

    gelosound , Sep 17, 2016 :
    Hi, after performing the second method I was stuck at version 3.1.2 of oxygenos . every time I try to install a new rom I have a softbrick. I can flah only the twrp recovery . I tried updating via ota , adb sideload and put cyanogen but the situation does not change . I can only restore to 3.1.2 with qualcomm tool . does anyone know how to do ?[​IMG]
     

    #76
  17. chakrarv
    Cupcake Sep 18, 2016

    chakrarv , Sep 18, 2016 :
    You are a saviour, my Oneplus 3 is back on its feet. Excellent and easy, I feel like a pro.

     

    #77
  18. jchau09
    Cupcake Sep 19, 2016

    jchau09 , Sep 19, 2016 :
    I'm getting the same screen here. Has anyone found a solution yet?
     

    #78
  19. vallurimukesh
    Cupcake Sep 19, 2016

    vallurimukesh , Sep 19, 2016 :
    Hi.. I accidentally bricked my OP3 when i locked the bootloader and since then it is stuck in a bootloop with the LOGO followed by a MD5Chksum failed screen . Posting the screenshot below.. Im unable to flash any kind of recovery at all.. I tried both the Method 1 & 2. Also tried installing Stock Recovery by running Windows Command Prompt method from SDK & ADB tools and whatever.. Still stuck at not able to get a recovery itself.. Any help would be much appreciated. Please rescue Recovery Failed.PNG IMG_2529.JPG my new OP3.. Thanks in advance.
     
    Last edited: Sep 19, 2016

    #79
  20. vallurimukesh
    Cupcake Sep 19, 2016

    vallurimukesh , Sep 19, 2016 :
    Hi.. Any luck with the unbricking ? I had a similar problem and still stuck with it.
     

    #80