172
[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 3

  1. Jitesh Saitawadekar
    KitKat Oct 3, 2016

    Jitesh Saitawadekar , Oct 3, 2016 :
    2nd method will definitely work unless it's hardware issue so make sure drivers are properly installed and MSM tool finds it.
    You have to disable drivers signature enforcement to detect your drivers and install it manually so that MSM tool detects it.
     

  2. 50960
    Gingerbread Oct 3, 2016


  3. Latrina
    Cupcake Oct 3, 2016


  4. alidarkstone
    Donut Oct 3, 2016

  5. dr.anel
    Gingerbread Oct 3, 2016

    dr.anel , Oct 3, 2016 :
    i believe there is NO CM12 for OP3.

    therefore it will really brick his op3.

    try the 2nd method rigorously.
     

  6. dannytgt
    Donut Oct 3, 2016

    dannytgt , Oct 3, 2016 :
    Of course there is no CM12 for the OP3 I hardly believe that he flashed CM 12 rom on his OP3,but certainly the phone is really screwed. I've tried all night long flashing and I've used the method 1 and 2 like five times each of them and same results: dead phone, no recovery, no fastboot, not charging, anything at all.

    I've suspect there is some battery related problem maybe, it's pretty rare. But phone gets randomly recognized by the pc.

    Do battery have some relation maybe with that dead phone?

    Actually I have two OP3, teh good one with 3.5.3 CB and the screwed one, so today I'm planning to get some t2 screwdriver and disassembly both of them to test if there is some hardware problem, because flashing at this point I think it's useless I've tried with different pcs different methods different drivers, and same result for me.

    I'm really desesperated because I've planned to fix and sale that screwed OP3, because I really need the money.

    Thanks for your answers guys, I really appreciate your help.
     

  7. redo1984
    Cupcake Oct 3, 2016


    Jitesh Saitawadekar likes this.
  8. melchorio
    Cupcake Oct 11, 2016

    melchorio , Oct 11, 2016 :
    Hi All,

    First off, this is what I did that led to this problem:
    *** Beforehand, phone is unlocked, rooted, and updated to latest OTA OOS version (I think 3.2.7)
    *** Unlock, recovery, root and NFS backup was implemented using the guide here in the forums
    *** OEM unlocking was turned off in the Developer Options

    1. DPI was changed using the OnePlus3-ToolKit-v3.0-By-@ahmed_radaideh as recommended by some in Reddit -- this was OK
    2. DPI was changed again using Le DPI Changer (found in play store), but used "EDIT BUILD.PROP" option
    3. When phone rebooted, it was either stuck on OP logo, or just looping on OP logo (can't remember)
    4. Booted into TWRP, and restored NFS backup (pre-root) and it was successful according to TWRP
    5. When phone rebooted, it was either stuck on OP logo, or just looping on OP logo (can't remember)

    Now after this moment, I tried Method 1 of the this thread, but I encountered multiple md5 check failures upon boot. I then tried Method 2, and the md5 check failures were reduced to just one: system: failed.

    I can boot into fastboot, but I can't boot into recovery and system because of said error. Please help!
     
    Last edited: Oct 12, 2016

  9. Kerttuurius
    Eclair Oct 14, 2016

    Kerttuurius , Oct 14, 2016 :
    Hi i am istall drivers okey and everything but msm donwload tool is not recognation my device sorry my bad english
     

  10. ramalama
    Gingerbread Oct 15, 2016

    ramalama , Oct 15, 2016 :
    Please make this thread sticky ! ! !
    And add a link somewhere in the official help page !

    Because oneplus allows unlock without voiding guarantee. . .

    So there will be a lot people, who will write/ticket/call the service for a repair/return. . .

    And this here needs to be optimized, and be an official solution. . .
     

    obiwan+ likes this.
  11. aenews
    KitKat Oct 16, 2016

    aenews , Oct 16, 2016 :
    After some failed system updates, I realized that the failures were due to recovery. Couldn't boot into Recovery. Otherwise perfectly normal phone. Reflashed TWRP and Stock Recovery with fastboot but oddly nothing seemed to work. I came to the conclusion that perhaps the recovery partition itself could be borked. Used my phone normally for a couple weeks, but got some time this weekend to try to fix the problem.

    I use this unbricking tool, and the program gets stuck with a "Sahara" error. The device now seems totally bricked and won't boot into anything but fastboot. The partitions themselves are probably broken at this point as attempting to boot brings up a screen with a bunch of failures.
     

  12. F_Andrea_Ippolito_ZsRS
    Ice Cream Sandwich Oct 16, 2016

    F_Andrea_Ippolito_ZsRS , Oct 16, 2016 :
    Thanks so much for this guide, @Naman Bhalla , I hard bricked my op3 yesterday and could get remote support only on Monday, so you spared me a weekend without my dear op and lots of anxiety.

    Cheers!
     

  13. kevinfelixiano
    Cupcake Oct 18, 2016

    kevinfelixiano , Oct 18, 2016 :
    My fellow OP users and developers, I require assistance.
    I have an OPT that is bricked for some reason when I tried to flash TWRP to replace the recovery mode, I've done the procedures according to the instructions and now I'm stuck in a boot-loop, unable to go to recovery mode and boot to the system.
    The only thing that I'm able to do is to enter fastboot which doesn't let me do anything because the OEM is locked and I can't unlock it since the system is corrupted, indicated in MD5 checksum screen error while booting the phone regularly.
    Tried 2nd method and this is the result.
    By the way, the system is HydrogenOS, which I think it may affect your decisions and actions to the phone.

    Here are the two available screens that I'm able to see at the moment.
    https://drive.google.com/open?id=0B0gZrNFH9Gv_RkZwdk1XSUNwbmc Fastboot Screen
    https://drive.google.com/open?id=0B0gZrNFH9Gv_X1hHX05aSUdSWW8 MD5
    Checksum Error Booting to system Screen

    I also have the ADB tool and Fastboot tool and also the Drivers and ROMs.
    Please kindly assist me in this frustrating situation.

    Keeween
     
    Last edited: Oct 19, 2016

  14. F_Andreas_Mertz_mHlf
    Cupcake Oct 19, 2016

    F_Andreas_Mertz_mHlf , Oct 19, 2016 :
    Okay i can't shut off the phone (holding for 40 sec) i get the fail message "Sahara Communication FailedE.. Please ".

    Just some info:
    I im just in loop from 1+ logo to black screen
    All started when locked my phone (In the bootloader)
    Step 5 looks to have been done right
    Im on the 1+3
    https://gyazo.com/917311d3f0d66302eb2d115da200863d

    - Im not the best at computeres and i hope someone can help would be much appreciated.
     
    Last edited: Oct 20, 2016

  15. Cervantes
    Lollipop Moderator Oct 20, 2016

    Cervantes , Oct 20, 2016 :
    Hi
    I moved the thread
    look the first page
     

  16. F_Andreas_Mertz_mHlf
    Cupcake Oct 20, 2016


    Cervantes likes this.
  17. F_Andreas_Mertz_mHlf
    Cupcake Oct 20, 2016

    F_Andreas_Mertz_mHlf , Oct 20, 2016 :
    Just the same has happend to me have u found a solution ?
     

  18. Jitesh Saitawadekar
    KitKat Oct 20, 2016

    Jitesh Saitawadekar , Oct 20, 2016 :
    Even i got the same error once while trying on my pc so i tried it on my Laptop with Windows 10 + Signature enforcement disabled and it worked so i think you need to change PC.
    Edit: I used 2nd method cz i think my phone's partition was corrupted and it worked.
     

  19. F_Andreas_Mertz_mHlf
    Cupcake Oct 20, 2016

    F_Andreas_Mertz_mHlf , Oct 20, 2016 :
    Okay im gonna try many thanks!
     

  20. F_Umar_Akram_vhjA
    Cupcake Oct 20, 2016

    F_Umar_Akram_vhjA , Oct 20, 2016 :
    Hey,
    I installed all drivers and it shows up as in pics below

    but when i try try to update driver,
    it says "Best driver is already installed"
    AND when i click on start,
    it shows "No device" "Waiting for device connection"
    Please Help me out
     

    Attached Files:

    • 1.PNG
      1.PNG
      File size:
      38 KB
      Views:
      158
    • 2.PNG
      2.PNG
      File size:
      36.2 KB
      Views:
      145
    • 3.PNG
      3.PNG
      File size:
      15.8 KB
      Views:
      127