176
[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 3

  1. MartinAdams1986
    Eclair Nov 15, 2016


  2. MartinAdams1986
    Eclair Nov 15, 2016

    MartinAdams1986 , Nov 15, 2016 :
    you say second method will definitely work but it wont work for me. i keep getting md5 checksum failed. what are the steps to fix this? ive tried both methods multiple times but they dont work for me. it says recovery failed so i cant boot to recovery.
     

  3. Jitesh Saitawadekar
    KitKat Nov 15, 2016

    Jitesh Saitawadekar , Nov 15, 2016 :
    Try different USB port or different PC and make sure you do every steps carefully from disabling signature enforcement to installing proper drivers so that it connects properly.
     

  4. sitoshi
    Cupcake Nov 16, 2016

    sitoshi , Nov 16, 2016 :
    Hi all. 1st post. Woo hoo.

    So, been using your tool to fix my phone allot recently because everytime I do I cant upgrade beyond the version that this installs. No OOS firmware. And now my camera seems to stutter in slomo mode. Thing is I had a session with oneplus and they used the same tool, except there version did allow me to upgrade and things. Is there an update for this that im missing?
     

  5. arun.samotra
    Eclair Nov 16, 2016

    arun.samotra , Nov 16, 2016 :
    I accidentally ended up wiping my OP3 clean while installing the CM 14.1 Nightly. Lost the system files along with recovery and was stuck on bootloader for 4 hours straight. I tried various forums, including the OP community, and finally landed on this guide. I must say that I'd seen the Qualcomm driver installation steps elsewhere as well but I still went thru as I'd used Naman's tutorials in the past as well.

    I'm more than happy to tell you that I followed Method 2 and my OP3 is alive and kicking now. The phone got stuck at OnePlus logo and I had to reboot to recovery but it ran flawlessly thereafter. I'm however not going to root my phone this time, at least for a few more days. :D

    Naman and all those who contributed towards this process, I can't thank you guys enough for sharing this tutorial and helping less-code-friendly people like me. However, it would be great if the Unbrick Tool could be updated with the latest OS version. I'm running the update right now though. :D

    Thank you guys. More power to you all!
     

  6. bryanluong4444
    Cupcake Nov 17, 2016

    bryanluong4444 , Nov 17, 2016 :
    Hello, I was wondering if any of you guys knew a solution to my issue. After using the MSM tool to unbrick my oneplus 3, I'm able to set up my phone. The issue is that it will shut off after 3-4 hours and wont turn on and I will be forced to use the MSM tool once more to unbrick the phone. The issue also happens if i turn off the device. Please let me know if you guys have any solutions!


    Thank you in advance!
     

  7. Krisowski
    Froyo Nov 17, 2016

    Krisowski , Nov 17, 2016 :
    to everyone with "Sahara..." problem - changing usb port to 2.0 helped me in this situation
     

  8. claytron1116
    Eclair Nov 17, 2016


  9. Wolf_
    Donut Nov 18, 2016

    Wolf_ , Nov 18, 2016 :
    Fantastic resource to have. I honestly didn't know a phone could come back from a hard bricking.
     

  10. theleo2k
    Cupcake Nov 18, 2016


  11. LORD_X_age
    Cupcake Nov 19, 2016

    LORD_X_age , Nov 19, 2016 :
    in my case it worked on USB3 Port after repeating step 4 and step 5 a few times.

    i had a problem that my phone didn't accepted my email-ID after installing CM and then switching back to OxygenOS
    phone stated "
    „Konto bestätigen:

    Das Gerät wurde zurückgesetzt. Melden Sie sich zum Fortfahren mit einem Google-Konto an, das zuvor auf diesem Gerät synchronisiert wurde.“

    which means "verify account - the phone has been reset, log in using your google account that was active on this phone before"

    Method 1 did not work but method 2 saved the phone by wiping all data - even the protected sh*t.



    @Naman Bhalla: this thread is absolut genuis! thanks for posting this here!
     

  12. Amrith09
    Eclair Nov 21, 2016


  13. atulkhatri29
    Honeycomb Nov 21, 2016

    atulkhatri29 , Nov 21, 2016 :
    It worked fine with the same port once i was connected to internet. Earlier i thought it doen't require an internet connection but i guess it does atleast to initiate the process.
     

  14. Jitesh Saitawadekar
    KitKat Nov 21, 2016

    Jitesh Saitawadekar , Nov 21, 2016 :
    Great ;)
     

  15. OnePlus3CC
    Eclair Nov 22, 2016

  16. ushiromiyanick
    Cupcake Nov 22, 2016


  17. JoseCalero
    Donut Nov 22, 2016


  18. AloCubano
    Gingerbread Nov 22, 2016


  19. Htet Aung Lwin
    Cupcake Nov 23, 2016


  20. Meonit
    Cupcake Nov 24, 2016

    Meonit , Nov 24, 2016 :
    Hi, do you also have a solution to this problem,
    I was given a oneplus 3 that I can keep if I can get it to work.

    The guy had installed twrp and CM14.1
    and then he doesn't know how but it's stuck in fastboot mode with locked bl.
    trying to unlock via adb say it can't be done remotely.

    Trying to boot to recovery or os doesn't work
    both these options just give lines of text saying what don't work.

    What do you say, is there a way out of this, or should I throw the phone away
    the guy already bought a new so I guess it's mine to either fix or trash.