1
Other [GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 3T

  1. ADITYA_VERMA_
    Cupcake Dec 21, 2017

    ADITYA_VERMA_ , Dec 21, 2017 :
    A hard bricked OP3T has nothing but a black screen and hard buttons on the device don’t respond (nothing ever comes on the screen, not even a boot logo, not even led notification for charging), it might vibrate when a power button is pressed and held for 20 seconds, has no Recovery partition, no adb mode, and no fastboot partition. The device might be detected in Linux and you might be able to even send commands to it. In Windows, the bricked OP3 should be detected as QHUSB_BULK, Unknown Device, Qualcomm something. You might have a bricked OP3T as a result of flashing a kernel, ROM meant for a different device or your attempt of unlocking the bootloader resulted in corrupting the boot partition.

    The following steps are to be followed to unbrick your Hard bricked Oneplus 3T and to get back to stock rom:

    Step 1: Download Driver and Unbrick Tool



    Step 2: Extract Drivers and Recovery Tool files on Desktop.

    Step 3: If you are using Windows other than Windows XP, turn off Driver Signature Enforcement. To do so, follow this guide :


    Step 4: Press the power button for 40 seconds to turn off the phone (there might be no vibration in the device but a sound of device connecting to the PC can be heard).

    Step 5: Press the volume up button for 10 seconds and connect the device with the computer while holding the volume up button (Important).

    Step 6: Open your device-manager and make sure in "Unknown devices" is one device with the name "QHUSB_BULK or Qualcomm something".

    Step 7: Right Click on your device in the device manager and select Update Device Software. Choose manually the drivers folder that was extracted earlier and install the driver.

    Step 8: When the device shows as "Qualcomm……9008", go run the “MsmDownloadTool V3.0.exe” in “OnePlus3T_28_A.23_161027”folder as administrator.

    Step 9: Click start at top left corner and wait for it to finish (green text will come).

    Step 10: Disconnect phone from PC and boot into system.


    Your OnePlus 3T should now be back to life!
     

    #1
    Johan Notte likes this.
  2. Tumsifu
    Cupcake Feb 25, 2018

    Tumsifu , Feb 25, 2018 :
    every time I attempt to run the tool I can't. It says "Load setting xml file failed. Read config file failed." can someone please help.
     

    #2
  3. MysteriousPatron
    Cupcake Apr 4, 2018

    MysteriousPatron , Apr 4, 2018 :
    unbrick tool went success.. bt still my device won't boot up.. it comes to that red and white dot animation, stays normal till around 30 secs.. and bam, switch off again... anyone familiar with this?? help me
     

    #3
    florisvanbrakel likes this.
  4. Rijuld
    Cupcake Jun 6, 2018

    Rijuld , Jun 6, 2018 :
    When installing the driver, I get an error code 28 (driver not installed; Driver is not intended for this platform.) Thus unable to get the device to be read as Qualcomm....9008

    every time I try and install the downloaded driver, the name changes from COM15 to COM16... to 17,18,19
     

    #4
  5. Goldiev29
    Cupcake Oct 8, 2019

    Goldiev29 , Oct 8, 2019 :
    My 3t does not even respond when charger is plugged it. It wasnt rooted or anything else. It is totally bricked.
    What should I do!?
     

    #5
  6. dickindeventer
    Cupcake Dec 22, 2019

    dickindeventer , Dec 22, 2019 :
    I hope that my reply is not too late for you, I had the same thing. ZChatging with the Dash charger had no effect over one whole night. I used the fast charger of another brand to test if it wasn't the charger or the cable. This time as I pressed the power switch my oneplus 3T miraculously came BAC to life.
     

    #6
    Johan Notte likes this.
  7. O1586024908548
    Cupcake Apr 4, 2020

    O1586024908548 , Apr 4, 2020 :
    Hello,
    I followed these instructions exactly with my OnePlus 3T on Windows 10 and wasn’t able to have any success. Everything worked as expected until I reached the end of step 6 where it appeared as Qualcomm HS-USB QDLoader 9008 automatically (Not QHUSB_BULK). I update the drivers of that device anyways with the ones provided and that worked successfully. Then, I verified in the Downloader Tool and it returned “OK”. Finally, I clicked start and it had the message, “Downloading Firehose Binary” for about 15 seconds and then “Sahara Communication Failed – Please try again after power off the phone”. I did the holding of the power button for 40 seconds and then the volume up button while connecting. Is there something I am doing wrong? Any suggestions would be much appreciated.

    P.S. My OP3T is hard-bricked: No vibration response, screen won’t light up, no logo/bootloader, etc. I have been attempting to unbrick for a couple days now and at one point in trying to run MSMDownloader V3.0 the OP3T’s LED came on and flashed orange and red for a while but I haven’t been able to replicate that since

    Thanks in advance
     

    #7
  8. GShajan3t
    Cupcake Apr 8, 2020

    GShajan3t , Apr 8, 2020 :
    Hi

    I have followed all the steps. Yellow/orange and red light flashed on the LED indicator. At step 9 the green text came up at which point i unplugged the phone and tried turning on but it doesn't turn on. Ive tried connecting back to the computer but doesnt even get recognised as "Qualcomm..." anymore.

    Please help.

    Thanks
     

    #8
    Kunalpatel 2016 likes this.
  9. LSEIV
    Cupcake Apr 19, 2020

    LSEIV , Apr 19, 2020 :
    Hi. I was using my phone normally and it uncharged, as it usually does. When I tried to connect it into the wall, it doenst give any life signals. What can I do? I already tried to charge it over a night with the dash charger, but nothing. Do you think an apple charger with a usb-c cable might do the trick? Thanks
     

    #9
  10. Kunalpatel 2016
    Cupcake May 6, 2020

    Kunalpatel 2016 , May 6, 2020 :
    i am having the same issue, are you able to unbrick your phone?, if yes please share the know how
     

    #10
  11. L1589124727739
    Cupcake May 10, 2020

    L1589124727739 , May 10, 2020 :


    Thanks a lot for your wonderful summery, but i followed all the steps correctly and i am exactly in the same stage with my phone. But every time its shows FirehoseCheckRSP Failed, Errno: 258
    I tried many times but every time this problem, what should i do? can you please reply me or anybody can help me in this stage?
     

    #11