44
[GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus 7 Pro

  1. lbule
    Cupcake Jun 21, 2019


    #21
  2. Swejuggalo
    KitKat Jun 21, 2019

    Swejuggalo , Jun 21, 2019 :
    I can't seem to find anything specific to the 7 model. I've sent a request for that info to Oneplus
     

    #22
    Thomas_AP likes this.
  3. TA44751
    Eclair Jun 21, 2019


    #23
    Titokhan likes this.
  4. R1528752001541
    Froyo Jun 25, 2019


    #24
  5. R1528752001541
    Froyo Jun 25, 2019


    #25
  6. Swejuggalo
    KitKat Jun 25, 2019

    Swejuggalo , Jun 25, 2019 :
    Did that happen after a unbrick? What phone model number and what region?
    If you have a non pro 7 what did you do?
     

    #26
  7. emonkhan826
    Eclair Jun 25, 2019


    #27
  8. H1561960043803
    Ice Cream Sandwich Jul 1, 2019

    Last edited: Jul 13, 2019

    #28
  9. Chun Wang Ho
    Donut Jul 12, 2019

    Chun Wang Ho , Jul 12, 2019 :
    Can I use this on my OnePlus 7 Pro GM1910
    It sucks in fastboot mode n unable to boot to recovery n system.
    This happened when I trying to replace H2OS with OOS :(
    whatever which methods I only able to boot into fastboot mode


    Can I use the Global ver on my GM1910?
     
    Last edited: Jul 12, 2019

    #29
  10. moses0563
    Gingerbread Jul 13, 2019


    #30
  11. Titokhan
    Honeycomb Jul 18, 2019


    #31
    Chun Wang Ho likes this.
  12. H1564498346595
    Cupcake Jul 30, 2019

  13. Pdscoelho
    Cupcake Aug 1, 2019

    Pdscoelho , Aug 1, 2019 :
    I'm stuck with faulty sensors (gyro,magnetic,proximity etc) what do I do?
    I've tried many stock roms now but the sensors are not being picked up at all.

    Please help
     

    #33
  14. Pdscoelho
    Cupcake Aug 1, 2019

    Pdscoelho , Aug 1, 2019 :
    I have a GM1910 model from gearbest which I see now is actually a Chinese variant. It came preloaded with OxygenOS out of the box. I would like to try load a HydrogenOS stock rom and see if that sorts out my issues I mentioned in the previous post.

    Can you help with a link for a hydrogen rom?

    I tried the link you provided called guacamole_21_H.04_190416_unlocked.zip
    but I get an error message when I open Msmdownloadtool.exe,
    it says 'packed image not exist'. The app doesn't open at all.

    I've used guacamole_21_O.07_190512_unlocked.zip and the Msmdownloadtool.exe works,
    I loaded the stock oxygen rom but my sensor issues still remain.

    Perhaps If I flash a HydrogenOS rom It will sort out my sensor problems? as the GM1910 is first loaded with hydrogen at the factory? Its the only idea I have left.

    Edit: Found a lot of Hydrogen roms here
    http://www.oneplusbbs.com/thread-4874855-1.html
     
    Last edited: Aug 1, 2019

    #34
  15. cp915j
    Donut Aug 7, 2019


    #35
    Johan Notte and I1565893711264 like this.
  16. M1562948359615
    Cupcake Aug 14, 2019

    M1562948359615 , Aug 14, 2019 :
    I have the T-Mobile variant with SIM unlock, can I use the Global/US Unlocked image to recover from hard brick?
     

    #36
  17. mateusz91
    Froyo Aug 23, 2019

    Last edited: Aug 24, 2019

    #37
  18. m1c88
    Cupcake Aug 25, 2019

    m1c88 , Aug 25, 2019 :
    ok any help I think phones soft bricked or hard bricked lol can't tell can get into fastboot and recovery mode download that guacamole file download msm tool thing plug it up and started the process and after about 2 mintues it says done and then reboot into the boot loop again
    Definitely I'm doing something wrong ,any info greatly appreciated cheers have Chinese version btw flashed already before it decided to play up
     

    #38
  19. joeqt8
    Cupcake Sep 10, 2019

    joeqt8 , Sep 10, 2019 :
    Hi everybody!

    I'm here too since I think i've just madre a BIG mistake. Flash TWRP to Ramdisk Boot Partition and now it's stuck to only Fastboot Mode. Event if I try to select Recovery or System, it keeps on going back to Fastboot Mode.
    Having said this, which file should I download since I have a GM1910 Version from Gearbest with OxygenOS preflashed.

    Please Help ;) Thank you in advance
     

    #39
  20. AliCevik
    Cupcake Sep 16, 2019

    AliCevik , Sep 16, 2019 :
    Hello,

    My Device model 1911. I got backup via twrp. Then I set up the rumor and didn't like it. Then I made wipe (system, data, dalvik). Then I did restore (system, data). Now my device won't turn on. The device manager connects to qualcomm hs-usb diagnostics 900e. I can't unbrick because MsM Tool doesn't see my device. Help me pls :(

    Solvedddd : I held 3 buttons connected for a long time and I was able to log into twrp mode. I threw stock photos and I'm free now. [​IMG]
     
    Last edited: Sep 17, 2019

    #40