96
OPX [GUIDE] Mega Unbrick Guide for A Hard Bricked OnePlus X

  1. OHara32
    Cupcake Jan 24, 2017

    OHara32 , Jan 24, 2017 :
    Hello! I can not install the drivers, because my OPX VID 00FE (00FE:9008) instead of 05C6.
    I edited the file named QCSER.INF:
    %QcomDevice90080% = QportInstall00, USB\VID_00FE&PID_9008
    :)
    Then appeared device "Qualcomm HS-USB QDLoader 9008 (COM3)". Further all the instructions, but:
    "Sahara Communication Failed Please try again after poweroff phone".

    What to do else? And which means 00FE?
    Advise, please. Thanks
     

  2. horritz
    Cupcake Feb 4, 2017


  3. JenneMeister
    Cupcake Feb 6, 2017

    JenneMeister , Feb 6, 2017 :
    Hi. First of all thank you so much for providing information like this. Without people like you I would have been in a ton of shitty situations without the means to recover from them.

    I don't know whether this thread is dead or not, but I have to give it a shot...
    I've done all the steps to the point of installing the driver. It is possible for me to find the Qualcom HS-USB under Ports in Device Manager, but it is not possible to install any other driver. When I try to install it Windows says that the right driver is installed and that there is no reason in changing it...
    I have, as the instructions told, set my computer to be in "Test mode" regarding the Driver Signature Enforcement.
     

  4. Kéno40
    Jelly Bean Feb 6, 2017

    Kéno40 , Feb 6, 2017 :
    It should work. Try with an old computer with windows 7 on it, it's easier.
     

  5. bixio2
    Cupcake Feb 6, 2017

    bixio2 , Feb 6, 2017 :
    I installed on my lineageos 14 plus one. All perfect for a few days. Then, while I was away from home, he started riavvisarsi continuously. He opened the TMRP recovery, but not loaded the rom. After a bit 'of attempts is the Roma in Safe mode is started. I rebooted again and resumed the continuous riavvivi. Now appears the OnePlus logo and then switches off and restarts. Even more the recovery is started, if not for a very short period, then restarts all. What can I do?
    thank you
     

  6. Seireiju
    Cupcake Feb 7, 2017

    Seireiju , Feb 7, 2017 :
    So I'm in the situation where my bootloader is locked, and I can't boot into recovery, just shows the OnePlus logo.
    Tried flashing again using the TWRP app and fastboot, nothing.
    Did "fastboot oem device-info" got this


    (bootloader) Device tampered: false
    (bootloader) Device unlocked: false
    (bootloader) Charger screen enabled: false
    (bootloader) Display panel:
    (bootloader) console_enabled: 0
    (bootloader) exec_console_unconsole: 0​

    I tried this unbrick method, but, depending on the computer used (Windows 10, Windows 7, or Microsofts IE11 Windows 7 VM) I either got, Unknown Device along with "TP-Link Android Phone/Android Bootloader interface", just "android", or just "Unknown Device". All of these do also have a COM1 under ports though. (I have driver signing or whatever off btw)

    None of those picked up the driver from qcser.inf when I used "Browse for driver software on your computer", only if I used Have Disk, which then gave the whole list of "QUALCOMM-HS USB Diagnostics xxxx" drivers, No clue which one to use since none of the devices have that name.

    Doesn't matter what driver I chose, MsmDownloadTool V2.0 just says "Waiting for Device Connection"

    I posted on XDA weeks ago and no one replied, do any of you have any clues? I'm willing to have someone teamviewer into a computer if they whana help figure it out.
     

  7. dryden
    Froyo Mar 3, 2017


    Kéno40 likes this.
  8. alirazaxd
    Cupcake Mar 11, 2017

    alirazaxd , Mar 11, 2017 :
    My phone had gotten stuck in a boot loop with no access to recovery or bootloader and was not getting detected by my computer. Luckily I stumbled across this. I was relieved to find out that I could unbrick my phone, and when I saw the mini unbrick, with no data loss, I was amazed. It has worked like a charm without any problems for months now. Thanks alot!!!!!!
     

  9. sabastefano
    Eclair Mar 15, 2017

    sabastefano , Mar 15, 2017 :
    I have the same problem... i see only Android Bootloader Interface and bootloader locked. Have you solved the problem? how?

    Thanks a lot.
     

  10. Luckyyy93
    Donut Mar 15, 2017

    Luckyyy93 , Mar 15, 2017 :
    Hello, I have a problem. When I connect my phone to PC with file transfer option, I cant see any file in each folder of the internal storrage. Help me how to fix this!
     

  11. aditya_ranaa
    Cupcake Mar 16, 2017

    aditya_ranaa , Mar 16, 2017 :
    That folders might be hidden folders or there are some privacy on that particular folders
     

  12. The Caped Crusader
    Gingerbread Mar 16, 2017

    The Caped Crusader , Mar 16, 2017 :
    @Naman Bhalla @SoniaB
    I'm following all the steps but after sometime clicking start I get "FirehoseCheckRSP failed,errno 258. Downloading NON-HLOS.bin failed"
    Please tell what to do ,I don't have any other devices to call anyone.
    Please Help!
    Backstory : Using my phone oneday suddenly it freezed and when I rebooted it by pressing power button an error came Encryption Unsuccessful and I'm unable to access my phone.
     
    Last edited: Mar 21, 2017

  13. G_Hasan_Arain_MZUB
    Cupcake Mar 16, 2017


  14. abhiramnaidu
    Cupcake Mar 23, 2017

    abhiramnaidu , Mar 23, 2017 :
    @Naman Bhalla @Synthio when I am trying to update Qualcomm driver it is showing windows has installed updated version
    driver version is 2.1.0.8
    installed version is 2.1.1.0
    what should i do?
     

  15. KrapnoV
    Cupcake Mar 26, 2017

    KrapnoV , Mar 26, 2017 :
    Greetings folks,
    I know very little about installing custom ROM but I usually can handle it by just following a guide. I messed up BAD this time however and ended up hard-bricking my OPX.

    The problem I believe is that Windows 7 is working against me preventing me to follow this guide (or any guide for that matter) because any attempt I make at registering Qualcomm drivers fail.
    I will include screenshots below, but my theory based on my limited knowledge is that the phone is being detected as the wrong "type" of unknown device such as a "universal serial bus controller", while the included driver present in this guide "qcser.inf" is listed as "Class = Ports".
    I have followed several guides, disabled driver signature verification but I always end up with "The folder you specified doesn't contain a compatible software driver for your device". So as long as my phone is not listed as "QHSUSB_BULK" nothing is gonna work. Any help would be appreciated at this point!

    Screen captures here: http://imgur.com/a/czd5r
     

  16. arudei
    Donut Mar 30, 2017

    arudei , Mar 30, 2017 :
    Dear sir, do you have firmware for board 15... I got new board and when i flash using this method... My phone stuck at oneplus logo, internal storage was disabled in Recovery... Fastboot is locked... and when charging didn't show the battery... only red light shown... please help me...
     

  17. arudei
    Donut Mar 30, 2017

    arudei , Mar 30, 2017 :
    Dear sir... maybe you're running x64 OS... Please use amd64 driver...
     

  18. Vkkan123
    Cupcake Apr 1, 2017

    Vkkan123 , Apr 1, 2017 :
    Hello All,

    My oneplus x has been all of sudden gone dead.

    Last week after came back from park I have noticed my phone flash light was glowing so I took the phone out of the pocket and seen the screen when we siwtch on with + sign and android name with black color, I tried to switch off and trying to switch on but no help

    I read through various posts but none of them helped me for ex
    1. Power + vol [down / up ]
    2. Called the support [India] to get help -> ticket no 597069 , they told me to do some steps none of them worked
    3. Took the phone to Koramangala service centre and they told mother board has been short circuited have to change the motherboard and instead of changing the board which costs between 8K to 11K the service engineer told me to buy new one
    4. keep the phone idle for two days and try to switch on , I did this today finally saw a screen which said battery was dangerously low keep it charge little hope so I put for charge and tried to switch on nothing happening now

    Can you guys help me what I have to do to bring back my phone
     

  19. Dickta
    Froyo Apr 1, 2017


  20. sunil1491
    Honeycomb Apr 3, 2017


    sachin2506 likes this.