117
[GUIDE] OnePlus 3/3T: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup & More!!

  1. SBrophy
    Cupcake Feb 27, 2017

    SBrophy , Feb 27, 2017 :
    thanks. I don't have any data on the phone.

    I long pressed the power button and it powered off, now I power it on and asks for the pattern to unlock it, I try my pattern and it says wrong pattern... can't get out of there!

    EDIT: OK, I rebooted the phone and it was asking for a pattern. Tried the one I had and didn't work. Clicked on "forgot password" and it wiped the phone and is now letting me boot into OS.

    I tried rebooting to recovery, and it shows the oneplus recovery, not TWRP... What should I do now to finish the root process? Should I start from scratch? Will the bootloader be unlocked after the wipe? (in system settings, developer mode, usb debugging and advanced reboot were turned off again after the wipe, but OEM unlock was enabled).
     
    Last edited: Feb 27, 2017

  2. Funk Wizard
    Moderator Moderator Feb 27, 2017

    Funk Wizard , Feb 27, 2017 :
    No the bootloader once unlocked will remain unlocked unless you lock it manually, so let the OEM unlock enabled.
    Just flash twrp via fastboot again and continue the root process.
    As the device is new its a right time to decrypt, make sure you use the latest 3.0.4-1 TWRP (linked on the OP)
     

    SBrophy likes this.
  3. SBrophy
    Cupcake Feb 27, 2017

    SBrophy , Feb 27, 2017 :
    Thanks, I will try that in a while.
    I don't want to decrypt it as it will contain work data.
    Just to be sure, and considering I don't want to decrypt it, should I try flashing TWRP and continue the root process without setting up a pattern/password on the phone before? Or should I create one before trying the TWRP again?
     

  4. Funk Wizard
    Moderator Moderator Feb 27, 2017

    Funk Wizard , Feb 27, 2017 :
    No as you have done a factory reset, do not create any pin/password/fingerprint for the time being.
    Just flash 3.0.4-1 via fastboot followed by supersu (both links on the op)
    Once done reboot system and you are done.
     

    SBrophy likes this.
  5. SBrophy
    Cupcake Feb 27, 2017

    SBrophy , Feb 27, 2017 :
    Thanks, I just did so and all seems to be good so far, so thank you very much for all your help today!
     

  6. chris_wolf
    Cupcake Feb 28, 2017

    chris_wolf , Feb 28, 2017 :
    hey, thanks for the guide!

    i have a problem: after unlocking bootloader i flashed the recovery (twrp-3.0.4-1-oneplus3.img).
    the problem is after rebooting into recovery mode - i just get the message, that the device is unlocked and cant be trusted and after 5sec it boots normal. when using volume keys and try to boot to recovery i get the same message again. but i have still access to the bootloader. tryed a lot also the stock recovery - still get the message/window.

    any idea/help?

    edit: fastboot says:

    DEVICE STATE - unlocked
    secure boot - enabled

    edit²: nvm... just got the "problem". - worked whole time but i ****** it up by interrupt the start causing of the "device is unlocked and cant be trusted" message
     
    Last edited: Feb 28, 2017

  7. elanglois
    Lollipop Feb 28, 2017

    elanglois , Feb 28, 2017 :
    Are you saying that this has always been the version there? That is not the one that I downloaded here when my phone soft bricked! Please make it clear that the download has changed and is now safe.
     

  8. elanglois
    Lollipop Feb 28, 2017

    elanglois , Feb 28, 2017 :
    The latest TWRP can cope with an encrypted device, so it is safe to set a password, just not mandatory either way. You will just need to give it your password when you run TWRP in order to mount /data. I'm still rooted and still encrypted. TWRP works fine. This may not work with a custom OS as I heard it uses the encryption libs from OOS, so if you change your libs around, it may get funky. With straight OOS, you are good.
     

  9. DavidPlus1
    Cupcake Feb 28, 2017

    DavidPlus1 , Feb 28, 2017 :
    Not found this issue- so hoping for assistance here.
    I've installed TWRP and went to 'INSTALL' to flash SuperSu, but my phone can NOT see the ZIP files...
    I rebooted and transferred the files again to the phone from the PC but the PC said they were already there.
    Why is TWRP not seeing the ZIP files?
    Thank you!
     
    Last edited: Feb 28, 2017

  10. OnePlusNothing
    Cupcake Mar 2, 2017

    OnePlusNothing , Mar 2, 2017 :
    Hi, I need some help.

    I followed the procedure on Page 1 and I'm able to flash twrp.img, but I can't boot into twrp.img -

    [​IMG]

    My bootloader is unlocked. I tried flashing it several times but it won't work. I can boot into the default recovery just fine though.

    Tried googling for "remote: dtb not found" but couldn't find anything. Does anyone know what I'm doing wrong ?

    My phone details -
    Model number: ONEPLUS A3010
    OxygenOS version: 4.0.3
     

  11. crotach
    Cupcake Mar 2, 2017

    crotach , Mar 2, 2017 :
    Hi,

    Does this procedure work with 4.0.3, or do I need to downgrade first?

    Also what does dm-verity do? Is that the option you get to add a pattern to your android phone that gets checked before the device is started (power-on) ? I find that useful, that the device will not even power on without a security measure.

    Last question - is there a way to root, debloat and do whatever else you want with root access, and then unroot and re-enable dm-verity?

    Thanks :)
     

  12. ilia.rabkin
    Cupcake Mar 2, 2017

    ilia.rabkin , Mar 2, 2017 :
    I have done this
    • Go to “Wipe” section and tap “Format Data”, and type “yes” (If you want to mount internal storage).
    And now my sdcard is empty. What can I do?
    Thanks :)
     

  13. xellestar
    Cupcake Mar 3, 2017

    xellestar , Mar 3, 2017 :
    Real noobie here, I'm at the start of the guide with "Before you proceed please OTA up to 3.5.3 as TWRP has an issue with Decryption on 3.5.1". I'm not sure what this means. My current Android version is 7.0 and under System updates i show ONEPLUS A3003_28_170208
     

  14. hnsmnn
    Gingerbread Mar 3, 2017

    hnsmnn , Mar 3, 2017 :
    You still get OTAs. You only have to reinstall root everytime you perform an update, as far as i know
     

  15. hnsmnn
    Gingerbread Mar 3, 2017

    hnsmnn , Mar 3, 2017 :
    ADB sideload the OOS zip from the official OnePlus website. I had the same problem.
     

  16. Alex Ferreli
    Cupcake Mar 3, 2017

    Alex Ferreli , Mar 3, 2017 :
    Hi, i had installed the Open Beta 3 on my One Plus 3T. Can i follow this guide for rooting? I have the bootloader unlocked, but if i flash the twrp and install the SuperSU zip, phone go in bootloop.

    How can i root with the Open Beta 3? Thanks in advance!
     

  17. taofeek25
    Cupcake Mar 3, 2017

    taofeek25 , Mar 3, 2017 :
    Taking more than 20min for rebooting after swiping for install SuperSu. Normal?

    I have followed all the steps of rooting 3 times but nothing changes. How can I fix this or undo all the steps from the begening??

    Please someone help me :sob::sob::sob::sob:

    Ps: I'm french so excuse me if you don't understand evrything
     
    Last edited: Mar 3, 2017

  18. bhadsavale
    Cupcake Mar 4, 2017

    bhadsavale , Mar 4, 2017 :
    I am in same situation. How long it took for you?

    Edit : I gave up after almost 30 mins then flashed OOS 4.0.3 from here again
    https://forum.xda-developers.com/oneplus-3t/how-to/rom-oos4-0-nougat-op3t-leaked-t3523482
    Followed by super SU and then was able to boot. :)
     
    Last edited: Mar 4, 2017

    Plenkske likes this.
  19. manuhalliwell
    Cupcake Mar 4, 2017

    manuhalliwell , Mar 4, 2017 :
    Hi, I do have OOS 4.0.2 and modified TWRP to work on my phone, just flashed the dm-verity... file to get that message gone but when I try to root the phone refuses to boot, it remains on the startup animation ( as far as i've tried, half an hour).

    I did flash latest SuperSu, any special file needed to do so? Thanks
     

  20. Bernie55
    Cupcake Mar 6, 2017

    Bernie55 , Mar 6, 2017 :
    I managed to root my phone but I have a strange issue. Most of the hardware on the phone is out of sorts.

    I think maybe it went wrong when I flashed the UPDATE-SuperSu, which is what I got when I used the provided link. I did manage to get a phone with TWRP, but it didn't have root. After flashing SuperSu binary I am rooted. I made a backup but hadn't noticed the hardware issues; it thinks it doesn't have modem, but they work a bit, most other sensors are bust.

    I have tried flashing OTA and proper SuperSu with TWRP and that only results in soft brick. I guess I need to side load to make that work?

    Will side loading fix soft brick? Will it also fix hardware, or are there other steps I should take?

    ===========================
    Update
    ===========================

    My phone was not really soft bricked, it was trying to boot in SuperSu setup script. But I had boot password set (it is not reset by unlock). SuperSu can not ask for the password so it's stuck.

    You should add setting your boot password to None before starting.
     
    Last edited: Mar 9, 2017