94
OP3T [GUIDE] OnePlus 3/3T Unbrick

?

Seems like there are some problems with MSMDownloadTool in Windows 8.1, do you have any?

Poll closed Jun 14, 2017.
  1. Yes(please describe the problem in comments)

    1 vote(s)
    50.0%
  2. No

    1 vote(s)
    50.0%
  1. Yaduvanshi_sagar
    Cupcake Jan 1, 2019


  2. genialmaniac
    Cupcake Jan 11, 2019

    genialmaniac , Jan 11, 2019 :
    Hello,

    here's my story about this:
    - as soon as my phone was going out of battery, it was really long to restart (I got to press the power button for a while before it finally starts)
    - sometimes it was booting to recovery and showing me a screen with a password to fill (password I never had, I learned after it's because partition is encrypted, I never asked for that, I tried my sim pin, my schema translated to digits, no success)
    - to note: I came from an original OxygenOs, I never rooted my phone, neither unlocked my bootloader, everything seems to have started with one of those firmware update of oneplus, it encrypted my partition and problems started
    - lately, I could not have it started again so I said myself it was time to reset to factory defaults (for the first time in more than 2 years) and follow this guideline.
    - I so downloaded all the necessary, boot in download mode and use the msmdownloadtool as required.
    - phone booted again but phone communication are gone, indeed, my IMEI are both wiped.

    this is the end of the story, I tried several things since, with different flavors of msmdownloadtool found there and there, without any success. Now on, my phone does not boot anymore, stuck on oneplus logo forever, I was forced to change.

    Thanks OnePlus for this scheduled obsolescence, I have to change my phone after only 2,5 years, I'm seriously pissed off.
    I understand you make good efforts to keep up-to-date your old models, but if it's to destroy them that way, stop it please, only provide security fixes and over.
    I now even ask myself if that - available to all - guide is not there only to kill the remaining oneplus on the market, wipping IMEI is a good solution...

    No thanks & Regards

    G.
     

  3. Deactivated User
    Jan 13, 2019


  4. genialmaniac
    Cupcake Jan 13, 2019

    genialmaniac , Jan 13, 2019 :
    your last comment is very strange because I saw other people with the same situation, IMEI gone after full flash from download mode. Also why don't provide latest msmdownloadtool to the community ? For exmaple there is OnePlus3_16_A.67_180816 online, but password protected, why ?
     
    Last edited: Jan 13, 2019

  5. genialmaniac
    Cupcake Jan 17, 2019

    genialmaniac , Jan 17, 2019 :
    Hi there,

    I continue my story, I was finally able to start the os again! I used
    OnePlus3_Unbrick Firmware_(By Sonu Ansari 786)
    package, commented out the userdata and system partitions in the rawprogram0/4.xml. I was finally able to boot in recovery, format cache/data (I could not do that anymore, was crashing each time), flashed a beta oxygenos via adb sideload and suddenly oxygenos boot, apparently the beta is not upgradable via OTA :(

    Problem remained, I had no more IMEI. I so flashed a qcn file with help of QFIL (part of QPST), qcn was mainly done for oneplus 3T but after all connectivity were back again anyway!

    Now I tried to upgrade to a higher oxygenos version but I failed and I'm in the boot loop again.... I tried the procedure again but it does not work. it seems the partitions are corrupted again so.
     

  6. genialmaniac
    Cupcake Feb 2, 2019


    acetone802000 likes this.
  7. acetone802000
    Froyo Feb 2, 2019


  8. K1549274602294
    Cupcake Feb 4, 2019

    K1549274602294 , Feb 4, 2019 :
    Hi,
    I keep getting stuck on 'Sahara Communication Failed£-Please try again after power off phone'
    Th phone seems off non responsive cant get into fast boot (apart from freak accident boots) and when it does turn on normally results in boot loop.

    thanks
    J
     
    Last edited: Feb 4, 2019

  9. G_Salah_Eldin_Abdelmabou
    Cupcake Apr 5, 2019


  10. F_Hanani_Corney_ndTg
    Cupcake May 10, 2019

    F_Hanani_Corney_ndTg , May 10, 2019 :
    i have performed all the above instructions successfully. all downloaded well in step 12 but when i tried turning the device on, it wouldnt work. any other suggestions?
    (while downlading from msmdownload tool the light on the phone was yellow, if this helps)
     

  11. Cervantes
    Lollipop Moderator May 10, 2019

    Cervantes , May 10, 2019 :
    Hi
    You take the steps again
    perform each step calmly: let the information load or process
    do not open the msntool until after connecting the phone
    Wait a moment and give it to check and then start the msntool process
     

  12. Smil0r
    Cupcake May 29, 2019

    Smil0r , May 29, 2019 :
    Because i want wo sell the Phone, i try to relock the bootloader (oem lock bootloader).. after the rebooting the phone want a password... and i dont know wich one but the best was that the recovery was in a bootloop... damn.. but this help perfektly!

    Thank you very much!
     

  13. amit5432
    Cupcake Jun 16, 2019


  14. Q1562324797407
    Cupcake Jul 5, 2019

    Q1562324797407 , Jul 5, 2019 :
    Hi Guys, I have tried this Method now a several times, but when MsMDownloadTool is finished with flashing, and I try to boot up the device, all it does is get stuck at that ball thingy bootup screen. I can get to recovery mode, but when i sideload the newest OxygenOS, it still won't boot.
    Anyone an idea what i could do?
     

  15. AntoineGpp
    Cupcake Jul 7, 2019

    AntoineGpp , Jul 7, 2019 :
    Hello !Even by following all instructions, I get sahara failure, and when I click on "verify", it fails:
    upload_2019-7-7_9-28-10.png
    What can I do ? Thanks for help guys !
     

  16. Praty_28
    Jelly Bean Jul 7, 2019

    Praty_28 , Jul 7, 2019 :
    I've heard that restarting your pc/laptop used to fix this did you try doing so?
     

  17. dennavilljagha
    Cupcake Aug 31, 2019

    dennavilljagha , Aug 31, 2019 :
    I do not know if it is because of that my device do not quick charge since a over a year back.

    But despite i am holding volume up for +25 sec and connect to the computer or try with another computer and i faund a thread that sugesting holding volume up + down simultaneously:
    https://forums.oneplus.com/threads/oneplus-3-oneplus-3t-unbrick-simple-steps.690213/

    I never get my OP 3t to appear in the device manager! (and therefore i am not able to transfer any data between computer and the OP 3t)

    Can it be that the 4 pins in usb connector is 2 for power and 2 for data. And to be able to use DASH quick charge the data hand shake needs to be done (to verify the right wires and charger is used). But if that is failing somehow then it will as default only do std slow charge. If that is the case then maybe there is something broken in the usb communication. That prevents data reaching the PC.

    Or is there something i have not tried yet to get it detected on the PC?
     

  18. Z1567290942622
    Cupcake Aug 31, 2019

    Z1567290942622 , Aug 31, 2019 :
    it doesn't then right click on 'QHUSB_BULK' choose 'Update Driver Software...' > 'Browse for driver software on your computer' > 'Let me pick from a list of device drivers on my computer' > 'Have Disk...' > 'Browse' > Navigate to the folder of unbrick tool and then choose 'driver' folder > choose 'qcser'
    8 After the installation is finished your device
     

  19. Nikto243
    Cupcake Oct 13, 2019 at 4:49 PM

    Nikto243 , Oct 13, 2019 at 4:49 PM :
    hello guys i have bricked my op3t i try all steps in this tutorials use windows 7 and dissabled antivirus, my problem is that show problem in md5 checksum failed because show in the last screen system fayled what you think is my problem
     

  20. Cervantes
    Lollipop Moderator Oct 13, 2019 at 5:20 PM

    Cervantes , Oct 13, 2019 at 5:20 PM :
    Hi
    You are using msntool