OP3T [GUIDE] OnePlus 3/3T Unbrick


Seems like there are some problems with MSMDownloadTool in Windows 8.1, do you have any?

Poll closed Jun 14, 2017.
  1. Yes(please describe the problem in comments)

    1 vote(s)
  2. No

    1 vote(s)
  1. xKhael
    Cupcake Oct 23, 2017

    xKhael , Oct 23, 2017 :

    it says sahara communication failed what to do?

  2. xKhael
    Cupcake Oct 23, 2017

    xKhael , Oct 23, 2017 :
    hello ! mstool says SAHARA COMMUNICATION FAILED.... what to do?

  3. jsnaxl
    Cupcake Nov 7, 2017

    jsnaxl , Nov 7, 2017 :
    Tried it step by step but my laptop still doesnt detect my OP3T

  4. kamkol
    Eclair Nov 7, 2017

    kamkol , Nov 7, 2017 :
    same on some laptops. idk what's the issue, all PC's works good but specially Lenovo but other devices too got some problems sometimes.

  5. tepetidis kostas
    Gingerbread Nov 7, 2017

    Cupcake Nov 10, 2017

  7. Kakrona
    Gingerbread Nov 13, 2017

    Kakrona , Nov 13, 2017 :
    Mine too. Green status already shows "Download Complete" Then my OP3 reboot just the logo of OnePlus then blank, nothing, just see the white LED. Have you fixed yours yet?

  8. namefaisal
    Cupcake Nov 19, 2017

    namefaisal , Nov 19, 2017 :
    Almost same issue like mine. Only different After DOWNLOAD COMPLETE in green text OP3 reboots just the logo then puff! Powers off.

    You see the white LED but Mine shuts down. Unable to find any new way to try on the device now.

  9. Kreniak
    Cupcake Nov 23, 2017

    Kreniak , Nov 23, 2017 :
    Hi, following your tutorial on op3t all good but when i try the msm tool says download cache fail error 258

  10. joeqt8
    Cupcake Nov 24, 2017

    joeqt8 , Nov 24, 2017 :
    Did you solve the problem?

  11. Kakrona
    Gingerbread Nov 26, 2017

    Kakrona , Nov 26, 2017 :
    I even had OP' level 2 technician remotely fixed my OP3. They just used MSMRecoveryTool v3.0.8 (nouget rom). They just followed the same instructions but it didn't fix anything. still the same. [e]1f612[/e]

  12. Min Khooptong
    Eclair Dec 6, 2017

    Min Khooptong , Dec 6, 2017 :

    Thank you so much. This saved my phone!

  13. broeckelman
    Cupcake Dec 31, 2017

    broeckelman , Dec 31, 2017 :

    thank you for your guide. I tried it with my OnePlus 3.
    "Download Complete" writen in green, but i cant start my phone. When I click on "Verfiy" this comes up:

    dynamic_nvbk.bin: OK
    emmc_appsboot.mbn: OK
    gpt_backup0.bin: OK
    gpt_main0.bin: OK
    userdata.img: FAILED open or read
    rawprogram0.xml: FAILED
    NON-HLOS.bin: OK
    rpm.mbn: OK
    static_nvbk.bin: OK
    tz.mbn: OK
    boot.img: FAILED open or read
    cache.img: FAILED open or read
    persist.img: OK
    recovery.img: OK
    system.img: FAILED open or read

    When I dont unplug my phone from my PC the download run again, and again "Download Complete" writen in green

    Sry for my bad englisch

  14. kenchinito
    Froyo Jan 5, 2018

    kenchinito , Jan 5, 2018 :
    Hello, thank you for this guide. I just did this proceedure and the phone still doesnt turn on. Everything went fine and the tool succesfully flashed everything. I think my battery is faulty but I'm not sure. The phone tries to turn on, shows the oneplus logo and then restarts. I sometimes get the message that the battery is too low and asks me to leave it plugged in.

  15. ecko4711
    Cupcake Jan 10, 2018

    ecko4711 , Jan 10, 2018 :
    i am also having the same issue and dont know what to do. Switching to a MSM Tool for the 3 would be dumb i think?

  16. bibiii79
    Eclair Jan 10, 2018

    bibiii79 , Jan 10, 2018 :
    yup I know what was the reason... I used unbrick tool from 3T. to unbrick a OnePlus 3...

  17. alfjos
    Cupcake Feb 5, 2018

    alfjos , Feb 5, 2018 :
    Thanks, sadly after unbrick process my onePlus 3T boot successfully but without wireless. After update system with sideloader with oxygenOS 5.0.1(with the method mentioned in the post) my phone was bricked again :( anyone with same problems?

  18. gerbaudloic
    Cupcake Feb 26, 2018

    gerbaudloic , Feb 26, 2018 :
    Been trying for (a few) hours to restore my 3T. Unfortunately, each time, the MSM tool (v 3.0.6 or 3.0.8) always showed me the "Sahara...." error.
    I had the bootloader unlocked (long story short, to fix the low in-call speaker problem I tried rooting the phone... After that, I had bootloop issues...).

    So, I relocked the bootloader, and MSM was able to do its job.

    I hope it'll help some pals.

  19. Nerulicious
    Cupcake Mar 1, 2018

    Nerulicious , Mar 1, 2018 :

    I don't know if this thread is dead or not but after doing this process I saved my OP3 but the colors in my screen are washed out (It looks like the screen is broken or something) does anyone had this problem and know how to solve it?

    Edit: I get to solve it by updating the system. Uffa
    Last edited: Mar 1, 2018

  20. SlyTimer
    Cupcake Mar 10, 2018