186
[GUIDE] OnePlus 3: How to Unlock Bootloader, Flash TWRP, Root, Nandroid & EFS Backup and More !

  1. G_Timo_Greiner_LpWo
    Cupcake Dec 7, 2016

    G_Timo_Greiner_LpWo , Dec 7, 2016 :
    Hello everybody,

    I think I destroyed my Device - need any help you coul offer!! :(

    I was doing an Update from CM14.1 to the new release of today (07.12.2016), when the phone crashed.

    Here the facts:
    - It doesn't boot anymore - after the OnePlus-Logo, the phone turns off again.
    - No chance to reach recovery-mode (TWRP) - nothing happens
    - fastboot-Mode is still working!


    What could be the Problem?
    The nex step I wanted to do was to make the EFS-Backup, but i didn't do it yet!! (BIG mistake)
    So I have no Files for EFS-Backup. (I still know my IMEI)

    What can I do now? Is the EFS-partition corrupted? Or what could be the cause for no recovery-mode and no booting?

    What I tried:
    Flashing TWRP-recovery again. This was not possible - I can reach the phone with 'fastboot devices' but I cant flash.
     

  2. lbop
    Cupcake Dec 8, 2016

    lbop , Dec 8, 2016 :
    i also needed stock recovery for an app called recovery switcher
     

  3. yiddyuk
    Gingerbread Dec 8, 2016

    yiddyuk , Dec 8, 2016 :
    Very nice thread I'm just wondering if it would be possible to root it without installing a custom recovery by flashing root through adb sideload in stock recovery or fastboot?
     

  4. Rahuvich
    Honeycomb Dec 12, 2016

    Rahuvich , Dec 12, 2016 :
    How do I update my OP3? It is rooted and I dont remember what steps I had to follow to update it, and please if you could post the links I need with the steps! Thaanks in advance!
     

  5. ravigola89
    Cupcake Dec 14, 2016

    ravigola89 , Dec 14, 2016 :
    I flashed twrp 3.0.0 but I am not able to boot twrp recovery.
    When I press volume down and power key simultaneously a blank screen appears and it remains there. I have to power off my oneplus 3 by pressing power button for several seconds. So kindly help in this issue as I want to install miui rom on my oneplus 3.
     

  6. F_Cédric_Catonyme_mwQu
    Cupcake Dec 14, 2016

    F_Cédric_Catonyme_mwQu , Dec 14, 2016 :
    For information : the beta 9 can be rooted with the same SR1. But you will lose your sim card... But your phone is Android 7 rooted ! \o/ But you cannot call or send SMS...
     

  7. TechnoTarzan
    Cupcake Dec 16, 2016

    TechnoTarzan , Dec 16, 2016 :
    Greetings All, I am having an unusual problem that I have not seen a direct answer to. I followed this guide a week ago and successfully was using my OP3 with TWRP 3.02-1 working fine, this morning I wanted to install the RR latest version, I followed this guide here.... http://forum.xda-developers.com/oneplus-3/development/rom-resurrection-remix-m-t3399960 and when I booted into recovery to install the FW and Modem version 9 and I can no longer boot into recovery, I can get a OP boot screen and then it goes black and stays that way. I can reboot into fastboot and the phone is recognized by fastboot but stays at a black screen. Cheers for your advice.
     

  8. hcbhatt
    Cupcake Dec 17, 2016

    hcbhatt , Dec 17, 2016 :
    I am also facing the same issue... Need help from the forum on this.
     

  9. TechnoTarzan
    Cupcake Dec 17, 2016

    TechnoTarzan , Dec 17, 2016 :
    I rolled the TWRP recovery back to the latest stable release and it worked, from there I was able to install the OS and get back up and going. Only issue is that now my phone shows SYSTEM folder using 30GB, that cannot be right. Looking into that now.
     

  10. darklynx
    Cupcake Dec 21, 2016

    darklynx , Dec 21, 2016 :
    My pc is not seeing my OP3 using 'fastboot devices' command. (ive tried both an elevated command prompt and elevated power shell)

    I have enabled developer options, enabled usb debugging, enabled oem unlock and enabled advanced reboot.
    I use advanced reboot to reboot to the bootloader.

    I have installed every driver imaginable. I first tried the generic adb driver here, and it doesn't see it. Tried the Samsung adb driver, the OP1 the OP2 and the OP3 drivers, all of which none work (I've searched many guides and each one says to use a different driver).

    Can someone link me the exact driver needed? (every guide also states if it is not seeing the device, its due to the right driver not being installed)
     

  11. TheEdenCrazy
    Cupcake Dec 26, 2016

    TheEdenCrazy , Dec 26, 2016 :
    What about rooting an already encrypted device? Will unlocking the bootloader still wipe /data even if it is encrypted?
     

  12. kanano
    Cupcake Dec 27, 2016

    kanano , Dec 27, 2016 :
    Can I add lockscreen security after I've done a TWRP backup? I don't want my phone to be accessible to anyone.
     

  13. gamax320
    Donut Jan 1, 2017


  14. divo89
    Cupcake Jan 1, 2017

    divo89 , Jan 1, 2017 :
    i not able to download the root superSU from your link, do you have an updated link? Thank you
     

  15. senthill4u
    Cupcake Jan 1, 2017

    senthill4u , Jan 1, 2017 :
    How to relock bootloader I'm in open beta 10 community build need official OTA what should i do for that bro
     

  16. wospino
    Ice Cream Sandwich Jan 1, 2017


  17. kalander Shihab
    Ice Cream Sandwich Jan 2, 2017


  18. gazornonplat
    Cupcake Jan 2, 2017

    gazornonplat , Jan 2, 2017 :
    This is no longer working for me - the twrp recovery image just boots to a black screen. Anyone having a similar issue?
     

  19. Zh_kilat
    Android Q Jan 2, 2017

    Zh_kilat , Jan 2, 2017 :
    you don't need to unlock bootloader to get OTA, and also no ob10 OTA yet....... Beware relocking bootloader may risk your phone to get bricked.
     

  20. Robbmeisterr
    Eclair Jan 2, 2017

    Robbmeisterr , Jan 2, 2017 :
    The flashing of the TWRP image does not work for me on Nougat.

    Cmd output:
    target reported max download size of 440401920 bytes
    sending 'recovery' (18841 KB)...
    OKAY [ 0.532s]
    writing 'recovery'...
    OKAY [ 0.159s]
    finished. total time: 0.698s
    When trying to access the recovery menu, I am sent to a menu which says: "Device has been unlocked and can't be trusted ...". When I select more options, I can choose between power off, restart, recovery, reboot or previous page. When I choose recovery, I am sent to the same menu again.