179
[GUIDE] OnePlus 3: How to Unlock Bootloader, Flash TWRP, Root, Nandroid & EFS Backup and More !

  1. Zh_kilat
    Android Q Feb 9, 2017


    Sun90 likes this.
  2. Jaysen3
    Donut Feb 9, 2017

    Jaysen3 , Feb 9, 2017 :
    So you must have root access in order to make a backup of EFS? At what point in the process could he modems become corrupted since usually you make backups before any processes could potentially screw things up?
     

  3. ams73
    Cupcake Feb 10, 2017

    ams73 , Feb 10, 2017 :
    Has anyone successfully rooted the OP3 yet using this method? Just being extra cautious before attempting to ROOT mine. :)
     

  4. elanglois
    Lollipop Feb 21, 2017

    elanglois , Feb 21, 2017 :
    actually, you need twrp 3.0.4-1 or later which is unreleased. You may have trouble booting following the recommended guides if you have Nougat. I have rooted 4.0.3 successfully
     

    Trilochan@86 and noquarter like this.
  5. noquarter
    Lollipop Feb 21, 2017

    noquarter , Feb 21, 2017 :
    Thread merged.
    Btw it's NOUGAT, not Nought
     

    theshinybeast and Funk Wizard like this.
  6. PCesar.Cercal
    KitKat Feb 21, 2017

    PCesar.Cercal , Feb 21, 2017 :

    Can you tell me what is the best current twrp for the new custom ROM of oneplus 3?
     

  7. Funk Wizard
    Lollipop Moderator Feb 21, 2017

    Funk Wizard , Feb 21, 2017 :
    Use the modified TWRP by Blu Spark, link updated on the OP
     

  8. AhmedMalik
    Cupcake Feb 23, 2017


  9. Nickexp
    Honeycomb Feb 23, 2017

    Nickexp , Feb 23, 2017 :
    Just updated to Nougat and can't find anything on rooting and installing Xposed. Anyone able to tell me how? (I was rooted on Marshmallow, I basically just need the files and some basic instructions and I can work it out)
     

  10. theshinybeast
    Marshmallow Feb 24, 2017

    theshinybeast , Feb 24, 2017 :
    All that can be found in the first post and there´s no xposed for Nougat yet.
     

    Nickexp likes this.
  11. domnerus
    Honeycomb Feb 25, 2017

    domnerus , Feb 25, 2017 :
    Hi, anyone can confirm will this method root my Oneplus 3 with oxygenos 4.0.3?
    Is it compatible with 4.0.3 ?
    Regards


     

  12. G_webwolf_LTwE
    Cupcake Feb 27, 2017

    G_webwolf_LTwE , Feb 27, 2017 :
    Hey guys,

    Great guide, but a few issues...
    First off if using an x64 build (at least for AMD) flashing the Stock ROM will require and x64 version of ADB. the regular version of ADB won't be able to push anything over a 1GB to the phone. So if you're getting the "Cannot read file.zip", make sure you have the file in the same folder as ADB and the ADB version is 64bit if you're using at least an AMD x64 build (not sure if Intel has the same issue, probably does but it's strange that this issue isn't well known).

    Anyone else have this problem:
    When I nandroid backup, my phone factory resets the ROM... it does the same when trying to recover the nandroid backup. so no backup / restore from TWRP without wiping the ROM completely back to factory settings.
     

  13. miTzaH
    Froyo Feb 27, 2017

    miTzaH , Feb 27, 2017 :
    Oneplus 3 4.0.3 firmware and never unlocked/rooted

    Procedure went like this
    fastboot oem unlock
    fastboot boot twrp.img
    Wait for it to boot , allow system modifications
    Mount SDCARD from twrp and upload magisk 11.1.zip
    Flash the zip
    reboot

    Now you get stock recovery , stock firmware with superuser abilities. Only downside is the notification given on each boot saying you have an unlocked bootloader.

    Other than that it works great.
     
    Last edited: Feb 27, 2017

  14. mso07runner
    Ice Cream Sandwich Feb 28, 2017

    mso07runner , Feb 28, 2017 :
    Hi everyone
    wish can help a newbie
    I have Oneplus 3 with oxygenos 4.0.3, unlock ... with this method in post 1, will be any problem?
    thanks all
     

  15. Nickexp
    Honeycomb Mar 1, 2017

    Nickexp , Mar 1, 2017 :
    Yeah I later found that out. Sucks ***, wouldn't have updated if I'd known there's no Xposed
     

    theshinybeast likes this.
  16. Trilochan@86
    Froyo Mar 8, 2017

  17. elanglois
    Lollipop Mar 8, 2017

    elanglois , Mar 8, 2017 :
    damn… scroll up two posts before yours
     

  18. elanglois
    Lollipop Mar 8, 2017

    elanglois , Mar 8, 2017 :
    you act like stock recovery is a benefit? make a nandroid backup of your EFS partition in case it gets corrupted which could be seriously hard to fix without a backup.

    Or maybe a partition is corrupt. run fsck from stock recovery.

    what benefit is stock recovery ?
     

  19. Trilochan@86
    Froyo Mar 9, 2017

    Trilochan@86 , Mar 9, 2017 :
    After fastboot flash recovery recovery.img done, not showing the above pics.please suggest me.....
     

  20. G_Adam_Emerson_pqWG
    Cupcake Mar 9, 2017

    G_Adam_Emerson_pqWG , Mar 9, 2017 :
    Hello,

    I followed the guide and successfully rooted my OP3. However, I could not get the phone to mount in r/w mode. Anytime i tried to alter a file I would get a "Device Busy" error, telling me that I could not mount in r/w. I tried to update TWRP and SuperSU, but that didn't work either. I decided to restore to the Nandroid backup we made in step 3 to start from scratch and try again, but I'm now looking at a phone with the white dots orbiting the red dot (startup screen) for the past few minutes. Is it supposed to take this long on boot after a restore? Any tips on how to fix the r/w issue?

    Thanks.