175
[GUIDE] OnePlus 3: How to Unlock Bootloader, Flash TWRP, Root, Nandroid & EFS Backup and More !

  1. smenon1 Cupcake Jun 1, 2017

    smenon1, Jun 1, 2017 :
    Okay, I reinstalled the SuperSU zip file 3 times, and for whatever reason, the 3rd time was the charm. Root is working just fine on my phone. Perhaps opening the SuperSU app before doing anything else on the phone made a difference? Perhaps I'll never know.
     

  2. SatriaPerdana Ice Cream Sandwich Jun 3, 2017

    Last edited: Jun 13, 2017

  3. sahil_starrh Honeycomb Jun 3, 2017

    sahil_starrh, Jun 3, 2017 :
    I unlocked bootloader and installed TWRP on my 3T, since then, whenever I turn my phone off, a message comes up saying "your device has been unlocked and can't be trusted"
     

  4. hoanghai2772 Cupcake Jun 8, 2017

    hoanghai2772, Jun 8, 2017 :
    help me please!
    I'd got a big problem.
    My device’s oem lock was disable (in developer setting) and my bootloader was in locked status. I cannot use the command: fastboot oem unlock. The command said remote unlock is not allowed. I don’t know how to unlock the bootloader in fastboot. I tried to ubrick my phone but it didn’t work. It said: check md5; cache failed…. and it reset the phone many times. I also couldn’t open recovery mode. Please help me. I really need your help. You are my only hope now. Thank you in advance
     

  5. Millig Gingerbread Jun 8, 2017

    Millig, Jun 8, 2017 :
    That's normal, no worries
     

  6. JohnnyBramble Eclair Jun 8, 2017

    JohnnyBramble, Jun 8, 2017 :
    Help!!!

    On Oxygen 4.1.5, when I try to root, after install SuperSU the phone freezes in OP circle symbol.
     

  7. bennigei Cupcake Jun 9, 2017

    bennigei, Jun 9, 2017 :
    I'm having the same issue. After upgrading to 4.1.5 and flashing supersu again my op3 freezes on bootup. Without supersu there is no problem.
     

  8. aveon1 Gingerbread Jun 11, 2017

    aveon1, Jun 11, 2017 :
    Flash SuperSU v2.82 and alsoTWRP 3.1.1 you are good to go
     

    conny005, smenon1 and JohnnyBramble like this.
  9. JohnnyBramble Eclair Jun 11, 2017


    aveon1 likes this.
  10. aveon1 Gingerbread Jun 11, 2017


    conny005 and JohnnyBramble like this.
  11. SatriaPerdana Ice Cream Sandwich Jun 13, 2017

    SatriaPerdana, Jun 13, 2017 :
    Can I use these files in the latest stable?
     

  12. SatriaPerdana Ice Cream Sandwich Jun 13, 2017

    SatriaPerdana, Jun 13, 2017 :
    Can you flash stock recovery then flash a new rom?
     

  13. jiten634 Cupcake Jun 18, 2017


  14. smenon1 Cupcake Jun 20, 2017

    smenon1, Jun 20, 2017 :
    I just wanted to recount my experience in installing Oxygen update 4.1.6 in case it's helpful to others. My phone is rooted.

    1) I received the update from OnePlus in notifications, and chose to download the update. I then chose to reboot the phone.
    2) Update worked fine, but phone was not rooted anymore.
    3) I attempted to install SuperSU 2.82 in Recovery mode. Recovery mode was frightening. It wasn't the screen that I had used before. I could choose a file to install, but I could not move up a directory. I chose the SuperSU zip file, and it failed to install. Then I was stuck, as I couldn't exit Recovery. I switched off the phone and figured I'd try again.
    4) I took the posted advice above from @aveon1 and flashed TWRP 3.1.1 in fastboot mode.
    5) After successfully installing this, I entered Recovery mode (and it was the one that I had seen in the past!). I successfully installed SuperSU 2.82.
    6) Phone rooted, and all's working fine :)
     

    aveon1 likes this.
  15. aveon1 Gingerbread Jun 21, 2017

    aveon1, Jun 21, 2017 :
    Glad to help you :D
     

    smenon1 likes this.
  16. Trundler Cupcake Jun 21, 2017

    Trundler, Jun 21, 2017 :
    So to clarify, these instructions are currently not working 100%? Or is the vocal minority the only ones experiencing problems. I was about to go for a root but I don't really have the time to encounter issues right now.
     

  17. smenon1 Cupcake Jun 21, 2017

    smenon1, Jun 21, 2017 :
    I rooted my OP3 using the instructions from the original post in this thread a few weeks ago. It went smoothly.

    The reason for some of these posts is that installing the recent Oxygen update (4.1.6), like any OS update, will not leave your phone in a rooted state. So there are a couple of steps to take after an update to ensure that your phone is rooted.
     

  18. Fuschy Gingerbread Jun 21, 2017

    Fuschy, Jun 21, 2017 :
    The no verity tool you posted on the OP5 thread. Is that also working for the OP3? Or is there another version for it?
     

  19. G_Bibi_Rivas_García_wsv Cupcake Jun 24, 2017


  20. poccix Cupcake Jun 28, 2017


    Deactivated User likes this.