175
[GUIDE] OnePlus 3: How to Unlock Bootloader, Flash TWRP, Root, Nandroid & EFS Backup and More !

  1. sahil_starrh Honeycomb Jul 14, 2017

    sahil_starrh, Jul 14, 2017 :
    I am trying to root and flash Resurrection Remix on my 3T, I have flashed TWRP, unlocked bootloader. I am trying to flash Resurrection Remix and GApps but as soon as I install and reboot into System a message pops up and says "your device has been unlocked and cannot be trusted" How do i get rid of this and flash Resurrection remix properly?
     

  2. Funk Wizard Lollipop Moderator Aug 17, 2017

    Funk Wizard, Aug 17, 2017 :
    This message is unavoidable and is a secure boot message so as soon as you unlock the device this message would appear on every boot for 5 seconds. You can press power to bypass it immediately or wait for 5 seconds
     

  3. chiliNknives Cupcake Aug 17, 2017

    chiliNknives, Aug 17, 2017 :
    Repost since this got moved to the Unrooting thread. I'm not trying to unroot the phone, but to root it and get stuck after installing SuperSU.
    Hello there,
    I'm on Oxygen OS 4.1.6(already had to reflash the OS for being stupid), TWRP 3.0.3-x and have the UPDATE-SuperSu-v2.79-20161211114519.zip in my download directory, shortly said I'm on the newest OS version with all the downloads as described in the OP. As noticeable I was able to install TWRP without a problem, backups and everything are working fine. My problem is whenever I try to install superSu(yes I checked the download if it's corrupt or anything) I just get stuck in the boot animation with the 2 dots stopping to move usually after the first reboot after the flash and my phone going black(apparently without turning off since I have to keep the power button pressed for longer to turn it off then on again). Before the new flash of the OS I had the same problem, but it also always told me while installing super su that /system couldn't be mounted. This problem doesn't seem to persist though. Is there any way to resolve this issue?
    Thanks a lot in advance for helping out :)
    P.S: It also always tells me at every boot that the dm-verity is not started in enforcing mode and may not work properly, does this maybe have something to do with it?
     

  4. nagarajsherigar Cupcake Aug 28, 2017


  5. SatriaPerdana Ice Cream Sandwich Sep 8, 2017

    SatriaPerdana, Sep 8, 2017 :
    @Funk Wizard can this thread be made sticky?
    I oftenly loose it and the search function doesn't help.
    And I guess new members won't bother using the search function, so I think it's just ideal to put it sticky.
    Now I'm using the watch thread tho.
    Thx

    Edit : I have just noticed that it's bookmarked in first post in one of the pinned thread, so I think it's good enough.
     
    Last edited: Sep 8, 2017

  6. julianfung94 Cupcake Sep 10, 2017

    julianfung94, Sep 10, 2017 :
    Hello,

    I followed your post step by step on how to root my OP3. Thank you for the awesome post and it was helpful.

    However, when I moved to step #4, I installed the zip folder on the TWRP recovery mode. Exactly according to your steps and screenshots. However, when it finished flashing SU and I pressed reboot, it showed the oneplus screen with black and white logo, and then the rotating animation with 2 white dots rotating around 1 red dot, and it just freezes after about 10 seconds, and then turns black and shuts off. What went wrong and what should I do?

    I have done a Nandroid backup through TWRP before flashing SU. I can still go into recovery right now and probably restore stock rom, but I am afraid to do anything before a second opinion.

    Any help would be much appreciated, thank you very much!
     

  7. RealUD7 Gingerbread Oct 16, 2017

    RealUD7, Oct 16, 2017 :
    First of all Thanks @Funk Wizard and @Naman Bhalla for this guide. I looked through the guide and have questions on each step since I haven't dealt with an encrypted device before (I'm currently on OB 24).

    1) At which step of this process, the built-in encryption is removed or do I have to remove it at any step?

    2) Won't the official TWRP work in the entire process?

    3) In the Step 1, you have mentioned that unlocking the device will wipe (all the data) off the device. But, in the Step 3, you have mentioned that there should be no screen security when making Nandroid backups. If unlocking wipes off the device how will the device have any screen security or is this instruction only for future Nandroid backups?

    4) Do I need to remove encryption before flashing a custom ROM in Step 4 if it hasn't already been removed during unlocking bootloader or flashing TWRP? Or will I be able to flash custom ROM over encrypted OOS?

    5) In Step 5 and 7, you have covered EFS backup. Isn't it possible to make EFS backup using fastboot? Also, do I need to make EFS backup while I'm on OOS? Can't I make EFS backup on a custom ROM?

    6) How do I return to stock OOS with locked bootloader?

    Thanks, in advance for all the help :)
     
    Last edited: Oct 17, 2017

  8. SirBacke Honeycomb Oct 18, 2017

    SirBacke, Oct 18, 2017 :
    It's a great guide! Except that I would root nowadays with Magisk / Magisk Manager instead of SuperSU. Then put Xposed Framework on top of Magisk (Special version available on XDA).
    (For rooting you won't need anymore a SuperSu or similar file because Magisk is rooting automatically when installing).

    Re 6): See search engine in this forum.
     
    Last edited: Oct 18, 2017

  9. RealUD7 Gingerbread Oct 20, 2017

    RealUD7, Oct 20, 2017 :
    I was hoping someone will help me out because I don't want to create a new thread for this given there are already quite a lot of stupid threads asking for Oreo. Even if someone notices my thread I will be redirected here but no one is helping me out. I'm hoping that @Funk Wizard or anyone else notices this and helps me out.
     

  10. G_Marius_Inspired_cDgV Cupcake Oct 31, 2017

    G_Marius_Inspired_cDgV, Oct 31, 2017 :
    Same here, any solutions? It get's stuck on the red dot and two white dots above frozen.

    EDIT: fixed it! Boot into recovery ---> Wipe ---> Proceed ---> Reboot to system after wiping

    EDIT 2: It seems it also wiped out the root. The problem was out-dated supersu package. Download the newest here: http://www.supersu.com/download
     
    Last edited: Oct 31, 2017

  11. Rubens Jr. Donut Dec 4, 2017

    Rubens Jr., Dec 4, 2017 :
    I've followed all the steps carefully. I installed SuperSU, but after cleaning cache and reboot, the device stops loading on boot loop. Even the loop image stops and the led notification turns on.
     

  12. maner Cupcake Feb 17, 2018


  13. harshalhirve Cupcake Mar 16, 2018

    harshalhirve, Mar 16, 2018 :
    I have unlocked by bootloader but unable to flash TWRP. I am on Open Beta 32. While trying to flash twrp, it gives me 'max file size' error.... & nothing after that. All drivers installed properly & adb commands working fine.
    Please help !