102
[GUIDE] OnePlus 3T: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup and More !!

  1. zatarra77 Gingerbread Mar 21, 2018

    zatarra77, Mar 21, 2018 :
    Hi everyone,
    I'm not able to understand if, after installing the twrp, I have to flash the DM-Verity to avoid a bootloop or if it is an option.
    Thank you
     

  2. Paschfire Ice Cream Sandwich Mar 21, 2018

    Last edited: Mar 21, 2018

  3. Paschfire Ice Cream Sandwich Mar 21, 2018

    Paschfire, Mar 21, 2018 :
    zatarra77

    Hi everyone,
    I'm not able to understand if, after installing the twrp, I have to flash the DM-Verity to avoid a bootloop or if it is an option.
    Thank you



    It all depends if you're going to flash root or not and want to remain encrypted.

    If yes to both, flash Root immediately after installing/boosting into TWRP recovery the first time and before booting into the OS, then no DM-Verity.zip is required.

    If no root or you want the option to Decrypt, then you must flash the DM-Verity.zip(or install a custom kernel with the DM-Verity check disabled) before booting into the OS.

    Once you Swipe in TWRP to allow modifications you must choose one or the other before booting into the OS or you will trip DM-Verity.
     

  4. zatarra77 Gingerbread Mar 21, 2018

    zatarra77, Mar 21, 2018 :
    Thank you very much.
    I'm in the first case: I want to root and remain encrypted.

    So, I have to:

    Install TWRP
    Launch TWRP
    Accept modification
    Flash root (magisk)
    Reboot

    Right?

    Bye!
     

  5. Paschfire Ice Cream Sandwich Mar 21, 2018

    Paschfire, Mar 21, 2018 :
    Yep, follow those steps exactly and you shouldn't have issues with tripping the DM-Verity check upon boot.
     

  6. zatarra77 Gingerbread Mar 21, 2018


  7. zatarra77 Gingerbread Mar 21, 2018

    zatarra77, Mar 21, 2018 :
    Please, could you confirm also that when we'll get a new OTA, I have to:
    Download the entire firmware
    Flash it on twrp
    Flash magisk (again)
    Reboot
     

  8. Paschfire Ice Cream Sandwich Mar 21, 2018

    Paschfire, Mar 21, 2018 :
    Yep sounds good. It also cannot hurt to wipe both Cache and Dalvik-Art Cache after, before finally booting into the OS.
     

    zatarra77 likes this.
  9. zatarra77 Gingerbread Mar 23, 2018

    zatarra77, Mar 23, 2018 :
    Thank you for your support. I've just finished to root my device successfully
     

  10. Paschfire Ice Cream Sandwich Mar 23, 2018

    Paschfire, Mar 23, 2018 :
    That's great news! Was happy to help, you're very welcome.

    If you ever need assistance or have a question about anything else in the future, as I'm usually lurking around somewhere so don't hesitate to ask.
     

  11. zatarra77 Gingerbread Mar 25, 2018

    zatarra77, Mar 25, 2018 :
    Thank you very much.
    Could be better to have more people like you, around.

    The purpose of my rooting is to find the worst wakelocks and kill them! Now I am looking around for the googlequicksearch tool. It is very useful but I'd prefer to slow down his wakeloks
     

  12. fcoayuso Cupcake Mar 26, 2018

    fcoayuso, Mar 26, 2018 :
    Hi Zatarra,

    I tried to follow the same steps yesterday and I ended up tripping with the DM-VERITY. Could you please elaborate on the steps you followed? This is what I tried:

    - OP3 running Oreo Oxigen 5.0.1
    - Unlock bootloader
    - Boot TWRP (dont remember the version)
    - Accept modification
    - Flash Supersu
    - Reboot device

    After the reboot, the DM-Verity warning came up and the device got stuck loading the OS.

    Finally I had to adb sideload the latest Rom available OnePlus3Oxygen_16_OTA_011_all_1607052050_0e5983ace5314161.zip to be able to use my device.

    All suggestions are welcome.

    Thanks and regards
     

  13. zatarra77 Gingerbread Mar 28, 2018

    zatarra77, Mar 28, 2018 :
    Hello!
    like said before, I downloaded magisk beta 16.2 and twrp bluespark (https://forum.xda-developers.com/oneplus-3/oneplus-3--3t-cross-device-development/kernel-t3404970).
    I have unlocked my bootloader since when I purchased the phone so now I had to change only the recovery and root it

    I installed twrp from fastboot, then launched it directly from fastboot:

    fastboot flash recovery (file name).img
    fastboot boot (file name).img

    Tapped “Never show this screen on boot again,” and swiped allow modification.

    then I flashed magisk 16.2 beta (but 16.0 stable is ok)

    wiped cache and rebooted

    that's all
     

  14. The_Rock90 Ice Cream Sandwich Mar 29, 2018

    The_Rock90, Mar 29, 2018 :
    If any one can assist, I have unlocked bootloader on 3t. Now i want to install TWRP and root the phone. But the files here on this forum are very old. Will these files work for android oreo open beta 24 or will my phone get bricked?

    If these files wont work, can anyone let me know where to find supersu/ magisk / twrp latest one which works with oreo?
     

  15. calvinhg Cupcake Mar 29, 2018

    calvinhg, Mar 29, 2018 :
    @Funk Wizard first of all thank you very much for the guide--
    second of all I've noticed a few of the files are missing or corrupted in the guide:
    • Post #2: The adb for Windows links are not working. I used this instead.
    • Post #4: The link for Unified TWRP points to a corrupted file. A quick google search provided me this.
    • Post #4: Not a file problem but the first code block is a bit confusing-- Mind changing it to `fastboot flash recovery recovery.img`, because anyway the recovery file was renamed?
    That's all for now. I may update if I find something else, as this is as far as I've gone so far. Thank you very much for the work put into this post.
     

  16. Lancelot_69 KitKat Mar 30, 2018

    Lancelot_69, Mar 30, 2018 :
    https://dl.twrp.me/oneplus3/
    Use 3.2.1
    This is Magisk
    https://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445
    Scroll down to downloads
     

  17. The_Rock90 Ice Cream Sandwich Apr 1, 2018


    Lancelot_69 likes this.
  18. RaoulW86 Cupcake May 6, 2018

    RaoulW86, May 6, 2018 :
    All of a suden my startup screen looks completely different than normal and I cant use my fingerprint. The screen is now completely black and asks for my pincode to start android.

    I thought I used the right pin, but apparently I didn't. Is there any way to unlock my phone? Via Google or something?

    I can find my phone via this link: https://www.google.com/android/find

    The best way would be if the normal start up screen would appear and I can just use my fingerprint.
     

  19. Cervantes KitKat Moderator May 6, 2018

    Cervantes, May 6, 2018 :
    Possibly you have entered the recovery, press the button to turn off. until I turn off
     

  20. RaoulW86 Cupcake May 6, 2018

    RaoulW86, May 6, 2018 :
    Thnx for helping. I pressed power button untill it turned off. And now I turned it on again, but unfortunately I got the same screen again. And I only got 3 attempts left.