111
[GUIDE] OnePlus 3T: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup and More !!

  1. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    Honestly, I'm not sure. I may have. It was late. I don't remember. I can still get into TWRP. What do I do next?
     

  2. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    Yes. I chose to format data. Now when I turn the phone on, it gives the "dm-verity is not started in enforcing mode and may not work properly." error then sits at the OnePlus (Powered by Android) screen forever. What can I do?
     

  3. Praty_28 Jelly Bean May 27, 2018


  4. Praty_28 Jelly Bean May 27, 2018

    Praty_28, May 27, 2018 :
    Carefully read every step and follow accordingly dont flash stuff hastily or you'll end up bricking your device.
     

  5. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    I followed every step and read every warning. Believe me, I took my time. I'm not sure what went wrong. It may not be obvious, but I'm a complete novice when it comes to this stuff. I can figure out most of it by following instructions, but I know nothing about how all this works exactly.
     
    Last edited: May 27, 2018

  6. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    Well, this morning I had a new development. So last night I had left the phone plugged in and sitting on the OnePlus logo just to see if it was just taking forever to do something. I woke up 3+ hours later to see it was still sitting on the logo screen.

    This morning, I turned it on and went through the first two prompts about it being unlocked and the dm-verity message, then it got to a screen where it wanted to confirm that I wanted to wipe the data, so I confirmed. It rebooted and I went back into TWRP. I tried installing the dm-verity and SuperSU and they both worked with no errors.

    Now when I boot up my phone and get past the two initials screens ("unlocked" and "dm-verity") it gets to these screens and I'm not sure what I'm supposed to do next. https://imgur.com/a/uS9ItUu (Sorry for the bad quality. Had to bust out my old Note 3 to take the pictures.)
     

  7. Praty_28 Jelly Bean May 27, 2018

    Praty_28, May 27, 2018 :
    Thats the stock recovery, somehow your twrp got overwritten. Did you try the thread i suggested to fix dm verity?
     

    asoileau83 likes this.
  8. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    I have not yet because I wasn't sure if the new development as of this morning might change anything. I will follow them now. Thank you.

    FYI, none of this guy's links work on the XDA forum post so I'm having to go find them myself. Also, his instructions are very brief and not very detailed so I hope I'm able to follow them. For example, when he says "flash and boot", I'm not sure exactly what steps I take to do that. Again, I'm a novice at this.
     
    Last edited: May 27, 2018

  9. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    I tried following the guide. I got as far as installing OxygenOS but it keeps failing around 50%. I tried the version 4.0.2 that the guy linked to (his link was broken so I downloaded direclty from OnePlus), then I tried the latest version (5.0.1). Both fail around 50%.

    I'm not sure what else to do, and now that I've done the complete wipe of data I don't think TWRP is even on my phone anymore. What should I do?
     

  10. asoileau83 Cupcake May 27, 2018

    asoileau83, May 27, 2018 :
    Um. Well, I just made some progress. I successfully executed "flashboot flash recovery <twrp recover>.img", then went into TWRP and only installed SuperSU, then went into the recovery and successfully sideloaded OxygenOs v. 5.0.1. (probably missed reporting a step I did somewhere in there) FINALLY!!!! Now the dm-verity warning is gone and it has loaded into OxygenOs. I'll see how it goes from here and keep you posted.

    Thank you, Praty_28, for your help. I've never really relied on posting to forums for urgent help and I was really in a bind in this situation, so thank you very much for all your responses.

    Let me just say, that OTG cable was a very good investment! I bought for loading movies off a USB flash drive when I went on trips and have yet to use it for that (usually load a few movies on my tablet). This is the first time I've used it and I'm so happy I bought it and didn't have to scramble to order it now and wait for it to be delivered!
     
    Last edited: May 27, 2018

    Praty_28 likes this.
  11. Praty_28 Jelly Bean May 28, 2018

    Praty_28, May 28, 2018 :
    I'm glad i could help. But you did most of it by yourself thats great! Also if you didn't have an OTG cable you could also use mtp with your pc/laptop. Twrp is compatible with both otg and mtp. Quick tip- from now on, always use the backup feature in twrp before flashing anything, it takes a while to backup but its totally worth it. You can restore all your partitions when something goes wrong.
     

  12. asoileau83 Cupcake May 29, 2018

    asoileau83, May 29, 2018 :
    Well, I ran into issues consistently getting MTP to work to my PC. It's probably an issue with Windows 10, but it didn't always detect that the device was plugged in. The OTG cable was a life saver after I wiped the data in TWRP and started getting the "unable to mount /data" errors.
     

    Praty_28 likes this.
  13. asoileau83 Cupcake May 29, 2018

    asoileau83, May 29, 2018 :
    So now that I'm back up in the OS and installing all my apps... I went to install SuperSU and RootChecker. My ultimate goal was to get Better Battery Stats installed so I could figure out what app is draining my battery - I used to get 3 days of battery life, but it dropped down to 1-1.5 days recently. It requires root access... or to run some adb commands to give it heightened permissions, so I chose to go the rooted route.

    When I installed SuperSU and Better Battery Stats, they both said my device isn't rooted. :eek: I rebooted and confirmed that I'm getting the "your device is unlocked" message on boot, and the LastPass app said it detected that my phone is rooted. What am I missing? Should I go through the steps again or re-do a particular step?

    Thanks again!
     

  14. Praty_28 Jelly Bean May 30, 2018

    Praty_28, May 30, 2018 :
    I've stopped using supersu long time ago maybe you downloaded an older version idk... You should try magisk, its kind of an alternative to supersu to gain root access but with bonus features. You could also hide root from apps using magisk manager. Here's the link for it https://www.google.co.in/amp/s/foru...-magisk-v7-universal-systemless-t3473445/amp/
    Just flash the zip in twrp and you're good to go.
    Install root checker app to check for root access. About last pass probably it checked your bootloader status, as a result of an unlocked bootloader it determined that your device might have root access. Try root checker first from play store then flash magisk if you didn't see root access.
     

  15. RyxeL Cupcake Jul 12, 2018

    RyxeL, Jul 12, 2018 :
    I have following the step for unlocking bootloader and flashing TWRP but after flashing TWRP, it ask me for a password. then I provide my old lockscreen password it says "decrypt took too long, killing process. failed to decrypt data". any solution for this?
     
    Last edited: Jul 12, 2018

  16. antillbt Cupcake Jul 15, 2018

    antillbt, Jul 15, 2018 :
    Wondering if I could get some help here:

    After having rooted my phone via your guide using magisk everything was working swimmingly for about an hour and through a couple reboots. But seemingly randomly, I rebooted and got caught in what I assume was a bootloop? My phone would only boot to recovery. Unfortunately the backup I created was also missing... I have sideloaded a stock rom but am left confused. Can anyone shed some light on my problems?

    Thanks!
     

  17. antillbt Cupcake Jul 15, 2018

    antillbt, Jul 15, 2018 :
    As a followup to my last; after completing this step "Go to “Wipe” section and tap “Format Data”, and type “yes” (If you want to mount internal storage)." I notice that the backup I created is gone and any zip I transferred into my internal storage is also gone. Am I doing something wrong here?
     

  18. TiagoJacob Cupcake Aug 5, 2018

    TiagoJacob, Aug 5, 2018 :
    So I tried to Root by following all the steps shown here. I also did the dm-verity and choose the last available, number 6 I think. And now I have a problem.
    When the phone reboots it shows the message that the device is unlocked and cannot be trusted. Then the OP logo shows up and another screen pops up showing that dm verity not started in enforcing mode and it goes straight to fastboot screen. And it goes on and on.
    How to solve this?
    I have the OP3T with Oreo 8.0.0 installed.

    Thank you very much for your attention
     

  19. K1534420351356 Cupcake Aug 22, 2018

    K1534420351356, Aug 22, 2018 :
    dear sir
    may I know this guide can be use for op 3 also ? I am a new user feeling like want to instal twrp and root Magisk . My phone at the moment running iOS 5.0.4 Oreo.
    thanks in advance
     

  20. matthu.2711 Honeycomb Sep 6, 2018

    matthu.2711, Sep 6, 2018 :
    I have installed Twrp and magisk. I wiped the data through Twrp but now can't flash OOS. Every time I try it fails.