[GUIDE] OnePlus 5: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup and More !!

  1. IzunaKatsu
    Cupcake Feb 20, 2018

    IzunaKatsu , Feb 20, 2018 :
    This guide doesn't work at all for me. There's no way to 'install' adb or fastboot without the screen flashing and going away.

    Devices aren't coming up at all, and I've tried various other tools to install these unspecified drivers that I need either.

    This guide is very lacking in detail when it comes to obtaining the correct drivers and setup.

  2. just_oneplusone
    Cupcake Mar 7, 2018

  3. L23de
    Cupcake Apr 4, 2018

    L23de , Apr 4, 2018 :
    When I try installing the ADB and Fastboot application from the steps prior to bootloader unlocking, I get 'Access denied' when I run it (Refer to picture). How should I proceed from here? Thank you very much!

    Attached Files:

  4. AlexandreP
    Honeycomb Apr 8, 2018

    AlexandreP , Apr 8, 2018 :
    Hi! -- You have to run the installer as administrator to proper install ADB and Fastboot.

  5. Notto
    Donut Apr 14, 2018

    Notto , Apr 14, 2018 :
    OK so followed the guide and phone boots to black screen with white led.

    I can get into TWRP.

    also has slighly annoying bootloader (oem) unlocked warning message.

    What am i missing here?

    So basically i had to reflash back to stock and re do it.

    Using Magisk for the Root and it works.
    Last edited: Apr 14, 2018

  6. Wackencorpse
    KitKat May 3, 2018

    Wackencorpse , May 3, 2018 :
    I got a little problem right now and I don't know the solution, perhaps someone can help me out. I got an open bootloader and flashed the newest [black themed] codeworkx twrp, magisk v16.0 and got the newest OxygenOS OpenBeta right now. Everytime I open TWRP I got the message: "Failed to mount /Vendor (invalid argument)".

    Can someone explain this to me and tell me how to solve?

  7. AlexandreP
    Honeycomb May 3, 2018

    AlexandreP , May 3, 2018 :
    Hi! -- You can ignore this message.

    Codeworkx's TWRP has been updated to take into account a "/vendor" partition if it exists on the device. The "/vendor" partition is created only if you ever flash a ROM that would unofficially enable Project Treble on your device (at the moment, only MoKee Treble can be enabled when flashing OxygenOS 5.1.5 and later, and OOS Open Beta 13 and later). That way, TWRP is able to manage a trebelized OP5/OP5T.

    If your device is not Treble-compatible (read: you have never flashed MoKee OOS 5.1.5+ or OOS OB14+), then the "/vendor" partition does not exist, thus TWRP cannot mount it. So you can simply ignore the message.

    Read more here and here.
    Last edited: Aug 29, 2018

    Wackencorpse likes this.
  8. G_pradip_sonara_WFiV
    Cupcake Jul 14, 2018

  9. Waveform Modifier
    Marshmallow Jul 14, 2018

  10. MentalDraco
    Marshmallow Jul 14, 2018

    borft likes this.
  11. Cervantes
    Lollipop Moderator Jul 14, 2018

    Cervantes , Jul 14, 2018 :
    Please read the first post
    You can review the forum or use the theme search

    G_pradip_sonara_WFiV likes this.
  12. bigjailerman
    Cupcake Aug 27, 2018

    bigjailerman , Aug 27, 2018 :
    Hi guys, I don't know if it's stated before but having a bit of difficulty. I can connect my opo5 to ADB on laptop (Windows 10), but cannot connect to fastboot. I try rebooting phone into bootloader, the os, booting phone into bootloader through ADB, restarted the laptop, uninstalled and reinstalled drivers, downloaded ADB tools. And never connected to fastboot. I installed adb/fastboot several times using admin privileges. I even put it in different folder. Again ADB connects, not fastboot. Phone is set correctly debugging .One unlocking etc. . Any help is greatly appreciated. Trying to unlock bootloader and install twrp... Should be easy lol

  13. npatelli96
    Honeycomb Oct 19, 2018

    npatelli96 , Oct 19, 2018 :
    For my part, I'm unable to mount the storage with TWRP 3.2.3-0, but it works fine with 3.2.1-1 ;)

  14. Crystalceo
    Cupcake Dec 24, 2018

  15. Matias Lioni
    Cupcake Apr 24, 2019

    Matias Lioni , Apr 24, 2019 :
    Hi, my oneplus5 turned the screen freeze yesterday. So, I can't unlock bootloader becouse I can't type my password code. Is there any way to unlock my phone?? I'm desesperate because I haven't enought money to buy a new phone. Thanks for your help and sorry about my bad english, I'm just learning the language haha

  16. Shahzeb_Pathan
    Cupcake May 16, 2019

    Shahzeb_Pathan , May 16, 2019 :
    i am using oos 5.1.7(8.1 oreo) when i am flashing magisk it show "updater process ended with error 1"
    help me

  17. EmirSc
    Donut Sep 20, 2019

    EmirSc , Sep 20, 2019 :
    thank you so much, working fine, just updated to OxygenOS 9.0.8 + Magisk


  18. MarkosMark
    Donut Mar 17, 2020

    MarkosMark , Mar 17, 2020 :
    How does an OTA update work after the device is rooted? My phone detected that it is rooted and said it would download the full upgrade package. @Funk Wizard , maybe you could add how to do this to the startpost?
    Should I do something like this?
    1. reboot recovery
    2. flash the downloaded OTA (how can I confirm the downloaded file in .Ota is the full OTA update?)
    3. reboot recovery
    4. flash magisk
    5. reboot system

    Or do I need to flash TWRP again? Will this do a factory reset?

    And another question, I have the original TWRP, should I use the blu_spark version?

  19. tarfeef101
    Cupcake Jun 18, 2020

    tarfeef101 , Jun 18, 2020 :
    I've used the following process to OTA update my OP5 for a couple years

    1) download and install update OTA when prompted
    2) after reboot, fastboot flash TWRP
    3) either ADB sideload or TWRP flash magisk
    4) continue usage, all data intact. Expect this one awkward time when I screwed it up and messed up my data partition, that wasn't very fun.