[GUIDE] OnePlus 5: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup and More !!

  1. G_Jo_Jo_oAdY Gingerbread Jun 24, 2017

    G_Jo_Jo_oAdY, Jun 24, 2017 :
    twrp-3.1.1-0-oneplus5.img link just posted by Funk Wizard

    1+T4me likes this.
  2. bombalicious Froyo Jun 24, 2017

    bombalicious, Jun 24, 2017 :
    Before the OP5, I had an OPO. I unlocked and rooted that phone and tried many different ROMs. I am thinking of not unlocking and rooting my device. The only reason for me to root it, would be to use Adaway. What would you guys suggest I do?
    For instance, should I unlock it now, cause at the moment the phone is "fresh" and wiping data is not a real problem? What are your biggest reasons for unlocking or/and rooting the device?

    collin5022 likes this.
  3. 1+T4me Gingerbread Jun 24, 2017

    1+T4me, Jun 24, 2017 :
    Great: so f2fs for cache & data only:
    # mount point   fstype  device                                    device2                flags
    /boot            emmc    /dev/block/bootdevice/by-name/boot
    /cache            f2fs    /dev/block/bootdevice/by-name/cache
    /data            f2fs    /dev/block/bootdevice/by-name/userdata                        flags=encryptable=footer;length=-16384
    /misc            emmc    /dev/block/bootdevice/by-name/misc
    /recovery        emmc    /dev/block/bootdevice/by-name/recovery                        flags=backup=1
    /system            ext4    /dev/block/bootdevice/by-name/system
    /system_image    emmc    /dev/block/bootdevice/by-name/system
    /efs1            emmc    /dev/block/bootdevice/by-name/modemst1                        flags=backup=1;display=EFS
    /efs2            emmc    /dev/block/bootdevice/by-name/modemst2                        flags=backup=1;subpartitionof=/efs1
    /efsg           emmc    /dev/block/bootdevice/by-name/fsg                           flags=backup=1;subpartitionof=/efs1
    /efsc           emmc    /dev/block/bootdevice/by-name/fsc                           flags=backup=1;subpartitionof=/efs1
    # Removable storage
    /usb_otg        vfat    /dev/block/sdg1                            /dev/block/sdg        flags=display="USB-OTG";storage;wipeingui;removable

    Funk Wizard likes this.
  4. toughiee Cupcake Jun 24, 2017

    toughiee, Jun 24, 2017 :
    Thanks worked perfectly
    BL unlocked + TWRP installed + Magisk Beta

    1+T4me likes this.
  5. Funk Wizard Lollipop Moderator Jun 24, 2017

    Funk Wizard, Jun 24, 2017 :
    For all those who have twrp, whats your average twrp load time from the splash screen ?

  6. mattou78400 Cupcake Jun 24, 2017

    mattou78400, Jun 24, 2017 :
    Hello gentlemen,

    I followed this thread step by step but I have a few point I can't find any answer for...

    - Once flashed, when first booting into TWRP, he asks me for a password to decrypt "stuff" (???), I tried anything, nothing seems to fit. it seems to go away after flashing the "no-verity" thingy but comes back after a reboot.
    - I managed to flash everything magisk included. but now, my phone seems to not be able to "use" it's memory. if I download something, then look for it with any file explorer, there are no folders, no files, no nothing anywhere. I tried taking apicture with the camera, even though it tkes it, when clicking the latest picture (bottom right bubble), it says "No picture".

    Guys I'm a little bit confused, any help would be greatly appreciated, I can't wait to use it every day :)

    EDIT: Also, I was thinking about maybe factory reset it (like flashing the original firmware), anyone knows how to do so and whether it would help?

  7. jejehtc Gingerbread Jun 24, 2017

    jejehtc, Jun 24, 2017 :

    I want to have a precision, if I unlock my bootloader and install a root and I keep a stock recovery.

    I will receive future OTA and they will install via stock recovery normally?

  8. Funk Wizard Lollipop Moderator Jun 24, 2017

    Funk Wizard, Jun 24, 2017 :
    Please try remove all pin/password/pattern from OS and then try to boot into twrp, looks like your twrp is having problems to decrypt your data.

    what comes back after reboot, perhaps a screenshot or photo could be better, if you are talking about secure boot screen, that will be there as we have unlocked the bootloader and there is no way to remove it

    Looks like you've done something wrong, hope you've not flashed su and magisk both.

    As far as factory reset in concerned you can either do it from twrp or from the OS in settings.

    Let me make it clear once you are rooted, you have to flash the full zip to upgrade the OS, OTA flash will fail as we have made modifications to the system partition.

    collin5022 likes this.
  9. jejehtc Gingerbread Jun 24, 2017

  10. Funk Wizard Lollipop Moderator Jun 24, 2017

  11. tabington Froyo Jun 24, 2017

    tabington, Jun 24, 2017 :
    Is there a way to protect TWRP so that when we update we don't have to fastboot flash it over again? I know there was a setting in the OP2 at least, but I can't find it in developer options here.

  12. G_EVR Honeycomb Jun 24, 2017

    G_EVR, Jun 24, 2017 :
    Which version of TWRP is this? The closed-source Chinese one or the open source one from the xda TWRP (testing) thread?

  13. Funk Wizard Lollipop Moderator Jun 24, 2017

    Funk Wizard, Jun 24, 2017 :
    All you have to do is to flash the full zip whenever an update come and flash supersu/magisk after that, twrp will stay.
    I will release the update thread once OTA is out

  14. Funk Wizard Lollipop Moderator Jun 24, 2017

    Funk Wizard, Jun 24, 2017 :
    Closed Source from China as that one is the only one working properly for now

    G_EVR likes this.
  15. ashishpadave Cupcake Jun 24, 2017

    ashishpadave, Jun 24, 2017 :
    Any idea why I keep getting 'download size is more than max allowed' error when flashing recovery?
    PFA screen shot.

    Attached Files:

  16. onirikon Honeycomb Jun 24, 2017

    onirikon, Jun 24, 2017 :
    It seems an old version of fastboot.exe..

  17. nora.pit Cupcake Jun 25, 2017

    nora.pit, Jun 25, 2017 :
    Hello, when you say ''Rename the recovery file that you downloaded above to recovery.img. '' what is the recovery ? the stock-recovery.img or twrp?

  18. Funk Wizard Lollipop Moderator Jun 25, 2017

    Funk Wizard, Jun 25, 2017 :
    TWRP, we are flashing TWRP so rename it or just use the current name. Copy paste the name and flash it
    Fastboot flash recovery (recovery name).img

  19. G_Jo_Jo_oAdY Gingerbread Jun 26, 2017

    G_Jo_Jo_oAdY, Jun 26, 2017 :
    Hello everybody !

    Yesterday I flashed the full 4.5.2 with TWRP everything went well except that when I reboot and want to flash Super SU there was no more TWRP but the stock recovery One +

    I used TOOL ALL IN ONE to install TWRP again : Unlocked Ok But not for Select Phone One Plus 5 : No device, i didn't changed nothing in the process.

    So I can no longer install TWRP and don't be able to flash Super SU.

    Anyone have an Idea?
    Last edited: Jun 26, 2017

  20. G_Jo_Jo_oAdY Gingerbread Jun 26, 2017

    G_Jo_Jo_oAdY, Jun 26, 2017 :
    Hey !

    There is an explaination for TWRP :
    When the twrp is booted for the first time it automatically delete or hide the stock recovery so if you flash the twrp and you boot directly from fastboot to twrp, the twrp will survive but if you flash the twrp and power one normally the phone the stock recovery will be restored.
    So when you flash the twrp, directly boot in it, from the tool you need to check "And boot it" option to boot it directly after flash.

    But not for Select Phone One Plus 5 : No device
    Last edited: Jun 26, 2017