[GUIDE] OnePlus 5: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup and More !!

  1. G_唐佳鑫_ReYK
    Cupcake Jul 4, 2017

    G_唐佳鑫_ReYK , Jul 4, 2017 :
    Does your op3t and op5 stick to the membrane? Feel the phone is very difficult to film! And what do you think is the most appropriate font size and dpi? @Funk Wizard

  2. liwei710
    Cupcake Jul 4, 2017

    liwei710 , Jul 4, 2017 :
    very thanks you guide, i do it step by step, and success root it, but
    don't download anything , don't camara it. it said no SD card.
    in the TWRP, not show "internal SD" item in TWRP 3.1.1 "mount" menu.
    Please help me, thanks.

  3. Funk Wizard
    Lollipop Moderator Jul 4, 2017

    Funk Wizard , Jul 4, 2017 :
    I use smallest display size and default screen size, dpi is 380 fyi

  4. liwei710
    Cupcake Jul 5, 2017

  5. zx322a
    Eclair Jul 5, 2017

  6. Funk Wizard
    Lollipop Moderator Jul 5, 2017

    Funk Wizard , Jul 5, 2017 :
    There is a detailed thread already running in development section, thread merged as duplicate.
    Please continue discussion on the development section

  7. Funk Wizard
    Lollipop Moderator Jul 5, 2017

    Δημήτρης likes this.
  8. _DEDSEC_
    Jelly Bean Jul 5, 2017

    _DEDSEC_ , Jul 5, 2017 :
    Oh, sorry I forgot to check there [e]1f601[/e]. Cheers.

  9. sandeeppathak007
    Ice Cream Sandwich Jul 5, 2017

    sandeeppathak007 , Jul 5, 2017 :
    How do you change the dpi , also I flashed the super super but it does not detect the roo on some apps while it works on some apps .
    Next query I have is that I have 4.5.3 so how do I upgrade to 4.5.5?

  10. Funk Wizard
    Lollipop Moderator Jul 7, 2017

  11. Shreyans22
    Cupcake Jul 8, 2017

    Shreyans22 , Jul 8, 2017 :
    Hi guys,
    I received the update for OOS 4.5.5. After downloading it, it took me to TWRP where the zip file was flashed. But since then the phone is in bootloop only. I have tried to download the rom again from oneplus site and flashed it again in TWRP but it did not work.
    Any help would be appreciated.

  12. 1+T4me
    Gingerbread Jul 9, 2017

    1+T4me , Jul 9, 2017 :
    @Funk Wizard , please, can you confirm that modemst1&2.bin are 2097152 bytes size , I'm new to op stuff and know how vitals are efs backups.

  13. papolytic
    Gingerbread Jul 9, 2017

    papolytic , Jul 9, 2017 :
    Yes, that's the correct size.

    1+T4me likes this.
  14. LukaVA
    Gingerbread Jul 10, 2017

    LukaVA , Jul 10, 2017 :
    Hmmm, I cant seem to flash TWRP....
    I keep getting the error:
    target reported max download size of 536870912 bytes
    sending 'recovery' (24496 KB)...
    FAILED (remote: Requested download size is more than max allowed
    finished. total time: 0.008s
    Any help?

  15. iRajeshRajput
    Honeycomb Jul 10, 2017

    iRajeshRajput , Jul 10, 2017 :
    Follow this guide, you can find the video there.

    Root Oneplus 5 and Install TWRP

  16. papolytic
    Gingerbread Jul 10, 2017

    papolytic , Jul 10, 2017 :
    2 things come to mind:

    1) You've downloaded a version of TWRP that used a slightly long naming convention like "TWRP-3.1.1-1 (some other stuff).img. If so: Rename it to "recovery.img" before "fastboot flash recovery recovery.img".

    2) You've got a limited version of fastboot.exe / fastboot . If I can attach mine, I'll do that. Mine is from W10 / W7 so keep that in mind: If I can upload it it'll be at the end of this reply.

    If you don't want to trust the uploaded file, then get one from a thread like this: https://forum.xda-developers.com/moto-x/moto-x-qa/max-download-size-error-fastboot-img-t2527287

    Also , of course, unzip fastboot.zip -> fastboot.exe and either use it directly (from it's path) or rename the old one and replace it with this.

    Attached Files:

  17. darkforce82
    Cupcake Jul 10, 2017

    darkforce82 , Jul 10, 2017 :
    I am having problems executing this.

    I unlocked my phone fine using the aforementioned method. As can be seen below.
    Then I got stuck at flashing TWRP, I keep trying the same command but got various of error messages, sometimes it got complete stuck and I had to reboot into bootloader to make it responsive.


    I read through the thread and seems someone mentioned the problem before, but no one seem to suggest a viable solution for now, can someone technically savy have a look into this please.


    Attached Files:

  18. darkforce82
    Cupcake Jul 10, 2017

    darkforce82 , Jul 10, 2017 :
    Problem solved.

    To clarify what I have done:

    1. I switched to another lightly used PC with not many software/drivers installed
    2. I uninstalled any Android drivers that I can found on that PC
    3. I followed this guide
    That's it.

    Last edited by a moderator: Jul 24, 2017

    papolytic likes this.
  19. Funk Wizard
    Lollipop Moderator Jul 10, 2017

  20. LukaVA
    Gingerbread Jul 11, 2017

    LukaVA , Jul 11, 2017 :
    None of that helped. Thanks anyways.