59

[GUIDE] OnePlus 5: How to Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup and More !!

  1. agrillo Cupcake Sep 4, 2017

    agrillo, Sep 4, 2017 :
    I have a similar problem with TWRP, because I did bootloader unlock, follow the procedure to install the TWRP, I install it I reboot with the command "fastboot boot". Recovery opens and works, but at the next reboot I see the recovery stock !!! How can I fix the problem?
    Thank you all
     

  2. schlaf Cupcake Sep 10, 2017

    schlaf, Sep 10, 2017 :
    so I did all that how do I relock bootloader tried lock via ADB
    still won't work
     

  3. G_Alan_James_Caruana_QhX Cupcake Sep 11, 2017

    G_Alan_James_Caruana_QhX, Sep 11, 2017 :
    hi, I encountered an issue when trying to unlock my OP5. I rebooted the device into fastboot mode, and it is recognised by fastboot. However, when trying to unlock the bootloader I am getting the following error:

    C:\adb>fastboot oem unlock
    ...
    FAILED (remote: Flashing Unlock is not allowed
    )
    finished. total time: 0.001s

    Can anyone help me?
     

  4. shaantara Donut Sep 12, 2017

    shaantara, Sep 12, 2017 :
    hi guys, I lost the IMEI and baseband of my OP5 after it fell from my hand. does anyone have the EFS partition backup. If yes, please send it to me...
     

  5. sarang Bakshi Ice Cream Sandwich Sep 12, 2017


  6. ivivdim Gingerbread Sep 12, 2017

    ivivdim, Sep 12, 2017 :
    All my updates were "dirty" - there were no problem. You are rooted, so you have to flash the full zip (about 1.5GB). If you make a nandroid backup you will have to remove the screen lock (no lock or only slide) and set again some more secure lock after the update.
    By the way for update i recomend you to use Oxygen Updater - a free app from Playstore.
     

    sarang Bakshi likes this.
  7. sarang Bakshi Ice Cream Sandwich Sep 15, 2017

    sarang Bakshi, Sep 15, 2017 :
    I dirty flashed the latest update, but now my root is gone (I have magisk installed) and my custom recovery too has gone.
    What to do.
     

  8. ivivdim Gingerbread Sep 15, 2017

    ivivdim, Sep 15, 2017 :
    When you flash the update you have to flash after that again the magisk (before the first reboot). This time you have missed this step, so you have to install again the custom recovery and after that to flash again the update file and magisk (without rebooting between them) .
     

  9. Twister_NL Cupcake Sep 15, 2017

    Twister_NL, Sep 15, 2017 :
    Help! I downloaded the ADB file, and I successfully unlocked my bootloader. Now you have to flash TWRP, but that doesn't work.
    Yes:
    - TWRP is in the same folder.
    - I tried renaming it to recovery.img and TWRP.img
    - I use the latest official TWRP version.

    Edit: After many tries there came up alot of sentences but there wasn't a message with "Finished" or something like that.

    After I saw all that I disconnected my phone from the computer and manually booted it in recovery mode just to check if it was flashed or not. And no, it booted in the stock recovery mode.
     
    Last edited: Sep 16, 2017

  10. AlexandreP Honeycomb Oct 4, 2017

    AlexandreP, Oct 4, 2017 :
    So if I read you correctly:
    1. Flash the full signed OTA -- do I flash it through TWRP? or can I go through Settings --> System updates?
    2. I guess the task has to be done in TWRP, because then you say after flashing the OTA, one should flash again Magisk before even rebooting in OOS. But if I flash Magisk before rebooting, do I need to flash TWRP again? How come flashing Magisk would prevent the stock recovery to be installed again?

    Thanks!
     

  11. ivivdim Gingerbread Oct 4, 2017

    ivivdim, Oct 4, 2017 :
    After unlocking the bootloader and flashing TWRP I have already flashed several updates (full signed OTAs) in TWRP and after that SuperSU (before rebooting the phone). Up to now I didn't lose my TWRP, so I know that this method works perfectly.
     

    AlexandreP likes this.
  12. v0 HaVoK 0v Ice Cream Sandwich Oct 14, 2017

    v0 HaVoK 0v, Oct 14, 2017 :
    When making backups, what should you select? on my old phones I never had so many options, but now I have extra things to backup like recovery system image and modem ( I used to just backup boot, system, and data)
    I backed up everything just to be on the safe side from my stock rom, but for flashing and changing between other roms would it be ok to just backup boot, system, and data?
     

  13. PuxicoRG Cupcake Oct 18, 2017

    PuxicoRG, Oct 18, 2017 :
    Alexandre, did you get this figured out? I just updated yesterday and lost my root as well (previously attained using Magisk.) I'm trying to determine if it's worth re-rooting or not. To be honest, I'm not even sure yet if my boot loader is still unlocked or not. Am I going to end up wiping my phone clean if I root again? Because, if so, I'm not likely to go through it. (The phone is awesome, though - I've had it for 3 weeks, and it's great!)
     

  14. AlexandreP Honeycomb Oct 19, 2017

    AlexandreP, Oct 19, 2017 :
    Hi!
    I simply followed @ivivdim 's instructions (up), and it did work.
    As my phone was rooted, the System update tool detected it and downloaded the full signed ZIP in the .Ota folder of internal storage. When I noticed the download was complete, I did not apply the update through Settings --> System update. I rebooted to TWRP. While in TWRP, I flashed the full zip first, and chained Magisk's zip. When both ZIPs were flashed, only then I rebooted to system. I confirm TWRP was left untouched.

    If you see a 5-seconds warning when you boot your phone saying that "Your device has been unlocked and can't be trusted [...]", your bootloader is still unlocked.

    No, if you root again after dirty-flashing full signed ZIP, you will not lose any data. (I would still recommand to first make a nandroid backup, and/or make sure you do have a copy of important settings, information and files somewhere outside your phone, just in case. But if you do things properly, you won't lose data.)
     

  15. sarang Bakshi Ice Cream Sandwich Oct 20, 2017

    sarang Bakshi, Oct 20, 2017 :
    Will my data get wiped again like it did the first time while unlocking the bootloader.
    Can you please take some time to give more detailed steps I need to take. I don't want to mess up my op5
     

  16. ivivdim Gingerbread Oct 20, 2017

    ivivdim, Oct 20, 2017 :
    Flashing TWRP recovery (if you have lost it) will not erase your data. See post 3 from this thread for more information. If after that you decide to make nandroid backup (before applying the new update) you first have to boot normally your phone, to download the full OTA update file (i personally use Oxygen updater - a free application from Playstore to download it), download also suppersu (or magisk) in root (the main) directory and before reboot in TWRP don't forget to remove any phone lock (fingerprint or pattern etc) and set the screen protection to No or Slide (this step is important if for some reason you will have to restore the nandroid backup).
    Now reboot in TWRP, select Backup option and make the backup. Go back in main TWRP menu and go to Install option. Browse to update file and flash it. When the installation is done go back, chose suppersu (or magisk) zip and flash it. Now you are ready to reboot your phone.
    If you feel some uncertainty about using TWRP options I suggest you to find some videos in YouTube.
     

  17. Bullo Oka Honeycomb Oct 27, 2017

    Bullo Oka, Oct 27, 2017 :
    is there any other method to just root our device, without data wipe and without replacing the recovery.
     

  18. ivivdim Gingerbread Oct 28, 2017

    ivivdim, Oct 28, 2017 :
    If you find such a method let us now please ;)
     

  19. Bullo Oka Honeycomb Oct 28, 2017


  20. richardb20 Eclair Nov 8, 2017

    richardb20, Nov 8, 2017 :
    HELP please. I thought I did all the steps just right, no errors. TWRP seems to work OK, but when I try to boot, I see the normal Android logo, and the screen goes dark and the blue top-left notification light is lit. The phone stays in this state for a long long time.

    I must have missed something - anyone know?

    R.