Guide to FLASH 3.5.2 Community Update with working TWRP recovery.

  1. kniVesss
    Jelly Bean Sep 16, 2016

    kniVesss , Sep 16, 2016 :

  2. PCesar.Cercal
    KitKat Sep 16, 2016

    PCesar.Cercal , Sep 16, 2016 :
    No, Just flash te recovery, then flash rom

  3. mlavende
    Cupcake Sep 16, 2016

    mlavende , Sep 16, 2016 :
    Oooh, this sounds like something I want to try. I've only had my phone 3 days :)

    I'm rooted with Magisk Systemless so will this still work ok as well or do I need to reinstall all that stuff? I have a TWRP backup so presumably I can just restore that if it all goes wrong?

    I understand I need the modded TWRP first



  4. Schrotty40
    Honeycomb Sep 16, 2016

    Schrotty40 , Sep 16, 2016 :
    I have install the Rom and working fine but i have a big problem. I can not return to my Backup. I have make full wipe and restore my cm backup but the Phone not booting. See only the One Logo and after this a black screen.

  5. ungeeked
    Ice Cream Sandwich Sep 16, 2016

    ungeeked , Sep 16, 2016 :
    Quick question, if I flash the unmodified ROM with stock recovery, will I be able to flash twrp later?

  6. kiki052
    Cupcake Sep 16, 2016

    kiki052 , Sep 16, 2016 :
    hello everybody,

    I have a big probleme !! :'(

    I have installed a new update 3.5.2 ..OKAY but impossible to install TWRP RECOVERY...
    Installation by fastboot..OKAY but this phone but on screen black before to do hard reboot :mad:

    and i have this msg when i want downgrade in 3.2.4

    help me please

    Attached Files:

  7. Deities
    Cupcake Sep 16, 2016

    Deities , Sep 16, 2016 :
    I see some people keep asking about magisk and systemless xposed, but i haven't found an answer yet. (root newbie here)

    I'm running 3.5.1 on the one plus 3 with Magisk, systemless phh root, and systemless xposed.

    Will I have to reinstall magisk and xposed every time I upgrade?

    Is there a way to update frequently while retaining the magisk and xposed setup?

  8. josefn24
    Jelly Bean Sep 16, 2016

    josefn24 , Sep 16, 2016 :
    Normally when you flash anything or update you will have to re flash xposed and su. That's the NORMAL way. However I don't know about specifically those ones. Wouldn't be the end of the world to reflash those. Anone know any different NB let me know..

  9. pawanrepswal
    Gingerbread Sep 18, 2016

    pawanrepswal , Sep 18, 2016 :
    you do not need to drag out from the zip you can do it by opening in notepad and then just save it..in this it will ask you two time to save one in notepad another in zip..then enjoy it

  10. G_Khoa_Ng_MJQE
    Cupcake Sep 18, 2016

    G_Khoa_Ng_MJQE , Sep 18, 2016 :
    I am on the unmodified 3.5.2 and want to flash twrp is that possible ? right now i have the stock recovery i cant sideload anything it just crashes at 47% and says installation failed

  11. luckyluk3
    Donut Sep 18, 2016

    luckyluk3 , Sep 18, 2016 :
    I installed the comunity build 3.5.2, but when I flash the twrp recovery nothing happens. When I want to enter the recovery I just get a black screen. Is there anything I can do to fix it?

  12. F_John_Verloop_JkgC
    Cupcake Sep 18, 2016

    F_John_Verloop_JkgC , Sep 18, 2016 :
    It also happened to me today.
    Important is to flash the twrp-3.0.2-19-oneplus3.img .
    Several times I tried to put back the stock recovery but that always went wrong. Also on my pc with usb3 no results with all the recovery images. Finally on an other pc with usb2 I got my twrp recovery back. twrp-3.0.2-19-oneplus3.img is not a very stable twrp but for reading properties it's better than nothing. Skip the backup part, it gave me a bad system backup, after restore my system hanged.

  13. Joy.sd
    Cupcake Sep 18, 2016

    Joy.sd , Sep 18, 2016 :
    I am facing one bug though, I updated the script and flashed the rom successfully but the device restarts itself on long pressing the power button, there is no menu . Someone pointed out this bug before but didnt receive any prominent reply. It would be a big help if someone could come up with a solution
    Edit :
    Even after flashing twrp first and then flashing the rom //without editing script// , the device restarts on long pressing the power key ( long press enough for the basic boot menu to show up)
    Last edited: Sep 18, 2016

  14. tubbydutta1
    Gingerbread Sep 19, 2016

    tubbydutta1 , Sep 19, 2016 :
    Than you have to install TWRP by following UNLOCK BOOT LOADER tutorial...its simply to run some commands under the fastboot mode. Just use the twrp file mentioned in the post.

  15. kniVesss
    Jelly Bean Sep 19, 2016

    kniVesss , Sep 19, 2016 :
    I think you need to change the language to fix this bug. Try American English, reboot and switch back to native language. I could be wrong, but I'm sure I see this somewhere yesterday.

  16. tubbydutta1
    Gingerbread Sep 19, 2016

    tubbydutta1 , Sep 19, 2016 :
    First of all, werent all uchihas killed by itachi and do u even sharingan?? :p

    Anyways you have to WIPE DATA or maybe clean flash, cause i also faced multiple issues regarding the OS but i wiped the cache and dalvik cache and resolved most of my issues. So try it out maybe that would resolve your issues.

  17. tubbydutta1
    Gingerbread Sep 19, 2016

    tubbydutta1 , Sep 19, 2016 :
    First of all i would recommend that go ahead and try it out on a windows 7 OS system, i have a windows 10 machine and ADB has some issues. Moreover twrp will install as a .IMG file not a zip file via fastboot, so try to extract it first as i can see you are trying to directly install from the zip.

    Do reply if this helps or not.

  18. AloCubano
    Gingerbread Sep 20, 2016

    AloCubano , Sep 20, 2016 :
    Can we flash this twrp recovery with out being via fastboot ? Via twrp for example?

  19. kniVesss
    Jelly Bean Sep 20, 2016

    kniVesss , Sep 20, 2016 :
    Yeah I guess, I used the flashify app and it worked. The version number doesn't change either way :)

  20. AloCubano
    Gingerbread Sep 20, 2016