73
Having trouble with data migration to your new phone? Try OnePlus Switch!

  1. Zugbar
    Cupcake Apr 14, 2020

    Zugbar , Apr 14, 2020 :
    I see this app works for a lot of people, but so far this has been horrible and a useless waste of time for me. Stuck at 0% indefinitely, everything ticking like it's in progress, eta whittled down to 0 minutes. Let it run at least an hour and for over 30 minutes on another attempt. Spent hours trying the various tips in forums to no avail. Rubbish and a waste of time, will try to manually transfer to my PC then up to my phone. :eek:

    Began with T-Mobile sending me to 2 "open" locations that were actually not only closed, but closed down and no longer located there...finally reaching an open location that had one hone left that I wanted, and it turned out to be broken so I couldn't by it, so I ordered online, delay with the delivery...finally got it and not can't even set the blamed thing up.

    So there's my rant! :confused::eek::(:mad:o_O
     

  2. Horsault
    Nougat Moderator Apr 14, 2020

    Horsault , Apr 14, 2020 :
    Which part didn't work? On which device? Running which ROM?
    To sum up, from which device to which device did you try so switch?
     

  3. Zugbar
    Cupcake Apr 14, 2020

    Zugbar , Apr 14, 2020 :
    Thanks for trying to help.

    I have an LG G5 trying to transfer to a OnePlus 7 Pro. I don't know how to check ROM. The LG is in Sending Data mode, 3 types of data completed, gets stuck indefinitely in progress on Apps 1/93, 2.68 GB). I also tried earlier by unchecking Apps, and it got hung up the same way on something else. Contacts/Call Logs/Messages appear complete on the sending side only because the swirling arrows become a checkmark. The Oneplus is in Receiving and Sending mode. Originally eta was 20 minutes and it counted down and stayed at 0 minutes. There's no error messages or anything to indicate it has a hold up, other than it shows it is in progress by the people throwing packages and multiple swirling arrow icons next to data types to transfer Some of them have check marks to show they completed on the sending side (but % transferred remains at 0), but it doesn't actually seem to make progress. I decided to leave it on overnight to see if anything moved forward if I leave it for several hours. But if any of that helps you to figure out what I am doing wrong, please let me know. Thanks!!!
     
    Last edited: Apr 14, 2020

  4. Horsault
    Nougat Moderator Apr 14, 2020

    Horsault , Apr 14, 2020 :
    I'd advise you to drop apps, as you can find them and reinstall them from your Google account. Anyway, you'll have to get last updates if your sending device runs older versions.
    Sometimes, countdown is bad because data amount is too important. It looks like data isn't sent as is, but treated on sending device, and on receiving device. If memory or storage is short on one end (typically sending device), or requires too much computing power, it can postpone treatment like forever.
    Try selecting only a small size data to sync, to see if it's working. It may be a good idea to sync docs first, then sounds, etc.
     

  5. Zugbar
    Cupcake Apr 14, 2020

    Zugbar , Apr 14, 2020 :
    Thanks, it worked when I send over less than a couple hundred MB at a time. For photos, I could send over by sub-folder, but some folders and many other items were too big to be broken down to smaller bits, though. I got some decent stuff over, though!
     

  6. Horsault
    Nougat Moderator Apr 14, 2020

    Horsault , via OnePlus 7T Pro , Apr 14, 2020 :
    If you don't need all your pics on your new phone, maybe you could just save some in the cloud or a computer to access them in case of need.
    This would allow you to get them on your device later, over wifi or through cable.
     

  7. Neonac
    Cupcake Apr 22, 2020

    Neonac , Apr 22, 2020 :
    This doesn't work for me. It's stuck on choose the data for your device with the two phones and the heart. Then I can't choose any data. Might this be because I installed a custom rom on my old device?
     

  8. Horsault
    Nougat Moderator Apr 22, 2020

    Horsault , Apr 22, 2020 :
    Did you grant access to storage?
     

  9. firefox16
    Eclair Apr 23, 2020

    firefox16 , Apr 23, 2020 :
    I concur with some of the others who says the Oneplus switch app does not work.
    Even more I state it does not even work between two Oneplus phones.
    Same issue here like user Zugbar reported - the transfer stuck at 0% indefinetely.
    But I managed to figure out the reason why.
    Everything works rosy until the two phones connects together.
    The connection is successful and I can select on the old phone what I want to to transfer.
    At that point if I go to the Settings I can see the old phone connected to the WLAN created by the new phone.
    If I leave it at this point the two phones stay connected together for an elongated time.

    But as soon as I hit the Start button for the transfer to start - the connection to the WLAN on the old phone immediately drops and it will never find it again.
    In the meantime the app is pretending its doing the transfer - but really nothing can transfer because there is no more connection between the two phones (indeed looking at the new phone it says the hotspot is still available but nothing is connected to it!
    So the transfer will stay at 0% until the end of days...
    Nothing helps with this issue...I can reset the app...connect again the two phones...but when hit the Start button the connection cease to exist.

    Old phone = Oneplus 3T (all vanilla factory settings, not rooted)
    New phone = Oneplus 8 Pro (just got it out of the box)

    I would love to get an answer how to get this work!!!

    Thanks in advance.
     

  10. firefox16
    Eclair Apr 23, 2020

    firefox16 , Apr 23, 2020 :

    Update - I am officially throwing away my hat here...

    I have tested one more thing...
    Let's say I only want to transfer the Applications (instead of everything) - the same issue happens what described above - the connection drops as soon as I hit the Start button.

    But if I go inside the Application and select only one particular application to transfer than it will work!!!
    I've done this twice and it worked both cases.

    That means there is nothing wrong with the phones - since I can successfully completed the transfer when I select one single thing.
    But I have hundreds off apps and thousands of photos so I can safely say I ain't going to do them one-by-one!!!

    I have seen earlier forum posts about where they say their problem was that the connection jumps back to the original Wifi or mobile data connections for some reason (so I have made the old phone to forget the home-Wifi and also switched off mobile data) but the issue is still persist.

    I did one last test - manually selecting more than one items to transfer.
    It still worked with two items...but as soon as I selected a dozen apps to transfer it goes back to drop the connection.

    So as it seems the Oneplus switch app is really bugged all the way...
     
    Last edited: Apr 23, 2020

  11. firefox16
    Eclair Apr 24, 2020

    firefox16 , Apr 24, 2020 :
    Finally figured out what might be the bug in the Oneplus Switch software.
    It was not easy because it just did not make sense that if I transfer one or two single items it works but as soon as trying en-masse transfers the connection get severed immediately as I tap on the Start button.

    So basically what happens:
    1. The Oneplus switch connection between the two phones works well initially
    2. Gets to the point to select what to transfer
    3. At this time checking the hotspot settings (the one created by the Oneplus switch s/w) on the new phone it says it's a 2.4 Ghz connection!
    4. When I hit the Start button that magically changes to 5 Ghz resulting in older phones immediately dropping the connection (the bad thing the s/w does not realize this and still pretending doing the transfer but it will stays at 0% forever since no connection)! <- so this is bug number #1
    5. So i have to go to the hotspot on the new phone change it back to 2.4 Ghz.
    6. Then go to the old phone switch off everything (Forget home-Wifi and switch off mobile data)
    7. Switch on/off Wifi - that will do a search and will find the hotspot created by the new phone
    8. At that point if it was already connected earlier will automatically reconnect and the transfer starts
    If not then you need to select the hotspot manually and enter the password given by the new phone (displayed by the Oneplus switch s/w when created the hotspot).

    I was thinking why it is the case that the connection issue does not happen in case of single files (i.e works perfectly) and only drops when initiate large transfers.
    I think this is a bug created by Oneplus software engineers that in case of a large transfer initiated (100+MB) the new phone is automatically trying to use 5GHz for better speed disregarding the fact that this obviously does not work out for older phones... <- so this is bug number #2

    To be honest I have expected a bit more quality control from Oneplus!
    Did they even try the Oneplus switch at least between the Oneplus 8 Pro and all other Oneplus phones???
    Because the s/w should be working faultless at least between their own phones!

    Anyway, I hope I could help the community.

    Kind Regards
     
    Last edited: Apr 24, 2020

  12. Anjum Anik
    Cupcake Apr 29, 2020


  13. K1535015883139
    Cupcake May 23, 2020

    K1535015883139 , May 23, 2020 :
    Thanks firefox16 - this kind of thinking helped me get the app working.

    I had airplane mode turned on, phones would see each other via hotspot, then I'd click to transfer the files and the connection would drop and stay at 0%.

    Solution?
    Manually re-connect the hotspot again... and it started transferring.

    New phone: OP 8
    Old Phone: Pixel 2XL
     

  14. geoxar
    Froyo May 27, 2020

    geoxar , via OnePlus 7T Pro , May 27, 2020 :
    Handy application, it copied all my photos, SMS and call logs without issues from Xperia XZ3 Android 10 to OnePlus 7T Pro Android 10, but it needs to be improved in terms of application transferring.

    First of all, you need to wipe cache after the transfer is completed because apps might crashing when trying to access them.

    Second and most important, transferring apps without their data is almost useless. The point is to get all the app data along with the application APK so you don't need to sign in and configure each app settings and privacy from scratch.
     

  15. Andrewsimo
    Donut Jun 17, 2020