HELP "call ended" before it rings

  1. Fredfabels
    Cupcake Nov 20, 2015

    Fredfabels , Nov 20, 2015 :
    Hi everybody!

    I Got the op x for almost two weeks now. First everything was fine, after I spent a weekend outside my country I suddenly cant make nor receive any calls. It says "call ended" before it can even ring.. I tried my settings but I doesn't seem te work, my provider says they can't help either, my sim card in another phone works fine.
    Does anyone recognise this problem or knows what is the solution? I am unreachable for 5 days now and it is terribly annoying and incredibly inconvenient considering work..

    Every advice is very much appreciated!!

  2. srm_008
    Honeycomb Nov 20, 2015

  3. Andyturff
    Cupcake Nov 28, 2015

    Andyturff , Nov 28, 2015 :
    Exactly same for me. Had my op x 10 days. All been fine. This morning can't make or receive calls. Tried sim in my old phone all works fine. Any one got any ideas?

  4. Andyturff
    Cupcake Nov 29, 2015

    Andyturff , Nov 29, 2015 :
    Update. Moved sim card to second sim position. Can make calls now but can't receive. Get a text saying I missed a call.

  5. donpablo999
    Cupcake Dec 10, 2015

  6. witnness
    Donut Dec 11, 2015

    witnness , Dec 11, 2015 :
    I had my phone for weeks now, but same issue. Suddenly when I try to call it doesn't even ring, straight goes to call ended and that was it. Internet etc works fine no issues there. I can't make any calls. Is there a solution to this issue?? Would be greatful for help. I do need my phone to make calls.

  7. Dilipkhanolkar
    Froyo Dec 11, 2015

    Dilipkhanolkar , Dec 11, 2015 :
    Are you on 2g network?

  8. Goaty
    Cupcake Jan 13, 2016

    Goaty , Jan 13, 2016 :
    Same thing is happening to me, but this "only" lasts few hours or it's fixed after reboot, but the problem reapears in minutes. I also cannot send/reecive sms (message is "sending") and also i cannot connect to mobile data... My SIM card works on other phones, but others SIMs don't on this one. And the signal bar is full.
    I'm on OPO tho.

  9. sniperswagat
    Cupcake Jan 18, 2016

    sniperswagat , Jan 18, 2016 :

    The same error is happening in my wife's One Plus X.

    Call ended as soon as she tries to call. Incoming is not a problem. Any advice?
    Country - India
    Carrier - Airtel


  10. sniperswagat
    Cupcake Jan 18, 2016

  11. Vampire-Taco-Ninja
    Cupcake Jan 19, 2016

    Vampire-Taco-Ninja , Jan 19, 2016 :
    I had the same problem but it was fixed when I restored the Access Point Name (Settings > More > Cellular Network > Access Point Name) to default setting. Also I switched the sim card to the second slot (where the micro sd card is) made a call to voice mail then putting in it the first slot again (A load menu popped up for me). Hope this works for you too. ;):)

    pa5t1s likes this.
  12. Bergdoktor
    Donut Jun 24, 2016

    Bergdoktor , Jun 24, 2016 :
    I have experienced the same issue (OPX on Germany O2 Network. No Dual SIM).
    At some random point my OPX stopps receiving calls or SMS while Data still works fine. Most of the times I don't even realize the issue until I try to make a call myself and the call is aborted immediately (even before first ring). Issue is fixed after rebooting the phone upon which I immediately receive a backlog of SMS + Info about missed calls.
    I followed @Vampire-Taco-Ninja's Advice and did what he suggested: Resetting my APN to default made my phone switch from one APN to another. (see attached Screenshot)


    Even though I don't remember ever setting it to something myself, this just might have done the trick. It's only been about an hour since I changed it, so I'm keeping my fingers crossed that the issue won't reappear at some point.

    Thanks anyway to everybody.

  13. gmsica
    Cupcake Jun 26, 2016

    gmsica , Jun 26, 2016 :
    Hi there,

    Try this:

    1) Settings > Wireless & networks > More > Cellular networks > Network operators
    2) Wait for it to scan available networks and sign in to your network again by tapping it--you may have to repeat this step a few times.
    3) Attempt making a phone call after every rescans and sign ins.

    It fixed the problem for me and hopefully it will for you.

    Got the same exact issue here in Canada (on Koodoo mobile carrier) a month and I seriously freaked out. I could use the mobile data and wi-fi, but could'nt receive nor make any phone calls and the SIM card worked fine on other phones.
    The OnePlus support told me to reset to the factory settings but I'm glad I didn't and gave the above trick a chance.

    Let me know if this worked.

  14. gringoboy
    Lollipop Jun 26, 2016

    theshinybeast likes this.
  15. theshinybeast
    Marshmallow Jun 26, 2016

  16. Nick Adams
    Froyo Jun 26, 2016

  17. theshinybeast
    Marshmallow Jun 26, 2016

  18. Nick Adams
    Froyo Jun 26, 2016

    Nick Adams , Jun 26, 2016 :
    OK, somehow funny...

    Here is the thing:: thread has been creaTed. Many others reply and confirm there is an issue. Severe. I mean hello? Phone can't receive calls!!!
    Then admin comes and moves thread to a "support forum". Other users have the same issue but can't find thread as it is hidden in the south called "support" forum.
    Angry old user comes and links each new post with the link to the thread in the "support" forum...

    Young lads cracking jokes about old and concerned user... :cool:

    gringoboy and theshinybeast like this.
  19. gringoboy
    Lollipop Jun 26, 2016

    gringoboy , Jun 26, 2016 :
    Easier if you just tagged them all in one post, like @Nick Adams. :)

    theshinybeast likes this.
  20. theshinybeast
    Marshmallow Jun 26, 2016

    Nick Adams and gringoboy like this.