0
OxygenOS help for relocking my oneplus 8 pro bootloader...

  1. T1637280467654
    Cupcake Dec 5, 2021

    T1637280467654 , Dec 5, 2021 :
    hi can anyone please guide me how to relock the bootloader on my oneplus 8 pro.

    android version is 11
    build number is oxygen os 11.0.9.9.IN11BA
    model IN2020

    i tried for the fastboot using the cmd but my device never shows up and connects with my pc.

    pls someone help me as i want to relock bootloader as i cannot use my phone for google pay as it does not allow me to use the nfc.
     

    #1
  2. BhavyaMehta0786
    Ice Cream Sandwich Dec 5, 2021

    BhavyaMehta0786 , via OnePlus 9 , Dec 5, 2021 :
    First of all, this will clear every single bit of data on your phone, so a backup is REQUIRED. Now that is out of the way:

    Are you using the cable that came in the box, 3rd party cables can sometimes be finicky. And if you're using the stock cable then try using a different cable.

    If that didn't help you then you can just manually boot into fasboot by switching your phone off and then pressing the volume UP, DOWN and the POWER keys all at once. Plug your phone into your laptop and try the command adb devices, your phone then should show up.
     

    #2
  3. Dresa91
    User of the Year 2016; Most Active User 2020 Community Expert Dec 5, 2021

    Dresa91 , Dec 5, 2021 :
    Hey,
    did you try this guide?
    https://www.getdroidtips.com/relock-bootloader-oneplus-8-and-8-pro/
     

    #3
    Caomhin likes this.
  4. T1637280467654
    Cupcake Dec 5, 2021

    T1637280467654 , Dec 5, 2021 :

    thanks for your reply but my problem is that my device when it is turned on and connected to the pc and if i use cmd and enter the adb devices than it shows me that the device is connected through cable with some random numbers, but as soon as i enter the fastboot mode in my device through the command adb reboot fastboot it goes to the fastboot mode on my deivce but after that i cannot see my device connected to the pc so even if i use command prompt for fastboot oem lock, it does nothing.
    below is the screenshot .
     

    Attached Files:


    #4
  5. T1637280467654
    Cupcake Dec 5, 2021

    Attached Files:


    #5
  6. BhavyaMehta0786
    Ice Cream Sandwich Dec 5, 2021

    BhavyaMehta0786 , via OnePlus 8 Pro , Dec 5, 2021 :
    Here's something that could potentially help, boot it into fastboot using adb, let your device boot into fastboot, then unplug and replug your device into your computer and try checking if it shows up
     

    #6
  7. BhavyaMehta0786
    Ice Cream Sandwich Dec 5, 2021

    BhavyaMehta0786 , via OnePlus 8 Pro , Dec 5, 2021 :
    Also try using a different cable, cables have been a common variable for shoddy adb and fastboot connectivity, not just for me but for several others on the internet too.
     

    #7
  8. T1637280467654
    Cupcake Dec 6, 2021

    T1637280467654 , Dec 6, 2021 :
    hi i tried as you said but still after my device goes to fastboot mode and i use cmd adb devices than it shows no device attached
     

    #8
  9. T1637280467654
    Cupcake Dec 6, 2021

    T1637280467654 , Dec 6, 2021 :
    i tried using 3 cables and it is same with all cables that after i go into fastboot mode it never shows the attached devices
     

    #9
  10. BhavyaMehta0786
    Ice Cream Sandwich Dec 6, 2021

    BhavyaMehta0786 , via OnePlus 8 Pro , Dec 6, 2021 :
    If these haven't worked, then there could be an issue with your usb port or the drivers
    1) Try using a different USB port, preferably USB 2.0
    2) If even that doesn't work then uninstall all device drivers and try booting into fastboot
     

    #10
  11. BhavyaMehta0786
    Ice Cream Sandwich Dec 6, 2021

    BhavyaMehta0786 , via OnePlus 8 Pro , Dec 6, 2021 :
    Oh no i think I figured out what the issue is here, adb doesn't work and list devices when the device is in fastboot, you will have to try fastboot devices to see your device, also instead of "fastboot oem unlock" try "fastboot oem relock" or "fastboot flashing lock"
     

    #11
  12. T1637280467654
    Cupcake Dec 6, 2021

    T1637280467654 , Dec 6, 2021 :
    i tried your commands and it only shows waiting for devices and nothing happens after that
     

    #12
  13. T1637280467654
    Cupcake Dec 6, 2021

    T1637280467654 , Dec 6, 2021 :
    i tried using all the methods you said above but the problem is that once the device is on and i connect the cable with the pc, and under the platform folder i hit the command prompt than typing just adb devices it shows me the device number and the connection status that it is connected, but once i put the device into the fastboot mode and than try to put any command than it never goes ahead and thus i am stuck with it.

    is there any method apart from adb to lock the bootloader, shall i flash the rom to stock flashboot rom and than try after it, although i have to wipe off the device first. any suggestion as i m fed up with this method
     

    #13
  14. BhavyaMehta0786
    Ice Cream Sandwich Dec 6, 2021

    BhavyaMehta0786 , via OnePlus 8 Pro , Dec 6, 2021 :
    There's other methods but they also depend on fastboot, so that will mean you will have no luck trying them too, if you can maybe try using an alternate PC
     

    #14
  15. BhavyaMehta0786
    Ice Cream Sandwich Dec 6, 2021

    BhavyaMehta0786 , via OnePlus 8 Pro , Dec 6, 2021 :
    Maybe a possible solution (The drivers are reliable even then I would suggest trying this at your own risk):
    Boot your device into fastboot mode.
    Go to device manager and check if it shows up under other devices (maybe named Android or OnePlus (model no.)).
    If it does then download this driver:
    https://drive.google.com/file/d/1sHuqeqlxMr1CsR_FpOYmRA2HtEDoeK7_/view?usp=drivesdk
    and manually update the device driver, by selecting browse my computer and then selecting let me choose a compatible driver
    After it updates check using cmd if your device shows up
     

    #15
  16. Dresa91
    User of the Year 2016; Most Active User 2020 Community Expert Dec 6, 2021

    Dresa91 , Dec 6, 2021 :
    What about the drivers?
    Did you try another USB port?
    Did you try a type c to type cable?
     

    #16