2
OxygenOS [Help] Super Hard Brick - Stuck in EDL and no button response at all + SHA256 fail

  1. charnet3d
    Cupcake Jan 23, 2020

    charnet3d , Jan 23, 2020 :
    Hi everyone,

    I'm having an issue with my 7 pro (1911). This is my 1st Oneplus as I used a Mi 5 before, the flash procedure was much easier without this A/B mess.

    So I somehow messed up a new install of pixel experience with blu_spark kernel and twrp and found myself with the qualcomm crash error. Trying to get back into fastboot with the button combination (was able to save it once in it) the phone restarts and got stuck in edl mode. I noticed it's recognized as 9008 in the PC so I said okey this is nothing I'll just use the MSMTool to get it back on again.

    Went through the xda mega thead procedure, had no problem getting the phone to connect to the tool, however, first unexpected thing I encounter is the fact it stops with a SHA256 doesn't match error, and fails to send op2.img. I verified the ops file to make sure it has no errors and it was good. I then checked "disable sha256" box and it goes normally with the flash this time. Except in the end instead of restarting into the system it restarts into edl mode again and if the cable is still attached starts flashing again. This loop keeps going on forever.

    I checked everywhere the only other thing I found that hints at a possible solution was doing an SMT download (based on this thread from OP6). Having an EFS backup already in one of my TWRP backups I went ahead with the procedure. Everything goes normally with the sha256 box disabled. it takes longer than upgrade mode (it flashes also to b slot), it finishes fine till the end. I disconnect the phone to boot it but it's still stuck in EDL mode!!! pressing any combination of button only keeps restarting the phone in EDL; when connected to the pc you see it going off then on in device manager.
    The only idea I have left is waiting for battery to die, which could take forever and I have no idea if that'll work [​IMG]

    Things I tried/used :
    • Qualcomm drivers are the latest from microsoft server v2.1.2.2. Tried some other ones but no change.
    • Pressing any combination of buttons (up + down + power, up + power, down + power) for multiple minutes doesn't change anything (it only hurts your fingers lol)
    • Before the issue the phone was at around 40%, I don't think the problem was battery charge, but I still tried connecting to official charger for some time but no boot.
    • I tried using multiple cables, ports (usb 3 and 2 from front of pc), tried on a laptop with both usb 2 and 3, all give me the same results, sha256 fails, without the check it flashes but no boot or response.
    • I redownloaded the MSMTool multiple times from both the mega thread and newer one with oos 10 images, even the chinese image, all of them give the exact same issue. The only one that didn't work was the TMobile image, saying it's the wrong image (tried it just to be sure my phone wasn't originally a TMO converted, as it's 2nd hand).
    • Tried starting a normal flash in MSMTool and leaving it on that loop (flash, finish, restart again in EDL, flash...) all night but still found it flashing in the morning, never booted to system.

    I found some people in the forums having the same symptomes (but quite rare compared to others), only 2 said they found a solution:

    OP7P (this guy fixed the issue by charging his phone) https://forum.xda-developers.com/sho...5&postcount=83
    OP6T (this guy discharged his phone completely then connected it and it booted) https://forum.xda-developers.com/sho...92&postcount=5
    OP7 https://forum.xda-developers.com/sho...5&postcount=41
    OP7 https://forum.xda-developers.com/sho...3&postcount=43
    OP6 https://forum.xda-developers.com/sho...1&postcount=88
    OP6 https://forum.xda-developers.com/sho...&postcount=203

    I'm making this thread maybe someone who had the same issue can show me how he solved it, or if not and my last resort works (complete battery discharge) hopefully stays as a helpful history to someone else.

    Thanks.
     

    #1
    Ashisshhh and G_plusone like this.
  2. charnet3d
    Cupcake Jan 28, 2020

    charnet3d , Jan 28, 2020 :
    Hi again,

    Updating my thread with what I could do lately:

    I opened the phone up, anxious to try disconnecting the battery and seeing if it makes any difference. To my surprise that also did no change at all.

    After some time working with @NErdgOd56 from the Reddit Discord we tried many things, among them reading back the memory using MSM Tool. There was also a python script that enabled reading a provision xml file that's used by the tool to flash everything. This file mentions where in the OPS file each image is. So after some fiddeling with the OPS using a hex editor, I found that there are quite some differences with the images I read from the phone, this hints at a possible flash memory corruption. Though this needs to be confirmed by someone who has a clean phone, whether the images are supposed to be exactly the same or probably they're encrypted when transfered to the phone.

    So right now I'm starting a search for a motherboard locally, hoping to find something.

    Thanks to all the guys from discord who gave their time to my cause @NErdgOd56, @DarkPhoenix and the others on the OP7 channel.
     

    #2
    G_plusone likes this.
  3. J1581130750014
    Cupcake Feb 21, 2020

    J1581130750014 , Feb 21, 2020 :
    Some extra info with my experience. After facing a bricked device when some magisk modules disagreed with my phone and twrp failed to refresh data.

    I got MSM Tool to work after a fresh Windows install to build 1909 [unmodified windows ISO], before this Qualcomm driver wouldn't work as intended even if the phone seem connected in the MSM Tool [wouldnt go to flash progress]

    Making sure the only driver I installed was the Qualcomm driver for EDL Mode [certificate install method]

    After installing the driver first, I pressed the buttons for EDL Mode and plugged in USB, and MSM picked up the phone and flashing the img worked flawlessly, I even did it twice since I kind of installed slightly the wrong img and wanted to make sure I got the one that came with the phone.

    Many OS Configurations get messy and my configuration was just a matter of it being modified so a new windows installation allowed the Qualcomm driver to work as intended and allow the MSM Tool to flash my phone image.
     

    #3
  4. chandreshverma
    Cupcake May 22, 2020

    chandreshverma , May 22, 2020 :
    Hi ,
    Did you find any solution for this problem ?

     

    #4
  5. Ashisshhh
    Cupcake Jul 9, 2020

    Ashisshhh , Jul 9, 2020 :
    Hi,
    Did you find any solution regarding this ?
     

    #5