Home Button/Fingerprint Sensor dies shortly after upgrade to Oxygen OS 3.0.2

  1. eralaj
    Eclair Jun 28, 2016

    eralaj , Jun 28, 2016 :
    The home button/fingerprint sensor on my OP2 suddenly died yesterday. It may be a coincidence but it happened within two weeks of having upgraded to Oxygen OS 3.0.2.

    The home button/fingerprint sensor is now completely unresponsive and I have been forced to activate the on-screen navigation bar. But this was not easy to do as the first symptom of something weird going on with the home button was that the device started to vibrate (Vibrate on touch) spontaneously with one-second intervals. It behaved this way as the phone did return to the home screen by itself every second and this took precedence over any intended interaction with the display.

    As I have seen several other users (on this forum) experiencing similar problems recently it can be suspected that this behavior was introduced with the deployment of Oxygen OS 3.0.2 even though the phone's behavior make you suspect a hardware failure.

    When I perform a test of the fingerprint sensor by dialing *#808# and selecting Fingerprint Sensor -> Autotest, then the test fails and the response is "Fingerprint Sensor not present".

    I have now created an RMA request. Waiting for response from OnePlus Support Team.

    Reidyy1234, Dhruvism, hatesh and 2 others like this.
  2. mikkellmmaynen
    Eclair Jun 28, 2016

    novagurl and eralaj like this.
  3. tev76
    Cupcake Jun 28, 2016

    tev76 , Jun 28, 2016 :
    The same happened to me this morning. The capacitive buttons are dead. I received Oxygen OS 3.0.2 OTA a couple weeks ago.

    ecliptic1101 likes this.
  4. novagurl
    Gingerbread Jun 28, 2016

    novagurl , Jun 28, 2016 :
    I'm experiencing the same problem after 3.0.2 update. Ive tried everything; downgraging to 2.0, battery drain and then full charge, wipe data and cache, reinstall 3.0.2 nothing works, fingerprint option isnt even available in settings anymore. Oneplus really need to do better than this, why send out an update that's messing up the phones. Hmmm It's very strange that new phone comes out and their update breaks the previous model.
    Last edited: Jun 29, 2016

    ecliptic1101 likes this.
  5. tev76
    Cupcake Jun 28, 2016

    tev76 , Jun 28, 2016 :
    I fixed my phone by turning it off for 30 mins. The buttons are working again.

  6. Prateekarora98
    Eclair Jun 28, 2016

    Prateekarora98 , Jun 28, 2016 :
    Same guys my fp button stopped working yesterday wtf wrong with oos or op2, but still i get test as passed(see screenshots) need some reply from oneplus team plz reply guys @Helen....... .

    Attached Files:

  7. swapjad30
    Gingerbread Jun 28, 2016

    swapjad30 , Jun 28, 2016 :
    Same thing happened to me today..Since afternoon suddenly fingerprint sensor stopped working..nd even option for fingerprint is not available in settings..
    ps..See SS

    Attached Files:

  8. mikkellmmaynen
    Eclair Jun 28, 2016

    mikkellmmaynen , Jun 28, 2016 :
    I have the exact same issue. :-/

  9. jweinert
    Cupcake Jun 29, 2016

    jweinert , Jun 29, 2016 :
    Had exactly the same issue. I did every possible solution but nothing worked. But then suddenly after 3 weeks the home button started working again and i don't have any idea why

  10. Vasilachi Eugeniu
    Honeycomb Jun 29, 2016

    Vasilachi Eugeniu , Jun 29, 2016 :
    yesterday my home button died. today i went service centre, they told me its not a software problem, its a hardware problem. they ordered new button for 6$.

  11. ickle59
    Cupcake Jun 29, 2016

    ickle59 , Jun 29, 2016 :
    same issues as above for me, i thought it was due to my phone getting wet whilst at a festival (soaked through my clothes and the phone to boot), evidently not! A few weeks later im still having the same problem and now with added loss of mobile data reception. Any suggestions/ help?

  12. namanmaloo
    Cupcake Jun 29, 2016

    namanmaloo , Jun 29, 2016 :
    Same thing happened with me i am not able to use home button and fingerprint scanner and the option is also not available and when i called oneplus customer care they told me to factory reset my phone. Does any1 has any better option? Please ask oneplus to launch a new update to solve this issue.

    mikkellmmaynen likes this.
  13. namanmaloo
    Cupcake Jun 29, 2016

    namanmaloo , Jun 29, 2016 :
    @tev76 you were right.... Guys you can try this switch off the phone for half an hour clear cache before restart... My problem got solved because of this...

  14. majzok
    Gingerbread Jun 29, 2016

    majzok , Jun 29, 2016 :
    Same here, FPS dead for 4 days now, tryied everypossible solution. Created ticket with support, they asked if i use 3.0.2 and after confirmation they asked to create RMA.

  15. Chenna Madhav Niketh
    Froyo Jul 1, 2016

    Chenna Madhav Niketh , Jul 1, 2016 :
    after marshmellow update i've faced a similar issue.

    Dont worry just use the on screen navigation button. Wait for a week or two and restart your phone and it will be back to normal.

    *Reset is not required.*

    Patience is the key :p

    Note: Issue might have happened due to a wet fingerprint reader.

  16. Micke61a
    Cupcake Jul 2, 2016

    Micke61a , Jul 2, 2016 :
    I got the same issue with my OPT. No fp or hb. The problem started after update to 3.0.2 and when i used the slider. So for me the problem is when i use the slider. Now i cant get the fb back whatever i do. Waiting and hoping for an update.

  17. SeanPG1983
    Froyo Jul 3, 2016

    SeanPG1983 , Jul 3, 2016 :
    I also have this exact same problem. The FP sensor stopped working randomly. There was absolutely nothing that seemed to cause it. Although I did notice random vibrations with the phone right before the sensor died.

  18. LinkRar
    Froyo Jul 3, 2016

    LinkRar , Jul 3, 2016 :
    The same thing happened with me. After I had it soaked in rice (the audio wasn't working as well), everything was fixed... EXCEPT for the home button. I don't get any response from using it, and when I tried a self-diagnostic, it said there was no response from the sensor

  19. chrisakker
    Cupcake Jul 3, 2016

    chrisakker , Jul 3, 2016 :
    Got it fixed again! Very easy!

    My fingerprint sensor / home button stopped working 2 weeks prior to my android 6.0 upgrade, but didn't start working after.
    Today, however, I saw in the setting menu that the option of adding fingerprints also disappeared, so now I knew it was a software instead of a hardware problem.
    After clearing the cache, everything started working again fine!
    So switch off phone, hold power button and volume down button simultaneously, until phone switches on. Select English, clear cache, and reboot. (it didn't remove any data or apps etc)
    And it worked fine after! (just had to add my own fingerprints again)

  20. F_Aarash_Wafah_SQVl
    Cupcake Jul 4, 2016