Home Button/Fingerprint Sensor dies shortly after upgrade to Oxygen OS 3.0.2

  1. Zaffar Anwar
    Cupcake Jul 4, 2016

    Zaffar Anwar , Jul 4, 2016 :
    Even i have the same problem and was suggested to Do a hard reset which did not fix, did run the test it shows FP not found, did soft reset as well multiple times no go, Contacted support and they suggested to contact support center, one of the OP2 user suggested to drain the battery and charge it full again and while the charger is connected to turn on the phone and it did work for him but not for me, even there is no update till now from OP+ team @Helen . Kindly assist what to do as my warranty is going to Expire as well,

  2. ninosilvennoinen
    Cupcake Jul 4, 2016

  3. novagurl
    Gingerbread Jul 4, 2016

    novagurl , Jul 4, 2016 :
    It's finally working again, my fps haven't worked for a month until today, there was no fingerprint option in settings either. Nothing I did before worked even the battery drain and charge didn't work. This is what I did, two days ago I reverted my OS to 2.2.1 like I did many times before (when I was trying to fix the fps) but that didn't help this time either and then yesterday I let the battery run down until the phone cut out then I did method #3 again http://forum.xda-developers.com/oneplus-2/general/guide-oneplus-2-home-button-dead-t3324321. What I did this time that was different was after the battery died I left it like that for 24 hours before fully charging it. After I turned it on still plugged in, I did the *#808# test and it passed, now the fps is working perfectly.

  4. Zaffar Anwar
    Cupcake Jul 4, 2016

    Zaffar Anwar , Jul 4, 2016 :
    Guys who have got the issue resolved gives me hope that my OP2 FP will work someday, until some one from OP+ teams finds a solution;)

  5. Zaffar Anwar
    Cupcake Jul 4, 2016

  6. ninosilvennoinen
    Cupcake Jul 5, 2016

    ninosilvennoinen , Jul 5, 2016 :
    Yep, had the same result. Red text and no recognizable sensors or fingerprints. But after following the steps I got it working again and then the test showed PASS.

    Zaffar Anwar likes this.
  7. G_facundo_cotella_DCtO
    Cupcake Jul 19, 2016

  8. fkur2943
    Cupcake Jul 20, 2016

    fkur2943 , Jul 20, 2016 :
    It is software problem. You can try to clear cache and reboot. Some people reported it works, some do not.
    If it's not working, what I did was go to settings and disable OEM unlocking, reboot and disable developer option. It worked for me.

    nh_opu likes this.
  9. majzok
    Gingerbread Jul 28, 2016

  10. Назарій Паньків
    Cupcake Aug 1, 2016

  11. Dhruvism
    Gingerbread Aug 1, 2016

    Dhruvism , Aug 1, 2016 :
    This has happened with 2 ppl in my class,thankfully I didn't upgrade! I'm waiting for the stable build

    & I just wanna say that I feel jealous for the OP3 owners as I bought my OP2 (for 12k from QuickR!) a while ago....
    Last edited: Aug 1, 2016

  12. Назарій Паньків
    Cupcake Aug 2, 2016

  13. ledian
    Cupcake Aug 2, 2016

    ledian , Aug 2, 2016 :
    My FP/HB stopped working more than three months ago (probably from wet finger). At that time I had OxygenOS 2.2.1. I tried everything suggested in the forum, upgraded to 3.0.1 and then later to 3.0.2. None of the attempts worked. I even had a remote session with OnePlus support when a L2 engineer of OnePlus wiped completely the device and flashed OxygenOS 3.0.2 (with their tools completely in chinese). The Fingerprint menu still missing, the fingerprint test failed and the home button still not working. So they gave up and asked me to submit a RMA request. I submitted the RMA request but the answer was: we will cancel your request because your country is not in the list we ship to.

    Today I managed to solve the issue by clearing cache and data of com.fingerprint.serviceext and then powering off the device by keeping the power button pressed for 10 seconds. After the restart it worked (maybe it was the moisture problem and it needed some time to disappear)

  14. ecliptic1101
    Cupcake Jul 23, 2017

    ecliptic1101 , Jul 23, 2017 :
    EXACT SAME ISSUE HERE - From Salt Lake City, UT USA. Updated my phone yesterday to OS 3.6.0. It freaks out when I touched the home button. It started thinking that the application button was being pressed every second. Which made it hard to restart the phone. I was able to force the restart, but immediately after it came up none of the off screen navigation buttons worked and the finger print sensor does not work at all. Did a factory reset and the finger print sensor says it's not there.

  15. G_nithan_biddappa_BOdE
    Donut Jul 23, 2017

  16. Martin Penc
    Cupcake Jul 23, 2017

  17. G_Amrit_Koul_zPlz
    Cupcake Jul 23, 2017

  18. the_reckoner
    Ice Cream Sandwich Jul 24, 2017

    the_reckoner , Jul 24, 2017 :
    Same problem here, on the latest Lineage OS nightly
    Worst case is that I am unable to find the system app mentioned whose cache I need to clear