1
Home Button Not Working

  1. Feegle
    Eclair Sep 25, 2014

    Feegle , Sep 25, 2014 :
    This is not the lag problem that I've seen posted widely on the web.

    My problem is that the Home button isn't working at all. Doesn't matter what app I'm in, pressing Home doesn't do anything.

    In the Buttons settings I have double-tap and long-press actions for the Home Button set to None so I know this isn't happening because the button is waiting for an input.

    The Menu and Back buttons work fine.

    Things I've tried:

    Rebooting : No effect
    Clear Defaults from Nova Launcher: No effect
    Remove Nova Launcher: No effect
    Reboot again: No effect

    Odd behaviour:
    If I do assign a long-press and double-tapo action to the Home button, then the double-tap action works, but the long-press action doesn't work. A single press still does nothing.
     

    #1
    brettman likes this.
  2. Feegle
    Eclair Sep 25, 2014

    Feegle , Sep 25, 2014 :
    Sorry for the double post. Don't know what heppened there. Please delete on of them.
     

    #2
  3. squllroina
    Gingerbread Sep 25, 2014

    squllroina , Sep 25, 2014 :
    As OP support will ask....try reset the phone....
    -_,-
    it might cause by some applications....
     

    #3
  4. Feegle
    Eclair Sep 25, 2014

    Feegle , Sep 25, 2014 :
    That's the next option if support can't provide a proper fix.

    I can see it now, do a factory reset, works for a bit and then stops working again.

    What will the advice be then? Why, do a factory reset again of course!

    I want a fix, not a workaround.

    *sigh*
     

    #4
    samneo likes this.
  5. kapiteintje
    Cupcake Jan 13, 2015


    #5
  6. Feegle
    Eclair Jan 13, 2015

    Feegle , Jan 13, 2015 :
    I installed the slimkat rom and wiped everything. Then I did a full factory reflash and it's been fine since.
     

    #6
  7. drfyzziks
    Donut Jan 22, 2015

    drfyzziks , Jan 22, 2015 :
    I just started experiencing the same thing. It's definitely software - if you enable the on-screen home button, the same thing happens to it. Rebooting doesn't appear to fix it - but it does occasionally start working again on its own, only to stop working on the next reboot.

    As for resetting the phone to factory defaults: while that might fix the problem, it's not going to guarantee that the problem won't come back (since by definition, the phone was set to factory defaults when I got it).

    I'm unimpressed - a functional home button is kind of a requirement for a working phone ... and resetting the phone to factory defaults every time this bug shows up is not an acceptable solution. A "flagship killer" phone shouldn't be burdened by a bug like this. I *was* planning on retiring my iPhone and switching to my One full-time, but this just changed my mind.

    *sigh*
     

    #7
    brettman likes this.
  8. Feegle
    Eclair Jan 22, 2015


    #8
    drfyzziks likes this.
  9. drfyzziks
    Donut Jan 22, 2015

    drfyzziks , Jan 22, 2015 :
    Thanks for the link.

    I know this probably sounds stupid, but I'm not going to re-flash my phone to make this problem go away - because there's no guarantee that it won't come back. The problem surfaced while my phone was running stock OPO Cyanogenmod - so re-flashing to stock might make it go away for the time being, but stock is obviously susceptible to the bug. I don't want to get into the habit of blowing away my phone as a viable solution to fixing bugs.

    That said, I did some investigating last night and I think I managed to pin down a potential cause, *and* also managed to fix/workaround the issue - at least on my phone.

    I had my phone set up to use location-aware profiles. If it was within range of my home WiFi network, I had it automatically disable the lock screen. As soon as I left home, it would switch to a different profile w/the lock screen enabled.

    I noticed that I was only experiencing the home button issue *at home* in my house. Outside of my house, with the lock screen enabled, I didn't encounter the problem.

    So on a hunch I turned off my location-aware profiles and set the default to lock screen everywhere - and the problem has not recurred. Something about the lock screen appearing causes the home/nav buttons to reset & become active again.

    Moral of the story: if you're having problems with the home button not working, and you've got location-based profiles turned on, try disabling them and setting the default profile to lock the screen. Worked for me.
     

    #9
    brettman likes this.
  10. brettman
    Gingerbread Apr 15, 2015

    brettman , Apr 15, 2015 :
    Thanks for this brother, you actually helped me out. I love your response too about not having to reflash to solve this.
     

    #10
  11. djdericsson
    Cupcake Feb 1, 2016

    djdericsson , Feb 1, 2016 :
    Really upset with One Plus customer support. My home button stopped working about 3 months ago, and I started using the onscreen option. I arranged a remote session with oneplus support as I thought they might be able to fix it. After the session on Jan 12th, when Sam couldn't resolve it, they forwarded the ticket to the next level of support and approved my OnePlus 2 64 for repair.

    I would have said NO if I had known what was going to happen. My phone was picked up on the 14th Jan, I have a tracking reference and the device was signed for on the 18th. Since then nothing. Desite me chasing with 2 online chats on 27th and 28th of January, they are unable to tell me what is happening to my phone.

    This was in the last email on Thursday 28th from Devian: "We are currently coordinating with the repair center regarding the receipt of you device. Once it is confirmed received, it will undergo inspection and repair. We will be updating you accordingly."

    All I can say is if it ain't broke don't (get Oneplus to) fix it. They will take away your phone and leave you in limbo.

    Andy
     

    #11
  12. Buzzstriker
    Cupcake Jun 13, 2016


    #12
  13. sanmansan
    Eclair Jun 15, 2016

    sanmansan , Jun 15, 2016 :
    I have the same issue but I just use the App Switcher/Menu button to get out of apps.
     

    #13