10
Network/Connectivity Hotspot tethering not working after android 10 update

  1. wal31cr
    Donut Jan 7, 2020

    wal31cr , Jan 7, 2020 :
    It happenned to me today, after going through multiple threads at this forum I found the solution by adding the APN type DUN (in capitals) in the Access Point Name settings as per the following thread
     

    #21
  2. gwjansen
    Gingerbread Jan 7, 2020

    gwjansen , Jan 7, 2020 :
    Where is that setting exactly? This question is about hotspot / tethering - I don't see that option anywhere.
     

    #22
  3. wal31cr
    Donut Jan 8, 2020

    wal31cr , Jan 8, 2020 :
    Settings > SIM & Network > SIM used for hotspot > Access point names > Currently used APN > Add ", DUN" at the end of APN Type setting
     

    #23
  4. Vitalii_Trubchaninov
    Cupcake Jan 8, 2020

    Vitalii_Trubchaninov , Jan 8, 2020 :
    Tethering does not work for me as well. And the problem with above solution is that my operator does not allow adding apn points of type "dun".
    A bit more info:
    Before the upgrade to Android 10 i had only 2 apn: Chatr Internet and Chart Tethering. Both with correct apn settings (Internet had "default" apn type and Tethering had "dun" type).
    But now I have 5 and the apn with "dun" type is "Citifone tethering" with wrong apn url.
     

    #24
  5. gwjansen
    Gingerbread Jan 8, 2020

    gwjansen , Jan 8, 2020 :
    That's what I'm saying - I don't have that setting. With hotspot on or off, it's not there. What's your device and android version? My Hotspot is working at 2.4G just not at 5G
     

    #25
    ACT43277 likes this.
  6. Gadgetnutter
    Froyo Jan 13, 2020

    Gadgetnutter , Jan 13, 2020 :
    I already have dun in my AP type and whilst hotspot works on 2.4 GHz it turns off after 5 secs on 5 GHz.
    Worked perfectly before I upgraded to Android 10 from the OnePlus site.
     

    #26
    ypresto and ACT43277 like this.
  7. wal31cr
    Donut Jan 15, 2020


    #27
  8. ACT43277
    Gingerbread Jan 17, 2020

    ACT43277 , via OnePlus 6T , Jan 17, 2020 :
    Also suffer the same problem using hotspot and 5Ghz band since 10.3.0 last update, it is a major bug.
    I previously uses this feature many Times and now i can't.
    any fix available from Oneplus ?
     
    Last edited: Jan 17, 2020

    #28
  9. gwjansen
    Gingerbread Jan 17, 2020

    gwjansen , Jan 17, 2020 :
    The issue as been reported already under Feedback several times so OnePlus is aware of it. For now we can use tethering, just on the 2.4 band - that is working just fine.
     

    #29
  10. ypresto
    Cupcake Jan 19, 2020

    ypresto , Jan 19, 2020 :
    Updating to OnePlus 6 Open Beta 4(Android 10) did not solve the issue. Both 2.4GHz (connected but ping 8.8.8.8 fails) and 5.0GHz (automatically turned off soon) does not work.
     

    #30
  11. ypresto
    Cupcake Jan 19, 2020

    ypresto , Jan 19, 2020 :
    Using APN type 'default, DUN' does not fix, but 'default,DUN' (no space o_O) fixed it.
     

    #31
  12. OssianF
    Cupcake Jan 20, 2020

    OssianF , Jan 20, 2020 :
    In my case the APN-type for Internet is "default, supl". It does not work with "default, supl,DUN" and not with "default,DUN".
     

    #32
  13. gwjansen
    Gingerbread Jan 21, 2020

    gwjansen , Jan 21, 2020 :
    Found the setting, added ,DUN - does not work. Tried with a different SIM (provider) - same story, not working.
     

    #33
  14. OssianF
    Cupcake Jan 23, 2020

    OssianF , Jan 23, 2020 :
    After updating Oxygen to 10.3.1 it works for me without any other changes.
     

    #34
    Caomhin likes this.
  15. Fusi Roberto
    Cupcake Jan 25, 2020

    Fusi Roberto , Jan 25, 2020 :
    same problem...OP6t the tethering hotspot does NOT WORK. or rather it is activated, the connected devices perfectly see the network but the internet is not accessible. This after updating to Android 10 OxygenOS 10.3.0 - Before it worked perfectly.
     

    #35
  16. gwjansen
    Gingerbread Jan 26, 2020

    gwjansen , Jan 26, 2020 :
    I would suggest we revisit the subject once we have 10.3.1 installed. There are a couple issues that are Hotspot related, I only have the 5G issue, not the others that have been mentioned.
     

    #36
  17. peiker
    Cupcake Jan 28, 2020

    peiker , Jan 28, 2020 :
    any more with op6t+10.3.1 with tethering working correctly?
     

    #37
  18. gwjansen
    Gingerbread Jan 28, 2020


    #38
    peiker likes this.
  19. mbatu91
    Cupcake Feb 4, 2020

    mbatu91 , Feb 4, 2020 :
    same problem here.
    After updating my Oneplus 6T to Android 10 OxygenOS 10.3.0 the tethering doesn't work anymore.
     

    #39
  20. gwjansen
    Gingerbread Feb 4, 2020

    gwjansen , Feb 4, 2020 :
    Respectfully, we already know that and it has been reported. Possible fix in 10.3.1 - once we have that update we'll test and post here. Thanks.
     

    #40
    peiker likes this.