1
How can I sync contacts to the OnePlus 2?

  1. KarlGustavH
    Froyo Oct 11, 2015

    KarlGustavH , Oct 11, 2015 :
    Hi!

    I tried syncing through Gmail, but it only synced like 25% of my numbers and said there's an error. How can I sync contacts from my old Samsung S3 to my OnePlus 2?
     

    #1
    Chika likes this.
  2. NaterTots
    Jelly Bean Oct 11, 2015

    NaterTots , Oct 11, 2015 :
    Make sure they are all backed up in the Google servers.

    I've never had an issue with that. Should be automatic, but you can check in settings>accounts.
     

    #2
    kc4one likes this.
  3. KarlGustavH
    Froyo Oct 11, 2015

    KarlGustavH , Oct 11, 2015 :
    I checked like 10x times. OnePlus 2 just said that "we have an error but it will be fixed soon" a message similar to that.
     

    #3
  4. NaterTots
    Jelly Bean Oct 11, 2015


    #4
  5. KarlGustavH
    Froyo Oct 11, 2015

    KarlGustavH , Oct 11, 2015 :
    I have waited for 2 days :/
     

    #5
  6. BassVity
    Jelly Bean Oct 11, 2015


    #6
    KarlGustavH likes this.
  7. KarlGustavH
    Froyo Oct 12, 2015

    KarlGustavH , Oct 12, 2015 :
    Thanks, that was very helpful! I really like this this program.
     
    Last edited: Oct 12, 2015

    #7
    BassVity likes this.
  8. KarlGustavH
    Froyo Oct 12, 2015

    KarlGustavH , Oct 12, 2015 :
    ....and Airdroid doesn't have an option to move contacts between 2 devices. F*ck my life, I have been trying to move contacts for 3 days now. Technology has advanced extremely fast but when getting a new phone, nobody has invented an app/program that WORKS when you want your contacts on your new phone.

    Anyone care to help me?
     

    #8
    Chika and BassVity like this.
  9. yahiroz
    Jelly Bean Oct 12, 2015

    yahiroz , Oct 12, 2015 :
    Just to check, you can see all your contacts here right? https://mail.google.com/mail/u/0/?tab=Cm#contacts

    Go to Settings -> Accounts -> Google -> you account and disable the contact sync on the OP2, go to Settings -> Apps -> All and find Contacts and Contacts Storage, clear data on both, and reenable contacts sync.
     

    #9
  10. KarlGustavH
    Froyo Oct 12, 2015

    KarlGustavH , Oct 12, 2015 :
    I already did all those steps 3 times. Google synced like 25% of my contacts and that's it. So I have only 25% of my contacts on the OPT.
     

    #10
  11. yahiroz
    Jelly Bean Oct 12, 2015

    yahiroz , Oct 12, 2015 :
    The only other thing I can suggest then is remove your Google account, then readd it.
     

    #11
    KarlGustavH likes this.
  12. KarlGustavH
    Froyo Oct 12, 2015

    KarlGustavH , Oct 12, 2015 :
    Didn't help, Google is useless. I need to find something else to sync my contacts. I am already thinking about writing 300+ contacts into my phone by hand :/
     

    #12
  13. yahiroz
    Jelly Bean Oct 12, 2015

    yahiroz , Oct 12, 2015 :
    Guess we'll need to do it the manual way.

    Go to: https://mail.google.com/mail/u/0/?tab=Cm#contacts

    Press "More" under the search bar then select "Export". On the dialog that pops up select "All contacts" and below choose "vCard format". This will download a file onto your PC. Transfer this to the OP2.

    Once the file is on the OP2, open the Contacts app, press the 3 dot menu button and select "Import/export". On the dialog that pops up select "Import from storage". Then select your Google account and the app will begin to seach for the vcf file you trasnferred. Once it finds it it will then import your contacts.
     

    #13
  14. KarlGustavH
    Froyo Oct 12, 2015

    KarlGustavH , Oct 12, 2015 :
    Here's the problem. Only 25% of the contacts also show up in my gmail. 4 days ago, I had nothing there. 2 days ago I synced it and it only took 25% of my phone's contacts, nothing else.

    I noticed that it mostly took the contacts that are older.
     
    Last edited: Oct 12, 2015

    #14
  15. lukez
    Gingerbread Oct 12, 2015

    lukez , Oct 12, 2015 :
    On your old phone go to contacts, settings, import/export and export to internal storage

    Then connect phone to pc, transfer that vcd file to pc, plug in op2 to pc, please the vcd file anywhere in internal storage , then on op2 go to contacts, settings, import / export and import this file.

    I just did this for my mom's new phone and worked like a charm
     

    #15
    sunilbagalur and suzane like this.
  16. Xenti3
    Honeycomb Oct 12, 2015

    Xenti3 , Oct 12, 2015 :
    when you follow the setup pay attention to 'Tap & Go' this is what it is for :) also try titanium backup
     

    #16
  17. BassVity
    Jelly Bean Oct 12, 2015

    BassVity , Oct 12, 2015 :
    Did you think of making a temporary new Google account, then syncing the contacts with it, and on the OP2 copying and deleting the temporary account?
    Hope it helps.
     

    #17
  18. yahiroz
    Jelly Bean Oct 12, 2015

    yahiroz , Oct 12, 2015 :
    On the S3, in the contacts app press the menu button and there should be an option to export to storage, which should also be a vcf file.
     

    #18
    reganvdb likes this.
  19. reganvdb
    Ice Cream Sandwich Oct 12, 2015

    reganvdb , Oct 12, 2015 :
    careful when sync works again could become a mess with the contacts..
     

    #19
    yahiroz likes this.
  20. rikardo1979
    Community Veteran Oct 12, 2015

    rikardo1979 , Oct 12, 2015 :
    seems to be problem with your google account and not the phone. look into your google account settings and try to contact google
     

    #20
    aenews likes this.