0

How do i update rooted oneplus 5t from Android 8.1 (OOS 5.1.7) to 9?

  1. LauRoman Cupcake Apr 7, 2019

    LauRoman, Apr 7, 2019 :
    I currently have my 5T rooted with magisk and using "official" TWRP 3.2.3-1 and the last build of OOS 5.1.7 (based on Android 8.1).
    I can't install the (full) OTA of 9.0.x because i get an error. I tried using a newer "official" twrp 3.2.3-2 but after booting to it i get a black screen and the status led light is blueish. I also tried just using the stock recovery image (the 8.1.0 variant, of course) from the first post on XDA here in the hopes i could unroot the phone and do the update from the app and re-root later, but all i get is a black screen when booting to recovery.
    I was a bit wary of using bluespark/codeworkx recoveries in the past because i found them to freeze whe using some options in twrp, but if that's the only option, i will use them.

    I am clearly skipping some steps or doing something wrong, so what can i do to upgrade, without losing data, if possible?


    LE:
    I figured it out. I just dirty flashed OOS 5.1.7 which removed root and twrp so i could flash OOS 9.0.4.
    However neither Magisk 18.1 or 18.2 or 19.0 worked with OOS 9.0.4. It would just bootloop. But unrooted 9.0.4 worked just fine. I also mucked up either the boot partition, or some other thing while i tried Magisk versions so i decided to moved to LOS for the time being. But i will be back to OOS soon-ish because i do like being able to use the dual camera, i do like the black system interface of OOS and a few things here and there, like the slightly modified clock app.
     
    Last edited: Apr 7, 2019

    #1
  2. Carman00 Gingerbread May 3, 2019

    Carman00, May 3, 2019 :
    Try using blu_spark it works for me with magisk and everything just fine
     

    #2