0
OxygenOS How is the syntax to change encryption password by using terminal (vdc cryptfs)

  1. WansHurst
    Gingerbread Dec 12, 2016

    WansHurst , Dec 12, 2016 :
    Hello

    how is the syntax to change the encryption password on OxygenOS 3.5.3 using terminal app?

    I tried:

    Code:
    su
    cd system/bin
    vdc cryptfs changepw mynewpin
    Code:
    su
    cd system/bin
    vdc cryptfs changepw pin mynewpin
    Code:
    su
    cd system/bin
    vdc cryptfs changepw pin mynewpin
    Code:
    su
    cd system/bin
    vdc cryptfs changepw pin [currentpin] pin [newpin]
    No success!! Can anybody help me?
     
    Last edited: Dec 13, 2016

    #1
  2. JoJoModding
    Froyo Dec 13, 2016


    #2
  3. WansHurst
    Gingerbread Dec 13, 2016

    WansHurst , Dec 13, 2016 :
    That's the point. I don't get an error. The the SELinux policy prevents the output. Modifying the policy with the code below did not work either. If I remember correctly, the error pointed to the flag --live. I tried the "encpasschanger" and "cryptfs password" app and both applications are failing to verify the current password. Output: "incorrect password". But the password/PIN is correct!!

    I did not want to waste my time with changing the encryption password for now, so I am working on the modification of the operating system (microG und other). Until I'm done with it, I will not change the encryption. After that, I will provide the full error text for the "supolicy... " command and continue the work on the encryption.

    Code:
    supolicy --live 'allow vdc devpts chr_file {read write getattr ioctl}'
    More infos about the vdc cryptfs command you can find here.

    *I hope my text was understandable because english is not my native language.
     
    Last edited: Dec 14, 2016

    #3
  4. JoJoModding
    Froyo Dec 13, 2016

    JoJoModding , Dec 13, 2016 :
    Dann poste es doch im deutschen Unterforum.
    However: Is it possible that you have set a pin and try to enter that? If yes then try e.g. 1234->41424344, aka put a 4 in front of every letter.
    Or install twrp recovery and use their emulator for encryption to do what you want.
     

    #4
  5. ScrapAttack85
    Cupcake Dec 23, 2016

    ScrapAttack85 , Dec 23, 2016 :
    Hey there,

    after a failed OTA Update (yes phone war rooted and has TWRP installed)
    I can decrypt my /data in TWRP, but If I boot up android normally, I get the Message "fehler bei Verschlüsselung" (I think its called "encryption unsuccessful" on English androids.
    It there is something I can do?

    Best reagrds,
    Christian
     

    #5