0
How to change USB mode?

  1. antiprism
    Gingerbread Apr 30, 2016

    antiprism , Apr 30, 2016 :
    Hello,

    Normally when connecting my OnePlus One through USB, in the drop-down notification bar I can choose the USB mode. However, the option is not showing anymore. How do I change it?

    Kind regards
     

    #1
  2. Cromartie
    Eclair Apr 30, 2016


    #2
  3. antiprism
    Gingerbread Apr 30, 2016

    antiprism , Apr 30, 2016 :
    I only have a "Storage & USB" option which just shows me the used up space on my phone. :s

    COS 13.0
     

    #3
  4. Soundhar
    Froyo May 1, 2016

    Soundhar , May 1, 2016 :
    Check in developer options... Be sure update oneplus one to latest version
     

    #4
  5. 2thor
    Froyo May 1, 2016


    #5
    #HYPEorGTFO likes this.
  6. SacredCultivator
    Gingerbread May 2, 2016

    SacredCultivator , May 2, 2016 :
    For some reason, seems for me, it doesn't "remember" that I set it to "Media Transfer Protocol". I've set it and after a while, it just forgets and defaults it to "Charging"

    REally annoying... Yeah this latest update is quite a regression than a progression.
     

    #6
    mattycass95 likes this.
  7. jonathan_cave
    Eclair May 7, 2016

    jonathan_cave , May 7, 2016 :
    I agree - first it renamed the path to all my storage (making it appear that everything had disappeared from file manager), and now this. I can set the mode from the lockscreen pulldown, but the phone then forgets. No way to change the default, since Settings/Storage has been eliminated. I have gone to developer options (now also hidden until I search for them) and set USB config there to MTP. Again, this has no lasting effect. Was there any reason for these changes? Can they be reversed?
     

    #7
  8. SacredCultivator
    Gingerbread May 7, 2016

    SacredCultivator , May 7, 2016 :
    From what I read, it's for security purposes... But at the same time, I would think that if YOU the user changes it in Developers Options, it would REMEMBER it and not to where you have to change it each time you plug it in. As that's more of a regression than progression.
     

    #8
    Lancelot_69 likes this.
  9. giaur500
    Jelly Bean May 7, 2016

    giaur500 , May 7, 2016 :
    This is a stock Marshmallow behaviour. No way to change it.
     

    #9
  10. gioninardo
    Eclair May 12, 2016

    gioninardo , May 12, 2016 :
    same experience here! (installed system: cos13!)
    Sorry.. but if this is a Marshmallow behaviour... this is a bullshit!
     

    #10
    ananda likes this.
  11. Adityanxz
    Cupcake Jul 29, 2016

    Adityanxz , Jul 29, 2016 :
    From past two days, when i connect my mobile(oneplus one) to laptop, i'm unable to see the notification panel which lets us choose MTP or PTP etc..
    I could only see the mobile charging.
    I even tried enabling/disabling developer options method but the result is same..
    Can someone help me out?

    `Thanks in advance :)
     

    #11
  12. SacredCultivator
    Gingerbread Jul 29, 2016


    #12
  13. jamescandlin
    Eclair Sep 23, 2016

    jamescandlin , Sep 23, 2016 :
    But it still doesn't save the settings, just reverts back to charging (why doesn't it save this setting, so annoying) :mad:
     

    #13
    Kytovec likes this.
  14. gioninardo
    Eclair Sep 23, 2016

    gioninardo , Sep 23, 2016 :
    In developer option enable android debugging.
    bye.
     

    #14
  15. bmark240
    Ice Cream Sandwich Sep 24, 2016

    bmark240 , Sep 24, 2016 :
    Go to About Phone.
    Tap Build number until it reads Developer Options.
    Open Developer Options.
    Under Debugging Menu Switch on Android Debugging.
    Switch on Debugging Notify.
    Plug in phone with charging USB into computer.
    Scroll down to Select USB configuration.
    Select MTP (Media Transfer Protocol).
    An icon should appear on your phone(Android symbol).
    Open My computer & it should showA0001.

    If not then you need to install Windows Media Centre for the drivers.

    https://www.microsoft.com/en-us/download/details.aspx?id=49919


    It should now work if you have the right version installed.
     

    #15
  16. Dominosmofo
    Cupcake Nov 22, 2016

    Dominosmofo , Nov 22, 2016 :
    Even with the official OnePlus drivers installed as well as Windows Media Centre, it simply will not work. Having the exact same issue as everyone else on top. Settings don't seem to stick and nothing shows up on the pull down tab when connected, even with the official USB cable. The phone is just trash in this respect.
     

    #16
  17. iLoveMySleep
    Cupcake Dec 4, 2016

    iLoveMySleep , Dec 4, 2016 :

    This worked for me. Thanks for sharing. People that are not Android Devs have no idea, like me ;)
     

    #17
  18. hosseboss
    Cupcake Jan 27, 2017

    hosseboss , Jan 27, 2017 :
    Hi I still have the same issue. Using the developers mode option makes my Windows 10 saying it does not recognize the USB-device. Using the "normal" mode shows A0001 and starts charging the phone.

    Everytime I am attaching the phone I have to choose for the "USB file transfer" option. Something to be changed? Currently using 13.1.2-ZNH2KAS3P0-bacon.
     

    #18
  19. gioninardo
    Eclair Jan 27, 2017

    gioninardo , Jan 27, 2017 :
    It's the current normal way to do that... unfortunately!
     

    #19
  20. ruben costa
    Donut Feb 7, 2017

    ruben costa , Feb 7, 2017 :
    Thank´s, it worked for me
     

    #20