2

How to enable mobile data(internet)

  1. shreesha06 Cupcake Aug 19, 2015

    shreesha06, Aug 19, 2015 :
    Yesterday my OS got updated and after that I am unable to enable internet. I did Setting> Data usage>Data Connection: On.. Need to change any other setting?

    please advise. Thanks
     

    #1
    Abhay Singh and Mick Garry like this.
  2. WA_Bob Jelly Bean Aug 19, 2015

    WA_Bob, Aug 19, 2015 :
    Should have worked. Have you tried rebooting the phone? If that doesn't work, you may have more luck with a factory reset.
     

    #2
    Tokolozi likes this.
  3. daddy Eclair Aug 19, 2015

    daddy, Aug 19, 2015 :
    Maybe you need to download your network data setting for the internet connection again after upgrading....It might work!
     

    #3
  4. matthewtaylor1995 Honeycomb Aug 19, 2015


    #4
    lostLambda and marksnavy like this.
  5. Free123211 Cupcake Nov 29, 2015

    Free123211, Nov 29, 2015 :
    I have a oneplus x, the mobile internet is continu hylighted (on), i can't switch it off :(
     

    #5
  6. Aro2220 Donut Nov 29, 2015

    Aro2220, Nov 29, 2015 :
    check settings > mobile network settings

    Take a look at preferred network type. If it's LTE, try changing it to 3G or whatever and seeing if that makes a difference.

    Also take a look at access point names and network operators although you probably won't have to change anything.

    There is also a special # number you call that lets you change a lot of advanced settings...you could look into that. I think it's something like...dial *#*#4636#*#*

    Note: If you are going to adjust any of these settings I strongly recommend you google around for a while to figure out what the settings are supposed to be for your carrier/region etc.
     

    #6
    otto2 likes this.
  7. PaulF8080 Gingerbread Nov 30, 2015

    PaulF8080, Nov 30, 2015 :
    My phone turns mobile data off when I am on wifi. Not sure if it is a feature or a bug. :)
     

    #7
  8. arundas5959 Ice Cream Sandwich Nov 30, 2015

    arundas5959, Nov 30, 2015 :
    Just now resolved the data issue in cm13 OPO. This is what I did:
    Called *#*#4636#*#*
    You will get three options
    Go to Phone information
    Scroll down
    In bottom right corner you will find a refresh button
    Tap on it
    You will find some figures change
    Don't worry
    Go back to home screen
    Reboot the phone
    After that your mobile data will work just fine
    I had found the number from this forum only and it was by accident I tapped the refresh button. Rebooting was logical. Well, try it. You may be lucky.
     

    #8
  9. TlathamXmahtalT KitKat Nov 30, 2015


    #9
  10. Free123211 Cupcake Nov 30, 2015


    #10
  11. goralpm Cupcake Nov 30, 2015

    goralpm, Nov 30, 2015 :
    I got similar issue.
    After last update, I cant share my internet!
    I got unlimited data with 4GB threatening (sharing). In my OPO personal hot spot was always on. Cos I share data wit tablet in my car - and only with this device.
    I never used more then 1GB on tablet.
    Now, after last update, when I use data only on my phone (tablet switch off) it say I use sharing... and take all my sharing allowance just be cos Hot Spot was on... It not happen before. Any chance to downgrade from last update?
     

    #11
  12. lamberke Cupcake Dec 28, 2015

    lamberke, Dec 28, 2015 :
    I have the same issue. My phone says it's always connected to 3G or 4G even when i turn off mobile internet... some please help!! :s
     

    #12
  13. Mustufa Gari Cupcake Dec 29, 2015

    Mustufa Gari, Dec 29, 2015 :
    Actually i am also facing problems with One plus one. As i have to travel a lot whenever i switch my network zones the device disconnects the earlier network and should automatically connect to the current network but the problem is when the network switches it just dont connect to the current network as it shows no connectivity. I have to restart my phone for it. Same with Internet connection. When i loose connectivity and connect the the cellular network again the 3g just wont connect. The only solution is to keep restarting the phone every time i face this issue which is highly frustating.
     

    #13
  14. G_Ri Cupcake Jun 20, 2019

    G_Ri, Jun 20, 2019 :
    As others have said try to get the correct APN settings from your provider. I tried every other thing I could find them finally I called my provider Koodo and the guy there walked me thru how to set up the correct APN settings, after that I rebooted and all is working fine.
     

    #14