10
How to Enable Wi-Fi Calling

  1. narceoneplus2
    Honeycomb Aug 25, 2016

    narceoneplus2 , Aug 25, 2016 :
    I recently updated my OnePlus One to the newest incremental Cyanogen OS update (COS 13.1.2-ZNH2KAS3P0). While going through the settings, I figured out how to enable wi-fi calling. I have tested it several times to make sure that it works and it DOES!!! Below are the steps of how to enable it.

    Note: Enabling this setting was done through the Nova Launcher app, which I currently use. Also, this was only tested through my T-Mobile SIM.

    1. Long-press on an empty space on your home screen and select Widgets.
    2. Select Activities and drop it onto your home screen.
    3. When the Activities menu appears, scroll down until you see Settings and tap it to reveal more options.
    4. Scroll down until you see Enhanced radio control and long-press it to make the menu appear. If you tap on it, it will just create the widget on your home screen and you will have to start back from step 1 to do the rest.
    5. In the Enhanced radio control menu, tap on the option that says TURN ON WFC DEBUG. It should now say TURN OFF WFC DEBUG. WFC stands for wi-fi calling, in case you are wondering.
    6. Press the back button to return to the Activities menu.
    7. Scroll down some more until you now see the Wi-Fi calling option and long-press it to make the menu appear.
    8. Once you are there, turn on the switch found right below the search icon, which looks like a magnifying glass.
    9. An option called Calling preference will now appear. You have two options to choose from below:
    • Wi-Fi preferred: All calls are made over an available Wi-Fi network. If there are no available Wi-Fi networks, then calls are made over the cellular network.
    • Cellular preferred: All calls are made over the cellular network. If the cellular network is not available, then calls are made over an available Wi-Fi network.
    Pick whichever you want.
    10. Exit the Activities menu and simply reboot your device. You will now have the ability to make Wi-Fi calls. Thanks, Cyanogen.
     

    #1
  2. IrfanAliBaig
    Eclair Aug 25, 2016


    #2
  3. IrfanAliBaig
    Eclair Aug 25, 2016

    IrfanAliBaig , Aug 25, 2016 :
    Hi there

    What would be the fees which it is addressing,when trying tho enable this feature..? Are thou able to call..? Is there edges fee we have to pay if we use this feature..
     

    Attached Files:


    #3
  4. arifeen_091
    Donut Aug 25, 2016

    arifeen_091 , Aug 25, 2016 :
    from settings , type calling preference in search and enable it. this is the simplest method . :]
     
    Last edited: Aug 25, 2016

    #4
  5. IrfanAliBaig
    Eclair Aug 25, 2016

    IrfanAliBaig , Aug 25, 2016 :
    But calls are not routing through WiFi, anyhow
     

    #5
    bobpet likes this.
  6. narceoneplus2
    Honeycomb Aug 27, 2016


    #6
  7. IrfanAliBaig
    Eclair Aug 27, 2016

    IrfanAliBaig , Aug 27, 2016 :
    Calls not connecting... Even connected to WiFi, are you able to do that..?
     

    #7
  8. narceoneplus2
    Honeycomb Aug 29, 2016

    narceoneplus2 , Aug 29, 2016 :
    I really do not understand what you are trying to say. Please be more clear.
     

    #8
  9. Linanc7
    Lollipop Aug 29, 2016

    Linanc7 , Aug 29, 2016 :
    Does this work on AT&T? I thought it could be used on T-Mobile but not other carriers
     

    #9
  10. narceoneplus2
    Honeycomb Aug 29, 2016

    narceoneplus2 , Aug 29, 2016 :
    I use T-Mobile as my main provider. However, test out this method and let me know if it works for you. In theory, if AT&T supports Wi-Fi calling then you should be okay. But we will not know until you try it.
     

    #10
    Linanc7 likes this.
  11. narceoneplus2
    Honeycomb Aug 29, 2016


    #11
  12. Linanc7
    Lollipop Aug 29, 2016

    Linanc7 , Aug 29, 2016 :
    Ok I'll give it a try with AT&T @hkagashe I'm playing with the networks again :laughing:
     

    #12
    Tobikage and The1Lion like this.
  13. IrfanAliBaig
    Eclair Aug 30, 2016

    IrfanAliBaig , Aug 30, 2016 :
    I tried to connect by your method but calls are not routing through WiFi in my network, any suggestions...?
     

    #13
  14. itechy21
    Ice Cream Sandwich Aug 30, 2016

    itechy21 , Aug 30, 2016 :
    In addition to confirm this turn on airplane mode and enable WiFi then make a call

    Edit: Not working on Three UK
     

    #14
  15. DrJMun
    Jelly Bean Aug 30, 2016


    #15
  16. besweeet
    Eclair Oct 8, 2016

    besweeet , Oct 8, 2016 :
    That's completely different from carrier Wi-Fi Calling, where you can handle native calls and SMS/MMS when connected to Wi-Fi -- with or without cell service.
     

    #16
    kylesweet likes this.
  17. Patrick10
    Froyo Oct 8, 2016

    Patrick10 , Oct 8, 2016 :
    Hello, I am on T-mobile, which supports wifi calling feature. I followed the steps and enabled wifi calling. To test it out, I turned on the airplane mode and then just turned on wifi to connect to my network. Then when I tried making calls, it says "Turn off airplane mode or connect to a wireless network to make a call." This happens even though I am connected to wifi and surf the net.

    Can @narceoneplus2 or someone else try to make a call with airplane mode on and wifi connected, and see if it works.
     

    #17
  18. besweeet
    Eclair Oct 8, 2016

    besweeet , Oct 8, 2016 :
    There have been no confirmed reports of Wi-Fi Calling working.
     

    #18
  19. narceoneplus2
    Honeycomb Oct 9, 2016

    narceoneplus2 , Oct 9, 2016 :
    It has been working on my end since I've created this post. And just to give you a heads up, putting your phone on Airplane Mode will disable all connections: Wi-Fi and Cellular. Try turning off your cellular data in the settings and turn on your Wi-Fi to test it out. Also, have in mind that I am in the USA. I cannot confirm that this will work with the international version of the OnePlus One. Let me know.
     

    #19
  20. DrJMun
    Jelly Bean Oct 10, 2016

    DrJMun , Oct 10, 2016 :
    OK, I followed the step by step instructions, I'm using Tmobile. All the widgets and menus were there per the instructions. I turned on wifi-calling. Put the unit in airplane mode and enabled my wifi. Tried to make a call and received: turn-off airplane mode or connect to a wireless network to make a call.

    So, this did not work (for me anyway)
     
    Last edited: Oct 12, 2016

    #20