10
How to Enable Wi-Fi Calling

  1. Patrick10
    Froyo Oct 23, 2016

    Patrick10 , Oct 23, 2016 :
    Just turning off the cellular data does not eliminate cellular network. It only stops the phone from using data while still being connected to the cellular network. To simulate bad/no reception you have to turn on airplane mode, and then turn on WiFi. If WiFi calling is working, then you should be able to make calls even when there is no cellular connection (this was the purpose of creating WiFi calling in the first place). That is how other phones with WiFi calling works.

    So, in short, even though we are able to turn on the WiFi calling switch, true WiFi calling does not work on OnePlus One.
     

    #21
    DrJMun and kylesweet like this.
  2. gupta_chhotelal
    Froyo Oct 23, 2016

    gupta_chhotelal , Oct 23, 2016 :
    Wi-fi calling is very simple on OPO.

    1) Get married.
    2) Handover your OPO to your wife.
    3) Now ask your wife to call.

    It's just so simple.

    @Carl
     

    #22
    narceoneplus2 likes this.
  3. retro486
    Cupcake Oct 31, 2016

    retro486 , Oct 31, 2016 :
    I get terrible T-Mobile reception at my work and on 13.1.2-ZNH2KAS3P0, following the steps in the original post, this does not work. I get the "emergency calls only" message (all radios enabled and the Wi-Fi Calling preference is set to wifi). I also rebooted the device after enabling WiFi calling to make sure everything was fresh.
     

    #23
  4. tiru.abhi
    Cupcake Nov 18, 2016

    tiru.abhi , Nov 18, 2016 :
    I don't see Activities under widgets??

     

    #24
    CasperTFG likes this.
  5. CraigW
    Froyo Jan 31, 2017

    CraigW , Jan 31, 2017 :
    Three have now enabled WiFi calling (and ditched their horrendous intouch app). Does it work for you now?
     

    #25
  6. curious
    Gingerbread Mar 2, 2017

    curious , Mar 2, 2017 :
    I'm with Three UK, followed the OP's instructions (very well explained) unfortunatley no luck. I hate having to go back to that crap app "Three In Touch"
     

    #26
    remedy likes this.
  7. Pavelovi
    Cupcake Jul 3, 2017


    #27
    CasperTFG likes this.
  8. RamNiranjan
    Donut Jul 6, 2017


    #28
  9. CasperTFG
    KitKat Jul 6, 2017

    CasperTFG , Jul 6, 2017 :
    Do you have to use Nova settings to enable WFC?
     

    #29
  10. EpicV
    Cupcake Aug 26, 2017

    EpicV , Aug 26, 2017 :
    This does not work. I have talked to T-Mobile to set up a 911 address and replaced my (old) SIM card on the recommendation of their tech.

    With cellular data off, I can place calls as long as there is a cell phone signal. When the cell phone signal disappears, I get the same message as others.

    With airplane mode on and wi-fi on, I get the same message as others.
     

    #30
  11. bdineshvarma
    Cupcake Nov 30, 2017


    #31
  12. kevinkrg6
    Honeycomb Nov 30, 2017

    kevinkrg6 , Nov 30, 2017 :
    I honestly don't see the point of wifi calling....most everyone has unlimited minutes these days anyway right? Just use your cell service....unless you have wifi but no signal, like in the basement of a library or business
     

    #32
  13. kolsalhtmac
    Cupcake Aug 30, 2018

    kolsalhtmac , Aug 30, 2018 :
    I search that and nothing comes up
     

    #33
  14. X1546358419725
    Cupcake Jan 1, 2019

    X1546358419725 , Jan 1, 2019 :
    What would be the fees which it is addressing,when trying tho enable this feature..? Are thou able to call..? Is there edges fee we have to pay if we use this feature..
     
    Last edited: Jan 3, 2019

    #34
  15. narceoneplus2
    Ice Cream Sandwich Jan 6, 2019

    narceoneplus2 , Jan 6, 2019 :
    Bro, this part is so old that is no longer applicable. Sorry.
     

    #35
  16. B1557591294249
    Cupcake May 11, 2019

    B1557591294249 , May 11, 2019 :
    or unless you have no signal, like at your house
     

    #36
  17. B1557591294249
    Cupcake May 11, 2019

    B1557591294249 , May 11, 2019 :
    Was a solution ever found for this problem?
    Just activated this phone. I've downloaded a lot of apps over wifi already. I have done all of the steps to activate VoWiFi through T-mobile. On my phone I went into engineering mode and used the and used the OnePlus Log Kit to turn on the VoWiFi switch. Rebooted. Went into settings and selected Use WiFi When Available, and WiFi Prefered.
    When I try to make a call in airplane mode I get "Prompt To place a call, first turn off Airplane mode. OK". When I turn off airplane mode I get "Mobile network is not available. Connect to a wireless network to make a call. OK"
    This is while I AM connected to a wireless network. What am I missing?
     

    #37
  18. H1555689181191
    Cupcake May 24, 2019