81
Guide How to Install CM12 on the OnePlus One- Android Lollipop/5.0

  1. fgaurano
    Ice Cream Sandwich Feb 28, 2015


  2. pradeepmendu
    Eclair Feb 28, 2015


    Anamit117 likes this.
  3. keithnyc
    Marshmallow Moderator Feb 28, 2015

    keithnyc , Feb 28, 2015 :
    Dude.. Thank you so much for the guide. Unfortunately it's for the semi beginner..... What about the beginner beginner
    Seriously, thanks again but I'm convinced more than ever I will unfortunately need to stick with CM until the OPO team reconsider their decision and will make an installation tool to go with their new OS
     

  4. MarmiteX1
    Gingerbread Feb 28, 2015

    MarmiteX1 , Feb 28, 2015 :
    I have installed CM12(nightly). I used Titanium Backup Pro to backup all my apps(excluding system) before i flashed CM12. I tried to restore them and it complained about missing SU binary.

    I then installed SuperSu from the PlayStore and i was able to restore my app and data for apps i had backed up.

    I've also installed Oppo Camera port. Appears to be good!
     
    Last edited: Feb 28, 2015

    Anamit117 likes this.
  5. sergiodmc
    Cupcake Feb 28, 2015

    sergiodmc , Feb 28, 2015 :
    i wasnt able to do it. everything works till the point where i do the fastboot flash recovery recovery.img and it says "cant load file". Anyone else with this probleme?

    thanks
     

  6. debarshikundu
    Eclair Feb 28, 2015


  7. dylaneyo
    Gingerbread Feb 28, 2015


  8. metalerjf
    Gingerbread Feb 28, 2015

    metalerjf , Feb 28, 2015 :
    Excellent guide as an advice if you add screenshot it will be even more helpful for beginners :).... not my case but you know lol
     

    Anamit117 likes this.
  9. ElectronicsGeek
    Donut Feb 28, 2015

    ElectronicsGeek , Feb 28, 2015 :
    I ended up working that one out last night. Thanks for your help, anyway. I'm pleased to report it works very well :)
     

    Anamit117 likes this.
  10. aakash0606
    Honeycomb Feb 28, 2015

    aakash0606 , Feb 28, 2015 :
    Hey @Anamit117 , your instructions are great and bang on target. It's the best throughout the web. But I just have one question. I installed CM12 perfectly according to your instructions. But now I wish to go back to CM11S factory ROM. I have downloaded the factory zip file from the official page and tried the same instructions. TWRP recovery is showing "Failed" when I try flashing with or without the firmware update you have given in the instructions. Please help me out. I want to do it through TWRP recovery. It is easy that way. Thanks a ton.
     

  11. Brandonyee2002
    Cupcake Feb 28, 2015


  12. joost_vh
    Cupcake Feb 28, 2015

    joost_vh , Feb 28, 2015 :
    hi there , i have problems with TWRP; every time i boot OPO with volume down and power; i can sea TWRP menu but touchscreen doesn't work and after few seconds my phone reboots. any help?
     

  13. joost_vh
    Cupcake Feb 28, 2015


  14. benoitv98
    Cupcake Mar 1, 2015

    benoitv98 , Mar 1, 2015 :
    Thx stupid me :/
     

  15. AntMunny
    KitKat Mar 1, 2015

    AntMunny , Mar 1, 2015 :
    do you have the latest version? 2.8.5.1?


    2.8.4.0 didn't work and did exactly what you described
     

  16. RetroHardroc
    Gingerbread Mar 1, 2015

    RetroHardroc , Mar 1, 2015 :
    when I enter
    fastboot oem unlock
    it says it took .5 second to fish but when it boots up im nothing has been wiped
     

  17. dpgx81
    Honeycomb Mar 1, 2015

    dpgx81 , Mar 1, 2015 :
    Alright, even though my employer will be less than thrilled Monday morning when I need a new cert for our corp app, I went ahead and did this after much frustration with the latest CM11s. So far so good, I have no clue how much of a hit I'll take on battery, but I really like the changes with CM12. I grabbed the latest nightly that came out just minutes ago, seems fantastic so far. Very well written guide, and I'm a big fan of TWRP, I haven't really played with android roms in a while tbh, last time I did I used CWM, a lot has changed.
     

    Anamit117 likes this.
  18. rpyne
    Donut Mar 1, 2015


  19. MikeL422
    Donut Mar 1, 2015


    Anamit117 likes this.
  20. rpyne
    Donut Mar 1, 2015

    rpyne , Mar 1, 2015 :
    Sorry, user error, though strange. I had the SIM tray in upside down, but it is strange that it wouldn't show the IMEI without a functioning SIM.
     

    Anamit117 likes this.