56
[How To] Install OxygenOS 2.2.0 Update (Root/Non Root Users) Without Data Loss!!

  1. chethiya
    Cupcake Dec 13, 2015

    chethiya , Dec 13, 2015 :
    This is to cofrim 2.1.3-x update works smoothly. Few weeks back I tried 2.1.3 and experienced the lag specially during scrolling and typing. Then i rolled back to 2.1.2 using the nandroid backup and usimg it till now. Just followed the steps in here and got it working fine without deleting data. Experience nothing changed in responsiveness when compared to 2.1.2.
     

  2. Funk Wizard
    Moderator Moderator Dec 13, 2015

    Funk Wizard , Dec 13, 2015 :
    Glad it worked for you, enjoy
     

  3. chethiya
    Cupcake Dec 15, 2015

    chethiya , Dec 15, 2015 :
    Thanks for the guide.

    For the completeness sake I should mention that I own an E1001 (white) model. It fails to flash using twrp with singanature verification on. But works fine with signature verification disabled. I made sure md5 matches for the images.
     

    Funk Wizard likes this.
  4. Funk Wizard
    Moderator Moderator Dec 15, 2015

    Funk Wizard , Dec 15, 2015 :
    Thanks for your feedback
     

  5. qiaoyaming
    Cupcake Dec 15, 2015

    qiaoyaming , Dec 15, 2015 :
    Hi, I used the OP method to update to 2.1.3x on a non-rooted OPX. All went very well. After reboot, the system gave me two notifications: 1. SD card is available. 2.System update downloaded. I understand their meaning. But I need advice to get rid of these notifications at reboot. Also to delete the used update file to save space. How can I do this? Thank you.
     

  6. qiaoyaming
    Cupcake Dec 15, 2015

    qiaoyaming , Dec 15, 2015 :
    The 2nd problem is solved. I connected it to PC and deleted the update file in the folder .OnePlusOta. Afterwards, reboot doesn't show the 2nd notification. Still need help with the SD card notification.

    My phone, from new, the SD card was working fine. In fact, no other issue at all, apart from one: a notification for updating to 2.1.3-x. So, my updating is for the sake of get rid off notifications. Well, I ended up with a new notification :). Maybe I have to live with it.
    As the Sd card is meant to be working on any android smart phones, I can't see the point of notifying me that the SD is available.
     
    Last edited: Dec 15, 2015

  7. Funk Wizard
    Moderator Moderator Dec 16, 2015

    Funk Wizard , Dec 16, 2015 :
    I have not figured out a way block that notification yet, simply swipe away when you reboot
     

  8. ahmrupok
    Cupcake Dec 19, 2015

    ahmrupok , Dec 19, 2015 :
    hello...whenever i try to flash the update via stock recovery it says flashing failed.am on stock 2.1.2 UNROOTED.thank you
     

  9. Tiger918
    Cupcake Dec 19, 2015


    Funk Wizard likes this.
  10. Ryder161
    Cupcake Dec 23, 2015

    Ryder161 , Dec 23, 2015 :
    Can you not download this update from the system yet? New OPX user BTW lol
     

  11. Funk Wizard
    Moderator Moderator Dec 23, 2015

    Funk Wizard , Dec 23, 2015 :
    Yes u can.. Just wait it out
     

    Ryder161 likes this.
  12. Justfortoday
    Cupcake Dec 24, 2015

    Justfortoday , Dec 24, 2015 :
    Hail you Funk Wiz :rolleyes:

    However, I´ve followed your guide and got a boot loop due to the custom kernel [from blu_sp★rk r68] I wanted . I searched a bit and found out that (at least for me) I needed to insert an additional step between 8. & 9 which you may (or not) want to add?

    So for all of you wanting to flash [blu_sp★rk r68]´s kernel and getting stuck into boot loop after following your (otherwise) great guide try the following:

    8. Wipe Dalvik & Cache

    8.1. reboot freshly installed ROM in stock state and flash [blu_sp★rk r68] kernel zip AFTER this step.

    9. Flash SuperSU to maintain root & other mods like Xposed/Kernel etc

    10. Wipe Dalvik & Cache

    12. Reboot System



    You now should´nt be having any boot loops anymore :D
     

    Funk Wizard likes this.
  13. Funk Wizard
    Moderator Moderator Dec 25, 2015

    Funk Wizard , Dec 25, 2015 :
    If you run a custom kernel all you have to do is to dirty flash stock ROM first to overwrite the system partition and then flash the update, or you can also do a clean flash and then restore your data.
     

  14. kionq
    Cupcake Dec 26, 2015

    kionq , Dec 26, 2015 :
    Hi..
    i already update my OPX E1001 to Oxygen OS 2-1.3x
    then i got problem with the message / Hangout, when i touch the application, there's error (cannot write SMS) & google keyboard got error too, so i use swiftkey application
    any solution?
     

  15. Funk Wizard
    Moderator Moderator Dec 27, 2015

    Funk Wizard , Dec 27, 2015 :
    Clear data and cache for that app, stay with swiftkey I recommend that
     

  16. aiyoju
    Eclair Dec 28, 2015


  17. BiRooT
    Cupcake Dec 28, 2015


  18. moesteve1
    Eclair Dec 28, 2015

    moesteve1 , Dec 28, 2015 :
    I am having an issue that when trying to flash a full version or any to be exact, I get an error:
    E:Error executing updater binary in zip '/scard/OmePlusOxygen_14_OTA_003_all_201510241934.zip

    Have tried a load of files but non work. I did see that it says This Package is for "OnePlus" devices; this is a "". just before i get the error in TWRP v2.8.7.0

    I have tried flashing the recovery again but no luck... I wouldn't mind flashing back to stock recovery but finding it hard to find one that works....

    I have cleared the system, cache and davlik loads of times, reset factory settings, tried memory cards etc etc no luck...

    Anyone else got any ideas? Bit stuck.... thanks in advance
     

  19. moesteve1
    Eclair Dec 28, 2015

    moesteve1 , Dec 28, 2015 :
    Since writing this I have really mucked it up!!! I have wiped the system, so do not have well a system.... Anyway so tried to change my recovery again and now it is saying that the device isnt unlocked... and no matter how many times i try to unlock it and install SuperSU 2.46 or 2.52 it still says that is isnt locked... so tried adb sideload and now that is saying unauthorized and cant sideload! WTF! I have now a bricked phone and the Mrs isnt happy.... Any help please!!
     

  20. moesteve1
    Eclair Dec 28, 2015

    moesteve1 , Dec 28, 2015 :
    Ok fixed it..... i downloaded the stock rom from here then used TWRP to install an image rather than a zip. Once that worked I rebooted into stock recovery and installed the full package that was on my phone storage.