0
How to install viper4android fx ?

  1. archz2
    Gingerbread Jan 27, 2022

    archz2 , Jan 27, 2022 :
    I have Oneplus 9RT 5G which is rooted via latest magisk canary. I'm trying to install viper4 android fx

    I tried the process given here
    https://www.droidwin.com/fix-viper4android-not-working-with-selinux-enforcing/

    Everytime I start viper, it keeps asking me to install drivers. I install it and the phone reboots. After that I open the viper app, it asks for the same driver installation. I do it, and the phone reboots again. Then I repeat the same process but I can't get to viper app without seeing the driver installation notification.

    I have installed Audio Modification library via Magisk.

    How can I run viper successfully ?

     

    #1
  2. alexdiyakuzas
    Froyo Mar 27, 2022

    Best Answer
    alexdiyakuzas , Mar 27, 2022 :
    Hi,
    On my oneplus 9 pro I have viper4android and James DSP working.

    The procedure I followed:
    - install v4a FX modules, then the AML 4.1 module, then James DSP module
    - reboot
    - I open Viper, it prompts me to install the driver. Ok. The phone restarts
    - I go with a Root file explorer . /data/adb/modules/VIPER4AndroidFX. Edit post-fs-data.sh file replace everything with:

    #!/system/bin/sh
    # Kill audioserver PID if it was initialized already
    SERVERPID=$(pidof audioserver)
    [ "$SERVERPID" ] && kill $SERVERPID

    mount -o bind /vendor/etc/audio_effects.xml /odm/etc/audio_effects.xml

    magiskpolicy --live 'allow audioserver audioserver_tmpfs file { read write execute }'
    magiskpolicy --live 'allow audioserver system_file file { execmod }'
    magiskpolicy --live 'allow mediaserver mediaserver_tmpfs file { read write execute }'
    magiskpolicy --live 'allow mediaserver system_file file { execmod }'
    magiskpolicy --live 'allow audioserver unlabeled file { read write execute open getattr }'
    magiskpolicy --live 'allow hal_audio_default hal_audio_default process { execmem }'
    magiskpolicy --live 'allow hal_audio_default hal_audio_default_tmpfs file { execute }'
    magiskpolicy --live 'allow hal_audio_default audio_data_file dir { search }'
    magiskpolicy --live 'allow app app_data_file file { execute_no_trans }'
    magiskpolicy --live 'allow mtk_hal_audio mtk_hal_audio_tmpfs file { execute }'


    -to restart.
    -enable legacy mode in viper. And James DSP works.
     

    #4
    charmr and archz2 like this.
  3. RonanDjinnTetsu
    Froyo Mar 25, 2022

    RonanDjinnTetsu , Mar 25, 2022 :
    You don't. AFAIK, I haven't gotten it working nor has anyone successfully done so with any specific method. James DSP works fine, however. Viper did work with a bunch of steps on a11 op7 series, but not for op9 unfortunately.
     

    #2
    archz2 likes this.
  4. archz2
    Gingerbread Mar 27, 2022

    archz2 , Mar 27, 2022 :
    Okay. James DSP crashes immediately on startup on my phone.

    Let me know what all you have installed to make it run flawlessly on your device, like SElinux enforcing, and some audio modification libraries, etc.
     

    #3
  5. archz2
    Gingerbread Apr 1, 2022

    archz2 , via OnePlus 9RT , Apr 1, 2022 :
    This process sounds quite hopeful. Unfortunately since our devices our different, yours being 9 Pro and mine being 9RT, I don't have any idea whether you process is brick free or not or is universally compatible.
    Flashable TWRP recoveries aren't available for my device yet and I don't want to take any risk.
    Please share the exact version of Viper and James DSP that you're using (with their download links).
     

    #5
  6. archz2
    Gingerbread Apr 16, 2022


    #6
  7. weriwd
    Cupcake Apr 26, 2022

    weriwd , via OnePlus 9 Pro , Apr 26, 2022 :
    Hi, I have the same device as yours with the latest c47 update.

    Unfortunately, after I edit the file, each time when I open viper4android it asks me to install the drivers and reboot.
     

    #7
  8. charmr
    Cupcake Apr 27, 2022

    charmr , Apr 27, 2022 :
    @alexdiyakuzas thank you my friend! Your trick worked on my OP8T with new Android 12 update!
     

    #8
    archz2 likes this.
  9. archz2
    Gingerbread Apr 27, 2022

    archz2 , via OnePlus 9RT , Apr 27, 2022 :
    Have you installed the audio modification library? Also ensure that you have saved the file with the changes. I'm just guessing that there is some step you're either doing wrong or skipping.
    Share a screenshot of the version of Viper that you've installed. I'm using 2.7.2.1.
    Here's mine.
    1651077207700.jpg
     

    #9
  10. weriwd
    Cupcake Apr 27, 2022

    weriwd , via OnePlus 9 Pro , Apr 27, 2022 :
    I have exactly the same version of viper4android, but in addition i have added Dolby Atmos Magic Revision v2.2 - otherwise viper4android keeps asking to install the drivers.

    Unfortunately, i suspect that dolby atmos plugin is glitching my volume steps :/, also loudspeaker sounds awful even with all effects turned off(stock is much better).

    Do you have any other suggestions? 🤔
     

    #10
  11. archz2
    Gingerbread Apr 28, 2022

    archz2 , Apr 28, 2022 :
    I'm not sure as I never used Dolby Atmos on my phone, but there is a possibility that Dolby atmos magic is messing with your Viper.
    Maybe you can uninstall it and then go for viper installation? Do ensure that you're doing the steps exactly as mentioned in post number 4. He did these steps on Oneplus 9 pro. I did them on Oneplus 9RT. So the method is indeed working on both these models.

    Moreover, viper and JAMES DSP are more than enough for all the customizations of sound in your phone. You won't require dolby atmos then.
     

    #11