0
OxygenOS How to keep apps running in background? (SmartThings / Life360 in particular)

  1. Medxion007
    Donut Oct 25, 2018

    Medxion007 , Oct 25, 2018 :
    I use SmarttThings at home for automation. Part of that is using the app as a presence sensor for changing modes from Home to Away and vice-versa.

    Since I got my OP6, I've not been able to keep ST running in the background. Any push notifications that come from SmartThings do not come up unless I very recently launched the app.

    Similar type of issue with Life360... My location is updated in the app periodically, but not very quickly.

    I have a perimiter set about ~3 minutes away by car, and even so, I can sit in my driveway waiting for the system to disarm, before manually opening Life360 and then it updates my location and things happen immediately.

    I disabled battery optimization for both apps but still got the problem.

    Please help :).
     

    #1
  2. ngydat
    KitKat Oct 25, 2018

    ngydat , Oct 25, 2018 :
    the simplest way to do that is to lock the app in the multitask view
     

    #2
    Kytharsis likes this.
  3. Medxion007
    Donut Oct 25, 2018

    Medxion007 , Oct 25, 2018 :
    Also try that solution but no results. I still need to open the app and then the presence is detected :(.
     

    #3
  4. ngydat
    KitKat Oct 25, 2018

    ngydat , Oct 25, 2018 :
    1. Disable adaptative battery (settings -> battery -> adaptative battery)
    2. Make sure that the two toggles in Settings -> battery -> battery optimisation -> (3 dots on the top right) advanced optimisation are disabled.
     

    #4
    deangilvin likes this.
  5. hgroove4
    Cupcake Oct 28, 2018

  6. Medxion007
    Donut Oct 30, 2018


    #6
  7. W1542664136539
    Cupcake Nov 19, 2018


    #7
  8. Medxion007
    Donut Nov 20, 2018

    Medxion007 , Nov 20, 2018 :
    Let me explain:

    install the new smartthings app https://play.google.com/store/apps/details?id=com.samsung.android.oneconnect

    install the smartthings classic app https://play.google.com/store/apps/details?id=com.smartthings.android

    open the new smartthings app

    Tap on the Dashboard tab

    Tap the three dots in the top right

    Tap Settings

    Toggle ON the switch for Use location information

    If prompted, give SmartThings access to use your phone’s location services

    Tap the back button to exit

    open the smartthings classic app

    my home

    Under things you see now your phone’s name as a presence device

    open automation and create a new routine

    for example alarm active

    set turn off these lights if you got some

    set smart home monitor to: Armed (Away)

    change the mode to: Away

    Automatically perform “alarm active” when everyone leaves
    Wich? Select you’re phone presence

    After this make sure you lock both apps in you’re multitask screen


    When you use oneplus make sure you disable battery optimalisation for both apps

    Go to Settings

    Battery > Battery optimisation

    Find the app you want to keep awake all the time

    Tap on it and select “Don’t optimize” option

    Tap “Done” to save
     

    #8
    W1542664136539 likes this.
  9. W1542664136539
    Cupcake Nov 23, 2018

    W1542664136539 , Nov 23, 2018 :
    I might've found another solution. go to system, developer options. standby apps and change the one for smartthings to working Set. been working for me for the last week or so.
     

    #9
  10. sonith_h
    Cupcake Sep 3, 2019

    sonith_h , Sep 3, 2019 :
     

    #10
  11. sonith_h
    Cupcake Sep 3, 2019

    sonith_h , Sep 3, 2019 :
    Hi.. I'm facing same problem with life360. Could you solve the problem?
     

    #11
  12. Kytharsis
    Marshmallow Sep 3, 2019

    Kytharsis , Sep 3, 2019 :
    Did you read the post at all?
     

    #12
  13. sonith_h
    Cupcake Sep 3, 2019

    sonith_h , Sep 3, 2019 :
    What do you mean? Yes. I'm asking how to solve the life360 problem which has stopped working in the background even though I have switched off battery optimisation, I have switched off adaptive battery, I have given all permissions, I have given unrestricted data access. Now what else has to be done? In the above I only see a solution for smart things app.
     

    #13