0

How to unlock tmobile 6T when oem unlocking greyed out and fastboot status is locked

  1. darklynx Cupcake Jun 1, 2019

    darklynx, Jun 1, 2019 :
    So i recently purchased a oneplus 6T from someone else, and they claimed it was flashed to the international version and is fully unlocked. After i received it, the bootloader is locked and it wont accept my metropcs sim (which worked find on my OP3), and funny enough metropcs is tmobile, but the sim was made prior to the buyout.

    What I assume happened was, it *was* unlocked, but then they did a factory reset (instead of wiping data in twrp or re-flashing international rom) and it put it back to locked status, but the phone still thinks its unlocked or something.

    https://support.oneplus.com/app/ans...-bootloader-for-oneplus-6t-(t-mobile-edition)

    I tried this, but the "OEM unlock" in the developer options is greyed out and can not be changed. In fastboot mode the device says "locked". When i try to do "fastboot oem unlock", it says "Failed (remote: "flashing unlocked is not allowed)". When I try to do "fastboot oem get_unlock_code" it just says unknown command or something.

    I then turned to this: https://forum.xda-developers.com/oneplus-6t/how-to/t-mobile-6t-to-international-t3888307

    And that seems to have "worked", but the device is still locked, and still cant be unlocked.

    Any help would be greatly appreciated.

    EDIT: *SOLVED*

    Cant use the 9.0.13 msmdownloadtool. You HAVE to use 9.0.11 or else you cant unlock the tmobile version.
     
    Last edited: Jun 1, 2019

    #1
  2. ironass KitKat Jun 1, 2019

    ironass, Jun 1, 2019 :
    Since you have the T-Mobile (USA) carrier minority variant of the OnePlus 6T, it might be better if you posted on the T-Mobile (USA) forum as there are all sorts of carrier implications and firmware attached to this model.

    If you hang fire for a short while, I will ask the kind, helpful and considerate Mods on here to move your post.
     

    #2
  3. noquarter French POC Assistant Head Moderator Jun 1, 2019


    #3
    ironass likes this.
  4. darklynx Cupcake Jun 1, 2019

    darklynx, Jun 1, 2019 :
    I solved the issue. I was using the OS9.0.13 version of the MSMTool. Apparently ONLY the 9.0.11 (or maybe earlier) tool will work because this exploit was patched I'm assuming.

    I now have an unlocked phone.
     

    #4
    ironass likes this.