2
I am consistently facing this issue on my new OnePlus 7 pro

  1. Atharv Patawar
    Cupcake May 25, 2019

    Atharv Patawar , May 25, 2019 :
    Usually my phone is connected to my Samsung Gear S3 Frontier, so when I get a call I have three options to choose from to speak on the call i.e speaker, phone and gear S3. When I receive the call although it is set on phone by default I hear the voice of the person through the speaker and then when I toggle on speaker and again toggle on phone only then can I hear the voice of the person through the earpiece and this is really annoying because till I do this procedure, the people around me hear to what the person on the phone is saying.
    But I do not face this issue when my gear S3 is not connected to my phone.
    Please fix my issue as soon as possible.
     

    #1
    creepa07 and mustafa4ever89 like this.
  2. Atharv Patawar
    Cupcake May 25, 2019


    #2
  3. creepa07
    Cupcake May 25, 2019

    creepa07 , May 25, 2019 :
    I am also having this problem, I have the new galaxy watch there are multiple threads on this
     

    #3
    Atharv Patawar likes this.
  4. mustafa4ever89
    Froyo May 25, 2019

    mustafa4ever89 , May 25, 2019 :
    I have the same combo, s3 frontier and OP7 Pro and I've experienced this problem intermittently as well. I have not tried it with the watch disconnected but I will test that out today. That's 3 bugs I'm dealing with.... so far
    1) Ghost touches
    2) Ambient display not working in dimly lit conditions
    3) Call audio playing through speakerphone and not the earpiece
     

    #4
  5. mustafa4ever89
    Froyo May 26, 2019

    mustafa4ever89 , May 26, 2019 :
    So I tested this with my watch disconnected and the call audio works as expected, earpiece by default with speaker option available as well.

    But when my watch is connected via Bluetooth and I take a phone call on my phone, the audio goes to speakerphone even though it says phone on the screen. I have to toggle to speakerphone and then back to phone for the audio to come through the earpiece. The phone does display the 3rd option which is the Bluetooth watch in the call audio settings.
     

    #5
    Atharv Patawar likes this.
  6. Atharv Patawar
    Cupcake May 26, 2019

    Atharv Patawar , May 26, 2019 :
    This is exactly the same problem I am facing.
     

    #6
  7. prfraczek
    Honeycomb May 26, 2019


    #7
  8. mustafa4ever89
    Froyo May 26, 2019

    mustafa4ever89 , May 26, 2019 :
    That's a good temporary fix but occasionally I do want to have the ability to switch calls to my watch when driving. The bug still persists if audio is enabled for the watch Bluetooth device.
     

    #8
  9. Atharv Patawar
    Cupcake May 27, 2019

    Atharv Patawar , May 27, 2019 :
    Even the recent update has not fixed this bug.
     

    #9