1
I want to be able to disable the capacitive home key button

  1. scott62185
    Froyo Aug 24, 2014

    scott62185 , Aug 24, 2014 :
    I'm loving CM11S-so fast and fluid, but I am not using either the on-screen nav bar nor the capacitive keys (I'm using LMT launcher, which is indispensable with this big beautiful phone, IMO). Problem I have is when I'm typing on the keyboard I often inadvertently hit the capacitive home key. And it cannot be disabled. The back and menu keys can be by assigning "none" to their short press but not the home key. I would love to have this option. I thought about with Tasker or Xposed but can't see how to do it with either of those.

    BTW, I am rooted and you must be rooted in order to use LMT. I HIGHLY recommend everyone check out LMT launcher as it enables you to not have to reach down to bottom of phones to control it (for one-handed use).

    http://forum.xda-developers.com/showthread.php?t=1330150
     

    #1
    pleymor likes this.
  2. Mihail_Ko
    Jelly Bean Aug 24, 2014

    Mihail_Ko , Aug 24, 2014 :
    XD
    I have a big hands, no issue with one hand use for me.;)
    XD
     

    #2
    DRCH likes this.
  3. DRCH
    Marshmallow Aug 24, 2014

    DRCH , Aug 24, 2014 :
    Same here ;)
     

    #3
  4. scott62185
    Froyo Aug 24, 2014


    #4
  5. Mihail_Ko
    Jelly Bean Aug 24, 2014

  6. B4kken
    Lollipop Aug 24, 2014

    B4kken , Aug 24, 2014 :
    I guess you could turn on software keys, put it in expanded desktop and set it up so it doesn't hide the statusbar. That should work
     

    #6
  7. ghettopops
    Honeycomb Aug 24, 2014


    #7
  8. B4kken
    Lollipop Aug 24, 2014

    B4kken , Aug 24, 2014 :
    Looks like it's pretty much the same
     

    #8
  9. rainbowhunt
    Gingerbread Aug 24, 2014

    rainbowhunt , Aug 24, 2014 :
    Same here my man
     

    #9
    scott62185 likes this.
  10. nem3sis
    Jelly Bean Aug 24, 2014


    #10
  11. scott62185
    Froyo Aug 24, 2014

    scott62185 , Aug 24, 2014 :
    PA pie is good but LMT seems to work the most fluidly to me. But yeah, both are excellent.
     

    #11
    nem3sis likes this.
  12. kolyan2k
    Gingerbread Nov 11, 2014

    kolyan2k , Nov 11, 2014 :
    Using Root Explorer (or CM file manager w/ root), navigate to System > usr > keylayout, and open Generic.kl and put "#" before those lines

    key 139 MENU VIRTUAL
    key 102 HOME VIRTUAL
    key 158 BACK VIRTUAL
    key 217 SEARCH VIRTUAL

    Maybe 172 too
     
    Last edited: Nov 12, 2014

    #12
  13. smrtphn
    Ice Cream Sandwich Nov 11, 2014


    #13
  14. Iseek1
    KitKat Nov 11, 2014

    Iseek1 , Nov 11, 2014 :
    where, in 38R, or 44S ?
     

    #14
  15. smrtphn
    Ice Cream Sandwich Nov 11, 2014

    smrtphn , Nov 11, 2014 :
    38r under settings>buttons>enable on screen nav bar AND DISABLE HARDWARE BUTTONS
     

    #15
  16. Iseek1
    KitKat Nov 11, 2014

    Iseek1 , Nov 11, 2014 :
    Thanks, forgot about that.
     

    #16
  17. kolyan2k
    Gingerbread Nov 12, 2014

    kolyan2k , Nov 12, 2014 :
    Disabling hardware buttons automatically enables software ones which are very annoying even in expended desktop, that's why you either need xposed module or just edit system file
     

    #17
  18. bigtodd
    Cupcake Apr 2, 2015

    bigtodd , Apr 2, 2015 :
    Thanks smrtphn. I also kept hitting the home button in place of the space bar. Problem is now solved.
     

    #18