Inaccurate GPS?

  1. bnhede
    Donut May 9, 2015

    bnhede , May 9, 2015 :
    I have given upon cm12 unfortunately. Lost my patience. Manually flashed oxygen os on the phone. Initially the GPS was not detecting as usual . then installed the app GPS status.
    Link below...


    Then the GPS started holding correctly in o2 os . but still the accuracy is bad if I put it in pouch. Can't keep running with large phone in hand.

    Could anyone test the app on cm12 and provide feedback ?

    There are gps
    Issue on lollipop in general. Below is a huge thread on it.


    But I have not seen it recur on o2 os since I "fixed" it using the app. Maybe the power drain in o2 is not that bad.
    Will keep tabs on the issue.
    For now its bye bye cm12.
    If problem recurs it will be back to KitKat.

  2. Mikebike125
    Cupcake May 13, 2015

    Mikebike125 , May 13, 2015 :
    I am having the problem where the GPS just keeps spinning and spinning and cannot locate me in 12.0. With this happening, I cannot use my Map My Ride or Map My Fitness apps. This is BOGUS!! This must be fixed!!!!

  3. mckenn
    Froyo May 13, 2015

  4. Mikebike125
    Cupcake May 14, 2015

    Mikebike125 , May 14, 2015 :
    I am using High Accuracy. It just keeps spinning. When I had 11.0, it would immediately find my position. I mean IMMEDIATELY. Now with 12.0, it is lost. Is there anything else I can do?

  5. bnhede
    Donut May 15, 2015

  6. mazlum1991
    Gingerbread May 15, 2015

  7. vivzek
    Eclair May 15, 2015

    vivzek , May 15, 2015 :
    Google maps shows wrong gps location, but Here maps is showing proper location! I don't know what to deduce of this.

  8. Toon10
    Ice Cream Sandwich Jun 12, 2015

  9. beltway
    Gingerbread Jun 13, 2015

    beltway , Jun 13, 2015 :
    Pretty sure it's a GPS sensitivity problem with CM12, similar to the cellphone radios loss of sensitivity on CM12. I'm hoping CM12.1 will fix these (and other) issues, but I haven't seen much at all to inspire confidence in Cyanogen or Google with Lollipop.

    Problems like this have also been reported even with stock Android devices. Maybe Lollipop reduced power consumption of the cell radios and GPS trying to save battery?
    Last edited: Jun 13, 2015

  10. Toon10
    Ice Cream Sandwich Jun 13, 2015

    Toon10 , Jun 13, 2015 :
    Found the solution , be sure that you give play services acces to your location . Fixed the problem for me.


    david.s and Castro2 like this.
  11. Bizzo
    Donut Jun 13, 2015

    Bizzo , Jun 13, 2015 :
    me too, with runtastic i had a lot of problem. Now i'm on cm12.1 and i'll tell u later if there are better news :)

  12. Castro2
    Cupcake Jun 24, 2015

    Castro2 , Jun 24, 2015 :
    Aleluya!!! It solved my problem!

  13. fastoy
    Cupcake Jul 4, 2015

    fastoy , Jul 4, 2015 :
    How do I give Play Services access to my location?
    Last edited: Jul 4, 2015

  14. ariefun123
    Honeycomb Jul 4, 2015

    ariefun123 , Jul 4, 2015 :
    Yes, when I tried google maps to go somewhere the arrow that indicates what direction I'm going to was not right and it made me lost a couple of times...

  15. CristianAS
    Froyo Jul 15, 2015

    CristianAS , Jul 15, 2015 :
    Right when i was wondering if i'm the only one with this problem.
    Even if i'm one of the few that didn't made the update to CM12 because of the bugs, i still have this problem on CM11 stock. I tried Google Maps, Citymapper, Sygic thinking it might be an App issue. It's not, the GPS is very inaccurate sometimes, it locks the location very slow and sometimes doesn't find my location at all.
    With my old Optimus G or Nexus 4 i didn't had this problem, not even once.
    Since the bug exists on both CM11 and CM12, i think it could be a phone issue.

  16. thegios
    Gingerbread Jul 21, 2015

  17. david.s
    Lollipop Jul 21, 2015

    david.s , Jul 21, 2015 :
    Thank you so much!!!! :D :D

  18. Hamade
    Honeycomb Jul 21, 2015

    Hamade , Jul 21, 2015 :
    Had similar GPS issues and regular Google maps crashes when I used to change Google play services permissions in the privacy guard, I gave up on doing that eventually as I use Google maps in regular basis.

  19. F_Thiago_Garcêz_NLQg
    Donut Feb 20, 2017

  20. v8mirage
    Cupcake Feb 24, 2017

    v8mirage , Feb 24, 2017 :
    Hi all,

    The metal bumper case has been the root cause of my op3 and op3t GPS inaccurate issue.

    Both phones were suffering GPS issues described by many here and both works fine after removing the case.